Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

User kann nur Mails empfangen ?!?!?!?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

User kann nur Mails empfangen ?!?!?!?

Beitrag von ArdRi »

Hoi Hoi
Ich bin´s wieder :D

So, habe es fast geschafft, einen Mailserver auf die Beine zu stellen.
Jetzt habe ich nur ein Problem. Ich als Root kann eMails verschicken und empfangen.
Die User auf meiner Maschine können Mails empfangen aber nicht mehr verschicken :(
Dann bekoomen Sie folgende Meldung

Code: Alles auswählen

Fehler beim Senden der Nachricht. Der Mailserver antwortete: <p.marpe@buw.com>: Relay access denied. Bitte überprüfen Sie, ob Ihre E-Malil Adresse in den Konteneinstellungen stimmt und wiederholen Sie den Vorgang
Diese Konto ist aber genauso eingerichtet wie das vom root (und da geht ja alles)

Der Server benutzt Postfix unter Suse 9.0. Als Mail Client benutze ich Thunderbird.
Was habe ich falsch gemacht ????
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

Beitrag von Desti »

Schau mal bitte wie der eingerichtete Gruppe von posfix heisst. Es sollte eigentlich postdrop sein.

Folgende Dateien/Ordner der Gruppe postdrop als Owner zuweisen:

1. /var/spool/postfix/public
2. /var/spool/postfix/maildrop
3. /usr/sbin/postdrop
4. /usr/sbin/postqueue

Machs am besten über KDE, ist dort Windows like. Rechte Maustaste auf ordner bzw. datei , Berechtigung uns postdrop als Gruppe.
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

Beitrag von ArdRi »

Nachtrag:

Habe noch etwas.
Der User kann die eMail nicht an p.marpe@buw.com (meine Firmenadresse) verschicken. Wenn ich sie aber an thrasher@gti-fans.de verschicke, geht das.
Heisst also innerhalb der Domain gti-fans.de kann ich Mails verschicken aber wenn es eine andere Domain ist bekomme ich halt die oben beschriebende Fehlermeldung.
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

Beitrag von Desti »

main und master.cf pls ! Aber bitte ohne die Standartkommentare in der main, aus der master reicht die Tabelle.
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

Beitrag von ArdRi »

@Desti

Hab Deine Thread garnet gesehen.
Ich habe gerade mal nachgeschaut. Ich habe garkeine Gruppe Postdrop. Bei heisst die Gruppe Maildrop. Und alles Ordner und Dateien die Du mir genannt hast gehören zu der Gruppe Maildrop

Da habe mich mir etwas mit angetan.....................ganz schön kniffelig............
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

Beitrag von ArdRi »

Ja, Keine Thema

Die main.cf

Code: Alles auswählen

readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = gti-fans.de
program_directory = /usr/lib/postfix
inet_interfaces = 127.0.0.1 62.75.138.17
masquerade_domains = no
mydestination = $myhostname, localhost.$mydomain
defer_transports = 
disable_dns_lookups = no
content_filter = 
mailbox_command = 
mailbox_transport = 
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions = 
smtpd_helo_required = no
smtpd_helo_restrictions = 
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000

#SMTP mit SASL-Authentifiction verwenden
smtp_sasl_auth_enable = yes
#Die Passwörter stehen in der Datei /etc/postfix/smtp_auth
smtp_sasl_password_maps = hash:/etc/postfix/smtp_auth
#Zusatz-Optionen: kein anonyme-Anmeldung verwenden
smtp_sasl_security_options = noanonymous
#Den Relayhost (der Server der unsere Emails annehmen soll)
#relayhost = auth.mail.gmx.de
relayhost = auth.mail.gti-fans.de
die master.cf

Code: Alles auswählen

# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp	  inet	n	-	n	-	-	smtpd
#smtps	  inet	n	-	n	-	-	smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission	inet	n	-	n	-	-	smtpd
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628	  inet	n	-	n	-	-	qmqpd
pickup	  fifo	n	-	n	60	1	pickup
cleanup	  unix	n	-	n	-	0	cleanup
qmgr	  fifo	n	-	n	300	1	qmgr
#qmgr	  fifo	n	-	n	300	1	nqmgr
#tlsmgr   fifo  -       -       n       300     1       tlsmgr
rewrite	  unix	-	-	n	-	-	trivial-rewrite
bounce	  unix	-	-	n	-	0	bounce
defer	  unix	-	-	n	-	0	bounce
flush	  unix	n	-	n	1000?	0	flush
proxymap  unix	-	-	n	-	-	proxymap
smtp	  unix	-	-	n	-	-	smtp
relay	  unix	-	-	n	-	-	smtp
#	-o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix	n	-	n	-	-	showq
error     unix	-	-	n	-	-	error
local	  unix	-	n	n	-	-	local
virtual	  unix	-	n	n	-	-	virtual
lmtp	  unix	-	-	n	-	-	lmtp
#localhost:10025 inet	n	-	n	-	-	smtpd -o content_filter=
#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# maildrop. See the Postfix MAILDROP_README file for details.
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus	  unix	-	n	n	-	-	pipe
  user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp	  unix	-	n	n	-	-	pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
vscan     unix  -       n       n       -       10       pipe
  user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}
procmail  unix  -       n       n       -       -       pipe
  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
Sagt mal, wie kopiert Ihr euere Configs. Ich geh ja über putty auf meinen Root, aber das lassen sich die configs so gut kopieren.
Ich zieh, ganz noobie, die configs per FTP auf meinen Rechner^^

Bin ja noch ein Linux Noobie. Muss noch viel lesen :D
Zuletzt geändert von ArdRi am 19. Jan 2005, 12:20, insgesamt 1-mal geändert.
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

Beitrag von Desti »

Achso, und bitte noch nen Auszug aus der /var/log/mail, damit wir sehen was genau schiefgeht. Am besten wenn grad ne mail gesendet und abgeholt werden..



Wie ichs mach, mit copy paste ^^ Text markieren (KDE) und mausrad drücken.
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

Beitrag von ArdRi »

Da werde ich mal schauen.
Auf dem Root habe ich kein KDE :(
Von der Arbeit greife ich mit putty auf den root. Und habe ich halt nur Console :(
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

Beitrag von ArdRi »

Öhhhhhhhhhhhhhhhhhh, ich habe garkeine Logdatei von Mail.

Was nu ????
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

Beitrag von Desti »

hmm, eigentlich !müsste! dort eine Log sein. Denn es läuft ja ein pop3 Daemon für postfix. Such mal am besten nach "mail" , eigentlich sollte sich die Datei in /var/log/ befinden.

Ausserdem probier erstmal in der main.cf den punkt

inet_interfaces = ALL zu setzten. Kann sein das hier die Mail abgewürgt wird.
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

Beitrag von ArdRi »

Habe ich gemacht. Kein Erfolg.

Ich denk mal, ich habe einen Fehler gemacht. Die Mails wollen einfach die Domain nicht verlassen.
Denn ich mit z.B. x1@gti-fans.de zu x2@gti-fans.de ganz normal senden und enpfangen.
Aber wenn ich x1@gti-fans.de zu user@buw.com schicken möchte geht das nicht.
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

Beitrag von Desti »

okay, also .

als 1. würde ich testen ob überhaupt ein pop3 Daemon rennt.

netstat -alnp | grep 25
-> Was kommt raus ?

telnet IP(oder localhost) 25

Bei "connection refused" , ist kein pop3 Daemon aktiv. Andernfalls rennt einer.

Falls er nicht läuft, installier dir den qpopper pop3 Daemon.
/etc/xinetd.d/ qpopper editieren
und disable = no setzten.

Spätestens dann solltest du die Logdatei mail in /var/log/ haben.

greetz Desti
Benutzeravatar
ArdRi
Member
Member
Beiträge: 94
Registriert: 6. Jan 2005, 11:45
Wohnort: c:/Essen/45133/Bredeney
Kontaktdaten:

Beitrag von ArdRi »

Also, wenn ich den Befehle eingebe.................kommt jenes

Code: Alles auswählen

vs138017:/etc/postfix # netstat -alnp | grep 25
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      -
unix  10     [ ]         DGRAM                    1504028625 20930/syslogd       /dev/log
Habe Datei so eingerichtet wie Du es gesagt hast. Muss ich noch etwas machen damit der die Einstellung übernimmt (restart oder so) ???
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

Beitrag von Desti »

ja postfix restart mit ./rcpostfix reload

Dann installier mal qpopper

yast -i qpopper


etc/xinetd.d/ qpopper editieren
und disable = no setzten.
Dann

/etc/inetd.conf editieren

und nach "pop3" durchsuchen, und die # entferen. Speichern neustarten.
Gesperrt