Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] SapGUI?

Moderator: Moderatoren

Antworten
Benutzeravatar
nbkr
Guru
Guru
Beiträge: 2857
Registriert: 10. Jul 2004, 15:47

[solved] SapGUI?

Beitrag von nbkr »

Hallo,

ich versuche gerade die SapGUI ans laufen zu bekommen, aber irgendwie scheitert es an den benötigten Libs. Jedes mal wenn ich versuche mich zum Server zu verbinden stürzt die GUI ab mit der Fehlermeldung:

Code: Alles auswählen

***
18.01. 16:14:30.912 ERROR: Cannot load shared library 'JPlatin' or some dependend
libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory
***
Die beiden genannten Dateien sind installiert und ich hab schon versucht das Problem zu lösen in dem ich symlinks auf die Dateien in /usr/lib und /lib kopiert habe. Ohne Erfolg.

Ich bin für jeden Vorschlag dankbar!
Zuletzt geändert von nbkr am 19. Jan 2005, 10:20, insgesamt 2-mal geändert.
Kann gar nicht sein, ich bin gefürchtet Wald aus, Wald ein.
Benutzeravatar
nbkr
Guru
Guru
Beiträge: 2857
Registriert: 10. Jul 2004, 15:47

Beitrag von nbkr »

Habs hinbekommen! Die angemeckerten Dateien sind in Wahrheit nicht 2 Dateien sondern nur eine. Es gibt also tatsächlich eine Datei:
"libstdc++-libc6.2-2.so.3" die exakt so heißt. Ich bin davon augegangen, dass die SapGUI zwei Dateien haben will "libstdc++" und "libc6.2-2.so.3".

Diese "2 in 1" Bibliothek gibts sogar bei debian.org und zwar hier:
http://packages.debian.org/stable/base/ ... 0-glibc2.2

Ich hab dann noch /usr/lib in $PATH aufgenommen (ich weiß nicht ob dieser Schritt nötig war) und schon gehts!
Kann gar nicht sein, ich bin gefürchtet Wald aus, Wald ein.
Antworten