Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SuSE 9.2 und USB-Sticks

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
as3jg
Newbie
Newbie
Beiträge: 9
Registriert: 28. Feb 2004, 22:13

SuSE 9.2 und USB-Sticks

Beitrag von as3jg »

Hallo Leute,

mein SuSE 9.2 hängt sich auf, sobald ich einen USB-Speicherstick anschließe. Ich kann ihn zwar im Arbeitsplatz noch sehen und öffnen, aber nach ein paar Sekunden hängt die Kiste.

Passiert sowohl auf meinem Fujitsu/Siemens Scaleo T als auch auf meinem Schlepptop Acer Aspire 1357LMi

as3jg
Fragen, nichts als Fragen...
Benutzeravatar
Dakuan
Hacker
Hacker
Beiträge: 282
Registriert: 30. Jul 2004, 09:46
Wohnort: Hamburg

Beitrag von Dakuan »

...aber nach ein paar Sekunden hängt die Kiste.
Den hatten wir schon. Wahrscheinlich sind da mehr als 158 Dateien drauf. Der Absturz passiert wahrscheinlich beim erzeugen der Vorschau. Mit der Konsole bzw. mc sollte es gehen.
Ließ das mal: http://www.linux-club.de/viewtopic.php?t=22194

Dakuan
Es ist zwar schon alles gesagt, aber eben noch nicht von jedem.
na-cx
Hacker
Hacker
Beiträge: 493
Registriert: 18. Mai 2004, 20:00
Wohnort: Syke

Beitrag von na-cx »

Bei genauerer Betrachtung des Problems stelle ich fest, das dieses Problem zur Kategorie USB gehört.
Schau mal dort rein. Die Lösungen stehen ganz oben!
CU
Christian

Bild
as3jg
Newbie
Newbie
Beiträge: 9
Registriert: 28. Feb 2004, 22:13

Beitrag von as3jg »

Danke,

und, ja, es sind mehr als 158 Dateien drauf.

as3jg
Fragen, nichts als Fragen...
Benutzeravatar
spunti
Hacker
Hacker
Beiträge: 598
Registriert: 6. Mai 2004, 10:49

Beitrag von spunti »

Es kommt auch auf den Stick an. Einige sind offenbar problematischer als andere. Notfalls Knoppix verwenden, das scheint besser klarzukommen als Suse.

spunti
Benutzeravatar
Dakuan
Hacker
Hacker
Beiträge: 282
Registriert: 30. Jul 2004, 09:46
Wohnort: Hamburg

Beitrag von Dakuan »

Ich denke das hängt nur von der Anzahl der Dateien ab, evtl. auch noch vom Dateisystem.
Leider hatte ich vorhin den falschen Link gepostet. Richtig ist dieser:
http://www.linux-club.de/viewtopic.php?t=20735
Ich habe das Problem inzwischen dadurch gemildert, dass ich in der Datei "/etc/sysconfig/hotplug" den Wert
HOTPLUG_MOUNT_TYPE von "subfs" auf "manual" geändert habe. Dadurch wird automatisch eine Desktopverknüpfung erstellt. Umount muß manuell durch rechtsklick und lokales menü erfolgen.
Nach der Änderung scheint es übrigens nicht zu reichen, das Hotplugsystem neu zu starten. Es hat bei mir nur rumgesponnen, erst nach einem reboot ging alles richtig.
Habe seitdem keine ernsthaften Probleme mehr mit Hotplug.
Dakuan
Es ist zwar schon alles gesagt, aber eben noch nicht von jedem.
as3jg
Newbie
Newbie
Beiträge: 9
Registriert: 28. Feb 2004, 22:13

Beitrag von as3jg »

Danke,

nachdem ich alle Ordner unter Windows gezippt hatte, faktisch also nur noch ca 15 Files auf dem Stick waren, lief er auch wieder under SuSE 9.2.

as3jg
Fragen, nichts als Fragen...
as3jg
Newbie
Newbie
Beiträge: 9
Registriert: 28. Feb 2004, 22:13

Beitrag von as3jg »

Ok, ich habs jetzt mal gewagt und KDE geupdatet.

Das Kontrollzentrum zeigt an, daß hier jetzt KDE 3.3.2 Level "a" läuft, aber trotzdem hängt sich die Kiste auf, wenn ich den USB Stick einstecke.

Hat noch jemand eine Idee?

as3jg
Fragen, nichts als Fragen...
Benutzeravatar
Dakuan
Hacker
Hacker
Beiträge: 282
Registriert: 30. Jul 2004, 09:46
Wohnort: Hamburg

Beitrag von Dakuan »

Also, ich habe unten aufgeführet Änderungen vorgenommen und kann damit leben, ohne vollständig auf hotplug verzichtzen zu müssen.

Code: Alles auswählen

#/etc/sysconfig/hotplug:
...
## Type:           list(yes,manual,no)
## Default:        no
#
# use the method described in HOTPLUG_MOUNT_TYPE for hotplugged devices?
#
#HOTPLUG_DO_MOUNT=yes
HOTPLUG_DO_MOUNT=manual
...
## Type:           list(subfs,fstab)
## Default:        subfs
#
# ...
# If HOTPLUG_DO_MOUNT is set to 'manual' only the fstab entry is generated and
# the user needs to manually mount the device.
#
#HOTPLUG_MOUNT_TYPE="subfs"
HOTPLUG_MOUNT_TYPE="fstab"
...
Dakuan
Es ist zwar schon alles gesagt, aber eben noch nicht von jedem.
Antworten