Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Fehler bei Start von SuSEfirewall2

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Rolando
Newbie
Newbie
Beiträge: 8
Registriert: 13. Jan 2005, 01:22

Fehler bei Start von SuSEfirewall2

Beitrag von Rolando »

Hallo.

Wenn ich "SuSEfirewall2 start" ausführe, bekomme ich folgende Fehlermeldung:

WARNING: Error inserting ipfwadm (/lib/modules/2.6.8-24-default/kernel/net/ipv4/netfilter/ipfwadm.ko): Device or resource busy
SuSEfirewall2: Firewall rules successfully set from /etc/sysconfig/SuSEfirewall2

Woran kann das liegen? Die Firewall läuft anscheinend trotzdem.


Und ich schaffs einfach nicht, den Zugriff von Windows-Clients auf den Samba-Server zu ermöglichen (bei deaktivierter Firewall klappts).

Hab eigentlich alle Ports freigeschalten:
FW_SERVICES_EXT_TCP="http https microsoft-ds netbios-dgm netbios-ns netbios-ssn ssh 111 135 161"
FW_SERVICES_EXT_UDP="111 135 137 138 139 161"
Masquerading ist deaktiviert.

Wenn kann mir weiterhelfen?

Viele Grüße
Rolando :roll:
gaw
Hacker
Hacker
Beiträge: 464
Registriert: 28. Sep 2004, 16:33

Beitrag von gaw »

ipwadm ist ein Tool für die 1.2 und 2.0 Kernel, was macht das auf deinem Rechner?


mfG
gaw
Rolando
Newbie
Newbie
Beiträge: 8
Registriert: 13. Jan 2005, 01:22

Beitrag von Rolando »

keine Ahnung. Hat wohl Suse installiert, ich wars nicht.

Wo kann ich des rausschmeissen?
gaw
Hacker
Hacker
Beiträge: 464
Registriert: 28. Sep 2004, 16:33

Beitrag von gaw »

Eigentlich ist das keine Option der Firewall sondern ein zu installierendes Programm dass zudem eine entsprechende Kerneloption benötigt. Falls du nicht selbst am Kernel rumgebastelt hast kann es auch an Fehlern an der Distribution liegen, ich würde mal schauen ob entprechende Hotfix-Pakete auf den SuSE-Servern zum Download bereit liegen.

Aber so wie es aussieht gibt das Skript nur die Fehlermeldung aus und führt iptables Regeln durch. Gib einfach als Root mal iptables -L aus. Dann siehst du ob deine Regeln aktiv sind.

Während die Firewall aktiv ist hilft auch ein X-Terminal (xterm, konsole etc. ) zu öffnen und ein tail -f /var/log/messages einzugeben. Der Cursor bleibt nach Ausgabe in der Datei hängen und wartet dass jemand eine neue Zeile eingebit die er dann sofort anzeigt.

Auch damit kannst du sehen ob und wenn welche Ports geblockt werden.



mfG
gaw
MSB
Newbie
Newbie
Beiträge: 6
Registriert: 5. Jan 2005, 01:14

Re: Fehler bei Start von SuSEfirewall2

Beitrag von MSB »

Rolando hat geschrieben: Hab eigentlich alle Ports freigeschalten:
FW_SERVICES_EXT_TCP="http https microsoft-ds netbios-dgm netbios-ns netbios-ssn ssh 111 135 161"
FW_SERVICES_EXT_UDP="111 135 137 138 139 161"
Masquerading ist deaktiviert.
Ich kenne jetzt den Rest deiner Konfiguration nicht, aber *_EXT_* kennzeichnet immer Anfragen von dem device das unter FW_DEV_EXT="ppp0" (im Normalfall also Internet), da ich aber vermute das deine Samba-Anfragen von dem device kommen welches unter FW_DEV_INT="eth0" steht kommen, musst du dieses auch unter *_INT_* eintragen.

Mfg
Manuel
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

...und von extern sperren, also die Einträge dort rausnehmen.
Weils besser ist.

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
Rolando
Newbie
Newbie
Beiträge: 8
Registriert: 13. Jan 2005, 01:22

Beitrag von Rolando »

des war n guter tipp. jetzt gehts.

Macht es Sinn, Masquerading zu aktivieren, wenn der Server nur als Samba-Server fungiert? DSL läuft über Hardware-Router mit eigener Firewall.
Antworten