Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SUSE 9 - LAN Einstellungen

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Helfer
Newbie
Newbie
Beiträge: 4
Registriert: 17. Feb 2004, 07:58

SUSE 9 - LAN Einstellungen

Beitrag von Helfer »

Hilfe! ich komme wirklich seit 2 wochen nicht zu recht.Ich habe SUSE 9 auf meine machine und XP auf andere HDD, und 3 nachbaren von mir haben XP auf kisten :lol: ;ich kann mit dem nicht verbinden. "Unable to find workgroups in your network" sagt samba zu mir.einmal sagt auch "Internal Error...libsmbclient....is a severe problem with your Network" und eimal wird ein passwort von mir verlangr. böse samba...
ich bekomme immer pings.ich habe auch mit LinNeighborhood versucht und sogar die netzwerk gescannt und als ich versucht habe ein shareordner von anderen pc, bekamm ich die meldung:"smbmnt must be installed suid root for direct user mounts (501,501) sbmnt failed 1".
was sol ich bei Samba Client eintragen, was bei Samba Server und wie bei DNS?
hier ist mein smb.config datei wenn euch hilft:
# Samba config file created using SWAT
# from localhost (127.0.0.1)
# Date: 2004/02/15 13:54:41

# Global parameters
[global]
workgroup = MSHOME
server string = Samba Server
interfaces = 192.168.0.2/255.255.255.0
security = SHARE
encrypt passwords = No
map to guest = Bad User
log file = /var/log/samba/%m.log
max log size = 0
time server = Yes
unix extensions = Yes
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
os level = 66
domain master = Yes
dns proxy = No
wins support = Yes
guest account = pub
guest ok = Yes
veto files = /*.eml/*.nws/riched20.dll/*.{*}/

[homes]
comment = Home Directories

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
guest ok = No
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
guest ok = No

danke für jede hilfe!
Karsten
Newbie
Newbie
Beiträge: 19
Registriert: 27. Dez 2003, 12:11

Beitrag von Karsten »

Hört sich ja übel an...

Haste sichergestellt, daß ihr alle in der gleichen Arbeitsgruppe seid? das würde schonmal einiges erklären.
Ansonsten gibt es bei XP einige besonderheiten (hab ich im Netz bei meinen ersten Samba-gehversuche gelesen) frag mich jetzt aber nicht welche.
Wenn Du von Windows aus nicht auf Samba kommst, dann hast du vermutlich noch keine SMB-User angelegt...dann will er ein Passwort, das es noch nicht gibt.
User legst du in der Komandozeile als root mit
smbpasswd -a username
an. Der User muß aber auf dem System bereits als Linuxuser existieren! Das vergebene Passwort ist dann das, was du bei Windows brauchst. In deiner smb.conf <b>muß auf jeden fall</b> encrypt passwords = yes sein. Unverschlüsselte passworte gibbet nur bei win95 soweit ich weiß...
Bei den Homeverzeichenissen sollte es auch sinnvoll sein, wenn du da einen pfad hin angibst - nur kommentar ist eigentlich albern, es sei denn es soll keiner in sein Home kommen;-)
Wenn dann der Sambaserver gestartet ist
(Komandozeile: rcsmb start und rcnmb start)
dann sollte das von Windows aus erstmal laufen, denke ich.
Für andersherum:
Auf Windows-Freigaben zugreifen

von Linux System auf Verzeichnis-Freigaben von Windows-Rechnern zugreifen.

Manuelles Vorgehen

Die Windows Freigabe kann manuell mit dem mount-Befehl eingebunden wird. Stellen Sie dazu sicher, dass das Paket samba-client installiert ist. Um zunächst die Freigaben eines Windows-Rechners einzusehen, geben Sie in einer root-Shell den Befehl
smbclient -L netbios-name

ein, wobei netbios-name für den NetBIOS-Namen des Windows-Rechners steht. Falls der Zugriff fehlschlägt, ist eine Authentifizierung unter Hinzufügung des Benutzernamens erforderlich. Die Syntax des Aufrufs lautet in diesem Fall folgendermassen:

smbclient -L netbios-name -U username

Als Ergebnis wird eine Liste ausgegeben, welche die Freigaben anzeigt:
erde:~ # smbclient -L winmachine -U testuser
added interface ip=192.168.0.1 bcast=192.168.0.255 nmask=255.255.255.0
Password:
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

Sharename Type Comment
--------- ---- -------
IPC$ IPC Remote-IPC
testshare Disk test-share
ADMIN$ Disk Remoteadmin
C$ Disk Standardfreigabe

Server Comment
--------- -------
WINMACHINE

Workgroup Master
--------- -------
WORKGROUP WINMACHINE

Wie aus der Auflistung ersichtlich, wird auf dem Rechner winmachine das Verzeichnis testshare freigegeben. Um dieses mit Hilfe des mount-Aufrufs einzubinden, erstellen Sie zunächst einen Mountpoint:
mkdir -p /windows/winshare

Mit dem folgenden Aufruf hängen Sie nun die Windows-Freigabe in Ihr Dateisystem ein (passen Sie Rechner-und Verzeichnisnamen bitte an Ihre Verhältnisse an):
mount -t smbfs //winmachine/testshare /windows/winshare

Durch diesen Aufruf wird die Freigabe namens testshare des Windows-Rechners winmachine eingebunden. Zugriff auf die Daten ist nun unterhalb des Verzeichnisses /windows/winshare möglich.

Falls am Windows-Rechner eine Authentifizierung mit Benutzernamen erforderlich ist, lautet die Syntax des Aufrufs folgendermassen:

mount -t smbfs -o username=benutzer,password=geheim //winmachine/testshare /windows/winshare

Für benutzer setzen Sie den Benutzernamen ein, der zur Authentifizierung auf dem Windows Rechner erforderlich ist, für geheim dessen Passwort.

Wenn das Verzeichnis automatisch beim Rechnerstart eingebunden werden soll, so kann eine entsprechende Option in die Datei /etc/fstab eingefügt werden (alles in eine einzige Zeile schreiben):

//winmachine/testshare /windows/winshare smbfs
auto,gid=users,fmask=0664,dmask=0775,iocharset=iso8859-15 0 0

In diesem Beispiel sind zusätzliche Optionen eingefügt: gid=users bedeutet, dass nicht nur root, sondern auch Benutzer des Linux-Systems auf die Daten des Windows-Share zugreifen können. Mit fmask bzw. dmask wird festgelegt, mit welchen Rechten Dateien bzw. Verzeichnisse im lokalen System angezeigt werden. Mit iocharset=iso8859-15 wird der Zeichensatz festgelegt. Weitere Optionen bietet der Shell-Aufruf man smbmount.

Da die Datei /etc/fstab von allen Benutzern des Linux Systems lesbar ist, sollten hier die Optionen username und password nicht direkt eingetragen werden. Stattdessen benutzen Sie die Datei /etc/samba/smbfstab, um den Eintrag vorzunehmen. Diese Datei kann nur von root, nicht jedoch von Nutzern des Systems eingesehen werden.


Entfernen Sie den Eintrag aus der Datei /etc/fstab und tragen Sie in die Datei /etc/samba/smbfstab folgendes ein (wiederum alles in eine einzige Zeile):

//winmachine/testshare /windows/winshare
auto,gid=users,fmask=0664,dmask=0775,iocharset=iso8859-15,username=benutzer,password=geheim

Achten Sie auf die im Gegensatz zur Datei /etc/fstab leicht veränderte Syntax: Das Dateisystem sowie die Angaben für dump und fsck (die beiden Zahlen am Schluss der Zeile) werden nicht angegeben.

Das Verzeichnis wird beim nächsten Booten automatisch eingehangen.

Mehr ann ich auch erstmal nicht sagen...
Viel erfolg!
Benutzeravatar
Helfer
Newbie
Newbie
Beiträge: 4
Registriert: 17. Feb 2004, 07:58

SUSE 9 - LAN Einstellungen

Beitrag von Helfer »

also ich habe 90% geschafft d.h. ich habe einer der Freigabe gemountet mit hilfe der LinNeighborhood und danach in Konqueror, oder direkt vom Verzeichniss "mnt". Ich konnte sogar der Inhalt der freigegebene Verzerchniss browsen.
Ich sage 90% weil es kommt immer die gleiche Fehlermeldung was auch Snowyrain sagt, und das wenn ich auf die Netzwerk-verknüpfung clicke.
Und zweitens, das alles kann ich nur wen ich als root angemeldet bin.Als normale benutzer ich kann zwar die Freigabe der Clients sehen aber der Inhalt nicht.
Kann mit jemand helfen dass ich 100% schaffe?
Danke!
Antworten