Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

WPA unter Suse 9.x

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Mr. S
Member
Member
Beiträge: 61
Registriert: 1. Apr 2004, 00:55

WPA unter Suse 9.x

Beitrag von Mr. S »

Hallo!

Ich habe eine Netgear WG511T mit Atheros-Chipsatz und möchte gerne das WPA unter Suse 9.2 benutzen. Die Karte wird einwandfrei erkannt und ohne Verschlüsselung funktioniert dies auch. Sobald ich aber WPA einschalte findet der das Netz nicht mehr.
Zuletzt geändert von Mr. S am 22. Apr 2005, 23:40, insgesamt 2-mal geändert.
MfG
Mr. S

"Linux is like a wigwam, no windows, no gates but an apache inside!"

OpenSuse Linux 13.1, Ubuntu 14.04 LTS, Arch Linux
Benutzeravatar
Diskus
Member
Member
Beiträge: 223
Registriert: 18. Dez 2004, 10:05
Wohnort: Nürnberg/Suse-City

Beitrag von Diskus »

Hallo,

funktioniert bei mir auch nur mit wpa_supplicant aber dafür bestens(im Moment mit ner Siemens PC Card 54 -geht aber auch mit Acer 108Mbit PCMCIA (Atheros-Chipsatz)-mußt halt madwifi als Treiber nutzen.
http://hostap.epitest.fi/wpa_supplicant/-Installationanleitung unter:
[/url]http://ndiswrapper.sourceforge.net/phpw ... %209.1[url]
nur das bei Suse 9.2 das Instalationsverzeichnis nicht /usr/local/bin/ sondern /usr/sbin/ lautet

vielleicht hilft´s
Diskus[/url]
Mr. S
Member
Member
Beiträge: 61
Registriert: 1. Apr 2004, 00:55

Beitrag von Mr. S »

Schon klar, das wpa_supplicant installiert werden muss! Das mit dem madwifi muss ich mal ausprobieren. Vielen Dank!
MfG
Mr. S

"Linux is like a wigwam, no windows, no gates but an apache inside!"

OpenSuse Linux 13.1, Ubuntu 14.04 LTS, Arch Linux
Benutzeravatar
Diskus
Member
Member
Beiträge: 223
Registriert: 18. Dez 2004, 10:05
Wohnort: Nürnberg/Suse-City

Beitrag von Diskus »

Mr. S hat geschrieben:Schon klar, das wpa_supplicant installiert werden muss! Das mit dem madwifi muss ich mal ausprobieren. Vielen Dank!
die wpa_supplicant -version die bei Suse 9.2 dabei ist läuft nicht richtig bei mir darum der link zur Originalseite-wollte nur helfen da mich das Thema auch zimmliche Nerven gekostet hat.

Diskus
Mr. S
Member
Member
Beiträge: 61
Registriert: 1. Apr 2004, 00:55

Beitrag von Mr. S »

Achso, das die von Suse nicht funktioniert wusste ich nicht. Danke für den Hinweis! Im Augenblick sieht es leider so aus, das ich gar kein Netz mehr finde selbst wenn ich Verschlüsselung deaktiviere.
MfG
Mr. S

"Linux is like a wigwam, no windows, no gates but an apache inside!"

OpenSuse Linux 13.1, Ubuntu 14.04 LTS, Arch Linux
Benutzeravatar
Diskus
Member
Member
Beiträge: 223
Registriert: 18. Dez 2004, 10:05
Wohnort: Nürnberg/Suse-City

Beitrag von Diskus »

Schreib wenn du es nicht hinbekommst helfe gern

Diskus
Mr. S
Member
Member
Beiträge: 61
Registriert: 1. Apr 2004, 00:55

Beitrag von Mr. S »

Hihi! Die Lösung ist viel trivialer!
Hallo!

Ich gehe davon aus, dass die Karte unterstützt wird.

Um WPA nutzen zu können, muss 'wpa-supplicant' installiert und mit der
entsprechenden Option (-> '.config') für Deinen Treiber übersetzt worden
sein. Ich denke mal, dass SuSE das alles gemacht hat.
(s. Optionen für das Kompilieren http://hostap.epitest.fi/wpa_supplicant)

Wenn am Access-Point "ssid broadcasts" abgeschalttet ist, musst Du im
Script /etc/sysconfig/network/scripts/ifup-wireless-wpa eine Option
hinzufügen:

(Zeile 123)

--schnipp--

Code: Alles auswählen

 network={ 
    ssid="$WIRELESS_ESSID" 
    scan_ssid=1                            #das kommt hinzu 
    psk="$WIRELESS_WPA_PSK 
    key_mgmt=WPA-PSK 
 } 
--schnipp--

Viele Infos zum Thema gibts hier:
http://www.mattfoster.clara.co.uk/madwifi-faq.htm
Quelle: http://lists.suse.com/archive/suse-linu ... /0841.html

Das mit Zeile 123 stimmt nicht ganz, aber es funktioniert jetzt sofort.
MfG
Mr. S

"Linux is like a wigwam, no windows, no gates but an apache inside!"

OpenSuse Linux 13.1, Ubuntu 14.04 LTS, Arch Linux
Benutzeravatar
Diskus
Member
Member
Beiträge: 223
Registriert: 18. Dez 2004, 10:05
Wohnort: Nürnberg/Suse-City

Beitrag von Diskus »

Hallo,

freu dich bei meinen 3 Laptops im Geschäft lief die Suse-Version nicht.

Diskus
Benutzeravatar
JohnDoe1978
Member
Member
Beiträge: 51
Registriert: 12. Mär 2004, 08:35
Wohnort: München
Kontaktdaten:

Beitrag von JohnDoe1978 »

Also ich hab ne Gigabyte Mini PCI im Notebook eingebaut, die hat auch Atheros chipsatz. Unter Windows lief die Karte nicht. Der Rechner fror immer ein.

SuSE 9.2 installiert, Karte wurde einwandfrei erkannt. WEP richtig eingerichtet -> Alles Online.

Fazit: Manchmal ist es nur eine Frage der Konfig. Wie bei mir. Mein Router benutzt für WEP nur hexadezimales Passwort. Wenn man das nicht weis, sucht man ziemlich lang...
Mr. S
Member
Member
Beiträge: 61
Registriert: 1. Apr 2004, 00:55

Beitrag von Mr. S »

@JohnDoe1978
WEP ist nicht das Thema hier, sondern WPA! Falls du nicht das Problem mit der ESSID hast wende dich an Diskus, der versteht was davon!

@Diskus
Meine WLAN-Karte wurde auch schon mit Suse 9.1 erkannt, nur WPA habe ich erst mit 9.2 hinbekommen. Die Netgearkarten werden alle erkannt. Im Packet km_wlan ist der madwifi für Atheros drin. Aber trotzdem vielen Dank für deine Hilfe.
MfG
Mr. S

"Linux is like a wigwam, no windows, no gates but an apache inside!"

OpenSuse Linux 13.1, Ubuntu 14.04 LTS, Arch Linux
Mr. S
Member
Member
Beiträge: 61
Registriert: 1. Apr 2004, 00:55

WPA mit Netgear WG511T und Suse 9.3

Beitrag von Mr. S »

Unter Suse Linux 9.3 funktioniert es auch:
  1. bei der installation das wpa_supplicant installieren
  2. bei der netzwerkkonfiguration in den hardwaredetails "wireless" auswählen (die karte wird ja von suse erkannt)
  3. als verschlüsselung WPA PSK auswählen
  4. Textpasswort eingeben und fertigstellen
Das Problem mit der SSID besteht immer noch, also ggf. wieder die Config-Datei ändern.
MfG
Mr. S

"Linux is like a wigwam, no windows, no gates but an apache inside!"

OpenSuse Linux 13.1, Ubuntu 14.04 LTS, Arch Linux
Antworten