Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

postfix kaputt?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

postfix kaputt?

Beitrag von michael_33 »

Hallo,

ich brauch das ansich nicht, SuSE will es aber offenbar, keine Ahnung davon. Jedenfalls übergibt sich SuSEconfig jedesmal:

Code: Alles auswählen

Executing /sbin/conf.d/SuSEconfig.postfix...
rebuilding /etc/postfix/virtual.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/transport.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/access.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/canonical.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/sender_canonical.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/relocated.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/sasl_passwd.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/relay_ccerts.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
Wie kann ich da was richtig stellen?

thx
michael
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.
peter120
Newbie
Newbie
Beiträge: 7
Registriert: 21. Aug 2004, 10:17

gleiches Problem

Beitrag von peter120 »

hallo michael_33,

bei mir ist es exakt das gleiche. Scheint aber keinen Einfluss auf das Restsystem zu haben. Jedenfalls merke ich nichts davon. javascript:emoticon(':?')
Susepro 9.3, K7N2-Delta, AMD 2500+, 1024MB, Radeon 9200SE
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

na dann passe die /etc/postfix/main.cf Datei mal an.

die Variable inet_interfaces setzt du auf 127.0.0.1 und dann sollte der Spuck nach einem erneuten SuSEconfig (als root!) beendet sein

andere Möglichkeiten:
#inet_interfaces = all
#inet_interfaces = $myhostname
#inet_interfaces = $myhostname, localhost
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
peter120
Newbie
Newbie
Beiträge: 7
Registriert: 21. Aug 2004, 10:17

geht nicht

Beitrag von peter120 »

leider funktioniert weder
inet_interfaces = 127.0.0.1
noch die anderen Alternativen.
SuSEconfig als root produziert die selben Fehlermeldungen:
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/transport.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/access.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/canonical.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/sender_canonical.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/relocated.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/sasl_passwd.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
rebuilding /etc/postfix/relay_ccerts.db
postmap: fatal: config variable inet_interfaces: host not found: ::1
Susepro 9.3, K7N2-Delta, AMD 2500+, 1024MB, Radeon 9200SE
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

ähm, nach der Änderung den postfix neu starten!

rcpostfix restart
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 »

Naja, dann siehts so aus:

Code: Alles auswählen

Executing /sbin/conf.d/SuSEconfig.postfix...
        *** WARNING ***
Found /etc/postfix/main.cf.SuSEconfig, exiting...
        *** WARNING ***
Executing /sbin/conf.d/SuSEconfig.profiles...
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

die Konfigurationsdatei des postfix hat sich geändert und bedarf einiger Anpassungen. Wenn du den postfix nicht brauchst, dann deaktiviere ihn im YaST-Runlevel-Editor. Bedenke aber, das dann keine mails mehr versendet werden können innerhalb deines Systems.

Besser wäre die /etc/postfix/main.cf zu richten.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Gesperrt