Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Habe ein Problem beim starten des Dhcp-Servers!!!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Chip@linux
Member
Member
Beiträge: 59
Registriert: 6. Jan 2005, 22:04

Habe ein Problem beim starten des Dhcp-Servers!!!

Beitrag von Chip@linux »

Hallo Zusammen

Ich habe die dhcpd.conf in /etc/ nch Anleitung aufgebaut und wenn ich nun in der Console mit dem Befeh "rcdhcpd start" den Server starten will kommt fologende Meldung:

Starting DHCP server ...cannot... DHCPD_INTERFACE in /etc/sysconfig/dhcpd is emty!

Was habe ich falsch gemacht?
Ich danke schon jetzt für die Antwort

Gruss
andreasw
Member
Member
Beiträge: 76
Registriert: 12. Dez 2004, 23:29

Beitrag von andreasw »

Du musst angeben, welche Netzwerkkarte der DHCP Server verwenden soll.

Also z. B. DHCPD_INTERFACE="eth0" in die Datei schreiben, falls eth0 die Netzwerkkarte ist.

die Stelle müsste übrigends bereits in der Datei drinstehen.

mfg

Andy
Chip@linux
Member
Member
Beiträge: 59
Registriert: 6. Jan 2005, 22:04

Beitrag von Chip@linux »

Danke für die Antwort. Ich habe den DHCP mal über Yast konfiguriert und das geregelt aber wenn ich mit Yast alles eingestellt habe, kommt am Schluss die Fehlermeldung, Konfiguration konnte nicht übernommen werden oder so was ähndliches und ob man die Änderungen doch übernehmen will. An was kann das liegen?
andreasw
Member
Member
Beiträge: 76
Registriert: 12. Dez 2004, 23:29

Beitrag von andreasw »

Es kann sein, dass Yast die Config Datei nicht mehr richtig parsen kann, nachdem du sie manuell bearbeitet hast, verschiebe die Datei mal und probiere es dann nochmal mit Yast.

mfg

Andy
Chip@linux
Member
Member
Beiträge: 59
Registriert: 6. Jan 2005, 22:04

Beitrag von Chip@linux »

Wohin soll ich die dhcpd.conf verschieben?
andreasw
Member
Member
Beiträge: 76
Registriert: 12. Dez 2004, 23:29

Beitrag von andreasw »

z.B. nach dhcpd.conf.old

ich hätte besser umbenennen sagen sollen sorry

mfg

Andy
Chip@linux
Member
Member
Beiträge: 59
Registriert: 6. Jan 2005, 22:04

Beitrag von Chip@linux »

Ich habe die Datei auf dhcpd1.conf umbenant und mit Yast wieder alles konfiguriert aber diese Meldung:
Speichern der Konfiguration fehlgeschlagen. Einstellungen ändern?

kommt immer noch, was mache ich noch falsch?
andreasw
Member
Member
Beiträge: 76
Registriert: 12. Dez 2004, 23:29

Beitrag von andreasw »

Tut mir leid, aber da weis ich nicht mehr weiter, evtl weis ja jemand anderes weiter.

mfg

Andy
Chip@linux
Member
Member
Beiträge: 59
Registriert: 6. Jan 2005, 22:04

Beitrag von Chip@linux »

Trozdem danke für deine Hilfe

Greez: Andy(heisse auch so)
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

Re

Beitrag von SySdaemon »

Hi,
hier ist mal meine dhcpd.conf
Hilft dir vielleicht weiter

Code: Alles auswählen

default-lease-time 86400;
max-lease-time 86512;
ddns-update-style none;

option domain-name "my.domain.net";
option domain-name-servers 192.168.1.1;
option broadcast-address 192.168.1.255;
option subnet-mask 255.255.255.0;

subnet 192.168.1.0 netmask 255.255.255.0
{
	range 192.168.1.2 192.168.13.254;
}
eth habe ich nicht extra angeben!

bye :roll:
SUN Sparc Server 10 (2x 75 MHz)
We have joy, We have fun, We run Linux on a SUN.
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

yast/system/sysconfig-editor.

Dort mal suchen bei Netzwerk. Da gibts irgendwo die Variabble, wo eth0 rein muiß
Such da mal rum.

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

RE:

Beitrag von SySdaemon »

Hallo,

könnte das in die /etc/rc.conf gehören ?!

Dort müsste dann DHCPD_INTERFACE="eth0" stehen!
Wenn das ganze auf eth0 laufen soll.

Nach der Fehlermeldung von oben könntest du das ganze auch mal in der /etc/sysconfig/dhcpd versuchen.

bis denn,
cu, :P
SUN Sparc Server 10 (2x 75 MHz)
We have joy, We have fun, We run Linux on a SUN.
stka
Moderator
Moderator
Beiträge: 3314
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Beitrag von stka »

In der Datei /etc/sysconfig/dhcpd muss der Eintrag DHCPD_INTERFACE="eth0"
stehen dann klappt auch mit dem DHCP Server
Antworten