Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SuSE 9.2 und USB Drucker - Geht nicht

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
rened
Newbie
Newbie
Beiträge: 7
Registriert: 5. Jan 2005, 11:02

SuSE 9.2 und USB Drucker - Geht nicht

Beitrag von rened »

Hallo,

ich will auf einem Einzelplatzrechner ohne Netzwerk einfach nur mit Hilfe eines einfachen HP 3745 USB Druckers Dokumente aus Officeanwendungen und dem Internet zu Papier bringen. Das scheint aber unter SuSE 9.2 nicht so ohne weiteres möglich zu sein.

Schon bei der Druckererkennung im YAST wird der Drucker nicht erkannt. Wenn ich versuche einen nicht erkannten zu konfigurieren, kann SuSE nicht mit dem USB Drucker kommunizieren. Er meint immer das ich nicht als root (den Testdruck) zugreife. Wenn ich dann in die Treiberauswahl komme, gibt es den 3745 nicht.

Kann mir bitte irgend jemand helfen? Danke schon mal im voraus.

Gruß René
Mit Computern lösen wir alle Probleme,
auch die die wir ohne sie gar nicht hätten.
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4001
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Versuche einen "anderen" USB-Drucker zu konfigurieren mit
einer PPD-Datei von hier:
http://www.linuxprinting.org/show_print ... skJet_3740

diese dürfte mit deinem Drucker kompatibel sein.

MfG
misiu
rened
Newbie
Newbie
Beiträge: 7
Registriert: 5. Jan 2005, 11:02

Beitrag von rened »

Hallo,

das hab ich probiert, geht aber auch nicht. Ich habe in den /dev Verzeichnis auch Textdateien mit Hello World gefunden, also das was beim Anschlusstest gesendet wird. Die hab ich gelöscht.

Okay, dann hab ich im Kontrollzentrum nachgesehen und da wird angezeigt das der KDE-Druckdämon nicht gestartet ist. Wie bitte kann ich den starten. Im Runleveleditor steht nix drin außer cups der ist aktiv.
Außerdem erhalte ich die Fehlermeldung:
Während der Kommunikation mit dem CUPS-Server beim Speichern der Warteschlange y2test ist ein Fehler aufgetreten.

cups(File)DoRequest error: client-error-bad-request

und zwar dann wenn ich den konfigurierten Drucker einen Testdruck entlocken will. Was mache ich da falsch??????

Wenn ich das Ding nicht bald zum laufen(drucken) krieg, krieg ich die Krise. Es ist zum verzweifeln, ein popeliger Drucker macht mir das Leben zur Hölle. :cry:
Mit Computern lösen wir alle Probleme,
auch die die wir ohne sie gar nicht hätten.
rened
Newbie
Newbie
Beiträge: 7
Registriert: 5. Jan 2005, 11:02

Nachtrag

Beitrag von rened »

wenn ich unter Dienstprogramme --> Druckerverwaltung gehe, ist der Status: angehalten (Aufträge werden angenommen)

Gru? rené
Mit Computern lösen wir alle Probleme,
auch die die wir ohne sie gar nicht hätten.
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4001
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Offensichtlich hast du schon CUPS-Update aufgespiellt, spiele
die DVD-CUPS-Dateien wieder auf, sonst kriegst du Probleme
mit der Kommunikation Drucker->Spooler. Wie es geht steht
im SuSE-Portal.

MfG
misiu
LittleNo
Member
Member
Beiträge: 62
Registriert: 14. Mai 2004, 00:21
Kontaktdaten:

Beitrag von LittleNo »

da ich ja hier: http://www.linux-club.de/viewtopic.php?t=22619 auch so meine Probleme mit 9.2 und Drucken hab, vermute ich jetzt mal, dass das bei mir auf die gleiche Ursache mit diesem Update zurück zu führen ist

finde aber im suse portal nix drüber

hast Du da vielleicht n link?
rened
Newbie
Newbie
Beiträge: 7
Registriert: 5. Jan 2005, 11:02

Beitrag von rened »

@littleNo

ich habe die Anleitung von hier befolgt:

http://portal.suse.com/sdb/de/2004/07/p ... stall.html

allerdings habe ich den Drucker danach immer noch nicht dazu bewegen können, seine Job ordentlich zu machen. Er streikt weiter.

Nach einem Anruf bei HP wurde mir gesagt das Linux nicht mehr unterstützt werde, zumindest im Nicht-Serverbereich. Das würde bedeuten, das dieser Drucker für die Nutzung unter Linux nicht in Frage kommt. :x Die nette Frau will mir per Mail was zu kommen lassen.
Ich halte euch auf dem laufenden.

Grüsse derweil
Mit Computern lösen wir alle Probleme,
auch die die wir ohne sie gar nicht hätten.
rened
Newbie
Newbie
Beiträge: 7
Registriert: 5. Jan 2005, 11:02

Beitrag von rened »

also HP hat mir folgenden Link geschickt:

http://h10025.www1.hp.com/ewfrf/wc/fast ... 14438%3Cbr
über diese Seite kommt man zu:

http://hpinkjet.sourceforge.net/


Hier gibt es ja die OpenSource Treiber, vielleicht kann damit ja jemand was anfangen. Mir hat das auch nicht geholfen.
Ich vermute mal, das der DeskJet 3745 unter Linux nicht mehr unterstützt wird und ich ihn werde nie zum drucken bringen.

Falls noch irgend jemand eine Idee hat, kann er sie gern mitteilen. Mir fällt nix mehr ein. :cry:

Danke und viele Grüsse

René
Mit Computern lösen wir alle Probleme,
auch die die wir ohne sie gar nicht hätten.
LittleNo
Member
Member
Beiträge: 62
Registriert: 14. Mai 2004, 00:21
Kontaktdaten:

Beitrag von LittleNo »

so, jetzt hab ich genau diese "Anleitung" auch befolgt - alle Pakete von Hand de-installiert, die verzeichnisse leer-geräumt, berechtigungen überprüft, und per yast von den CD's das CUPS wieder installiert

gleiches Symptom wie vorher, Druckauftrag steht in der Warteschlange und da bleibt er...

ich denke mal dann wirds auch bei Dir rened ned zwingend am Drucker liegen - da hat Suse einfach mal wieder was verbockt in dem ganzen kram, und keiner kennt sich aus bei der Geheimnisstuerei ... es ist wirklich ärgerlich dass man bei SuSE immer wegen solchen Lächerlichkeiten aufgehalten wird, ich meine ich hab eigentlich interessantere Dinge mit meinem Linux vor, als wochenlang zu raten warum der wohl ned drucken will ... bei komplizierten Dingen wie einer Samba-Domäne oder einem FTP-Server, weiss ich wenn was ned geht, es liegt an mir, aber da komm ich dann auch mit denken+artikel lesen weiter, nur sowas hier, wo es ohne fehlermeldung einfach nicht geht, das is einfach übelst ... leider schon fast standard bei Suse

so, das musste gesagt werden ... in diesem Sinne, meine Drucker müssen trotzdem irgendwann wieder gehn
LittleNo
Member
Member
Beiträge: 62
Registriert: 14. Mai 2004, 00:21
Kontaktdaten:

Beitrag von LittleNo »

hab jetzt mal zum test den drucker im samba freigegeben (als raw für cups), um zu sehn was passiert wenn man von windows aus druckt - fast das gleiche: windows stellt den druckauftrag in die warteschlange, und meldet dann dass der Drucker angehalten wurde...

da stimmt einfach irgendwas mit dem Drucksystem im linux ned
awern
Newbie
Newbie
Beiträge: 4
Registriert: 28. Dez 2004, 09:51

/etc/cups/printers.conf überprüfen

Beitrag von awern »

ich hatte wohl das gleiche Problem:

Überprüfe doch mal, ob in der /etc/cups/printers.conf die beiden Zeilen stehen:

State IDLE
Accepting Yes

Eine ggf. vorhandene StateMessage kann auch entfernt werden.

Ursache:
Wenn der Drucker beim Druckversuch nicht eingeschaltet war (vor allem der USB-Port nicht ansprechbar) wird der Drucker hier suspended. Anscheinend gibt es aber keine neuen Versuche der Kontaktaufnahme.
Also Datei anpassen und CUPS neu starten mit rccups restart.

Gruß
Andreas
awern
Newbie
Newbie
Beiträge: 4
Registriert: 28. Dez 2004, 09:51

Beitrag von awern »

P.S.:
natürlich muss man auch sicherstellen, dass die Datei
/etc/cups/printers.conf
den Eigentümer lp und die Gruppe lp behält bzw. wieder bekommt
rened
Newbie
Newbie
Beiträge: 7
Registriert: 5. Jan 2005, 11:02

Beitrag von rened »

Überprüfe doch mal, ob in der /etc/cups/printers.conf die beiden Zeilen stehen:

State IDLE
Accepting Yes
Hab ich überprüft und steht drin, ebenso sind die Rechte bei lp.

Ich habe noch weiter probiert und in Net gesucht. Habe mir dann noch usbview installiert und wollte damit testen, allerdings wird das Programm nicht gestartet. Ebenso bringt der Befehl: ptal-init setup nichts.
Nach dem die Paralelle Schnittstelle ohne Fund (was logisch ist da es ein USB Drucker ist) abgeschlossen ist, passiert bei der USB Abfrage nichts.

Ausgabe:

Probe for USB-connected devices([y]/n)? y

ab hier passiert nichts mehr. Ich denke mal ich habe da ein USB Problem. Ich bin kurz davor alles neu zu installieren, nur hab ich die Befüchtung das ich dann wieder Probleme mit dem Modem kriege. Suse, so scheint mir, arbeitet sich langsam in Richtung Windows hoch. traurig,traurig! :?


Grüsse René
Mit Computern lösen wir alle Probleme,
auch die die wir ohne sie gar nicht hätten.
rened
Newbie
Newbie
Beiträge: 7
Registriert: 5. Jan 2005, 11:02

Beitrag von rened »

HALLO

ich habe das Problem gelöst!!! :D
Ich habe einfach den Drucker an einen anderen USB-Anschluss gesteckt und beim Neustart wurde er sofort als HP 3745 erkannt und eingerichtet. Ist zwar seltsam aber es geht.
Ich danke allen die geholfen haben.

Viele Grüsse

René
Mit Computern lösen wir alle Probleme,
auch die die wir ohne sie gar nicht hätten.
LittleNo
Member
Member
Beiträge: 62
Registriert: 14. Mai 2004, 00:21
Kontaktdaten:

Beitrag von LittleNo »

ch habe das Problem gelöst!!! Very Happy
Ich habe einfach den Drucker an einen anderen USB-Anschluss gesteckt und beim Neustart wurde er sofort als HP 3745 erkannt und eingerichtet. Ist zwar seltsam aber es geht.
Ich danke allen die geholfen haben.
meiner geht leider immernoch nicht :evil: - der pc hat auch drei parallel-ports, und auf keinem geht er
LittleNo
Member
Member
Beiträge: 62
Registriert: 14. Mai 2004, 00:21
Kontaktdaten:

Beitrag von LittleNo »

awern, hab da grad mal rein geschaut:

Code: Alles auswählen

State Stopped
StateMessage Unable to open parallel port devie file "/dev/lp0": Permission denied
hab das dann eben so geändert wie Du gesagt hast, cups neu gestartet, und drucken versucht - gleiches Ergebnis

dann nommal die Datei angeschaut und dann stand wieder der gleiche kram wie vorher drin

aber das bringt uns doch schommal auf die richtige Spur, oder? hab leider zu wenig Ahnung von den Details um damit was wirkliches anfangen zu können, aber so wie ich das versteh, heisst das doch, dass er irgendwie ned auf den parallel-port "schreiben" kann - wo und wie kann ich n da nu weiter schüffeln?
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4001
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Versuche auf den Port , als Root zu drucken, wenn es geht, liegt es an den fehlenden Benutzer-Rechten.

MfG
misiu
Benutzeravatar
wingfire
Newbie
Newbie
Beiträge: 43
Registriert: 9. Jan 2004, 15:03
Wohnort: Köln
Kontaktdaten:

Beitrag von wingfire »

hi zusammen,
vielleicht hilft euch ja mein tipp weiter ...

ich hatte ein ähnliches problem:
immer wenn ich meinen drucker vom rechner getrennt habe (usb-stecker ziehen) dann wird auf cups mein drucker angehalten (kann man unter http://localhost:631 kontrollieren).
leider vergisst suse oder cups (zuständigkeit unklar) beim einstecken des druckers diesen unter cups wieder zu starten.
also drucker unter der cups-web-oberfläche einfach starten, hierfür ist die einrichtung des print-passworts erforderlich.
gruss christof
LittleNo
Member
Member
Beiträge: 62
Registriert: 14. Mai 2004, 00:21
Kontaktdaten:

Beitrag von LittleNo »

Versuche auf den Port , als Root zu drucken, wenn es geht, liegt es an den fehlenden Benutzer-Rechten.
geht nicht :(
Antworten