Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Mit Windows XP Pro über SUSE 9.2 ins Internet - Bitte Hilfe!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
boogie
Newbie
Newbie
Beiträge: 4
Registriert: 4. Jan 2005, 17:49

Mit Windows XP Pro über SUSE 9.2 ins Internet - Bitte Hilfe!

Beitrag von boogie »

Hallo!

Ich habe seit kurzem Suse Linux 9.2 installiert!
Möchte von Microsoft wegkommen und mich ein bisschen in Linux einarbeiten.
Habe es zusammen gebracht, dass ich mit dem Alcatel Speed Touch USB Modem ins Internet komm, auch schon mal was ! :D

Jetzt hab ich folgendes Problem, ich möchte mit meinem Windows XP Rechner auch noch ins Netz kommen.
Habe das Netzwerk mal am laufen gehabt, aber durch das ständige herumprobieren funktioniert das Netzwerk jetzt auch nicht mehr!
Ich kann vom Windows Rechner aus den Linux Rechner anpingen, aber vom Linux den Windows Rechner nicht?!
Ich kann auch nicht vom Windows Rechner ins www pingen.
Bin mit zwei Netzwerkkarten verbunden und gehe über das USB Port online.

Habe das Netzwerk laut einem Tutorial kunfiguriert:

Mein Linux Rechner hat folgende Einstellungen:
IP: 192.168.2.1 SM: 255.255.255.0
Firewall ist aktiviert
Daten weiterleiten und Masquerading durchführen ist auch an

Mein Windows XP Rechner hat folgende Einstellungen:
IP: 192.168.2.2 SM: 255.255.255.0
Firewall ist aus

Mein USB Modem hat folgende Einstellungen:
IP: 192.168.0.1
Standard Gateway ist mein Linux Rechner 192.168.2.1


Hoffe ich habe alles wichtige zusammen.

Wäre nett, wenn mir jemand weiterhelfen könnte, oder mir einen link posten würde!

Danke im Voraus für Eure Bemühungen,
MFG Boogie
NeoMan
Member
Member
Beiträge: 141
Registriert: 4. Okt 2004, 14:44

Beitrag von NeoMan »

Hallo boogie,

als erstes muß das interne Netzwerk, sprich LAN funktionieren. Wenn dies nicht funktioniert dann kommst du von deinem Windows-Rechner auch nicht ins Netz. Versuche erstmal dein LAN in gang zu setzen. Wenn die zwei Rechner über einen Switch verbunden sind, dann recht es aus, wenn die zwei Rechner im selben subnet sind. Dann muß ping in alle zwei Richtungen funktionieren.

Wenn LAN geht, kannst du das Internet für den Windows Rechner einrichten. Dabei mußt du von Windows-Seite den Linux-Rechner als Gateway eintragen und den Nameserver deines Providers. Mehr ist auf Windows-Seite nicht zu tun.

Auf Linux-Seite IP-Forwarding und NAT aktivieren. Außerdem würde ich erst einmal die Firewall deaktivieren. Damit kannst du diese als Fehlerquelle ausschliessen. Später natürlich wieder die Firewall aktivieren.



MfG NeoMan
Benutzeravatar
flox
Newbie
Newbie
Beiträge: 20
Registriert: 25. Dez 2004, 15:40
Wohnort: Köln

alle Clients in ein Subnet

Beitrag von flox »

Hallo boogie,

ich stimme NeoMan voll zu: erst das LAN (lokales Netz) dann der Rest.

mein Vorschlag
Linuxrechner 192.168.2.1
windowsrechner 192.168.2.2
modem 192.168.0.1

Die Details findest Du mit
man ifconfig
man route

dann:

eine route zum LAN, und zum Internet eintragen:
route add -net 192.168.0.0 netmask 255.255.255.0 eth0 #interne karte
route add default gw 192.168.0.1
boogie
Newbie
Newbie
Beiträge: 4
Registriert: 4. Jan 2005, 17:49

Beitrag von boogie »

Danke, für Eure Beiträge!

Ich hab jetzt zumindest das Netzwerk wieder zum laufen gebracht!
Kann vom Linux auf den Windows Rechner pingen und vom Windows auf den Linux auch. Jedoch komme ich immer noch nicht mit dem Windows Rechner ins Netz.
Habe Eure Ratschläge befolgt, jedoch ohne Erfolg :cry:

Kann das sein, dass es was mit der DNS zu tun hat, denn wenn ich von meinem Windows Rechner aus ins www pingen will, dann bringt er eine Fehlermeldung, dass der Servername für die Adresse xxx.xxx.xxx.xxx nicht gefunden werden konnte?!
Die Standardserver sind nicht verfügbar.

Ich habe jedoch die DNS meines Internet Anbieters eingetragen, also müsste es doch eigentlich funktionieren, oder?

Danke für Eure Hilfe,

MFG Boogie!
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Nicht Böse sein ! Der Onkel macht doch nur Spaß !
boogie
Newbie
Newbie
Beiträge: 4
Registriert: 4. Jan 2005, 17:49

Beitrag von boogie »

Ja, hab schon gesehen, muss mich da noch ein wenig mehr reinhängen, mir fehlen noch die Grundlagen, hab mir heut eh ein Linux Buch gekauft, mit Grundlagen usw.
Werd ein bisschen rumprobieren, das Forum durchforsten, nach dem Motto "learning by doing"

Aber trotzdem danke,

MFG Boogie!
boogie
Newbie
Newbie
Beiträge: 4
Registriert: 4. Jan 2005, 17:49

Beitrag von boogie »

Hallo!

Habe mir Gestern noch das Linux update heruntergeladen und siehe da, es funktioniert! :P
Kann jetzt von beiden aus ins Internet!

Danke für Eure Bemühungen

MFG
Boogie!
Antworten