Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kann NTFS Partition nicht über NFS mounten

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
SLAW0
Newbie
Newbie
Beiträge: 6
Registriert: 30. Dez 2004, 18:14

Kann NTFS Partition nicht über NFS mounten

Beitrag von SLAW0 »

Hallo Leute,
ich habe hier ein kleines Netzwerk aus mehreren Linux Rechnern. Teilweise ist da 9.2, teilweise 9.1 und teilweise noch 8.2 drauf.
Ich versuche schon seit geraumer Zeit eine auf einem der Rechner gemountete NTFS Partition auf einem anderen über NFS zu mounten. Bisher leider ohne Erfolg.
Ich habe es wirklich schon kreuz-und-quer versucht. Die /etc/export oder die /etc/fstab zu posten macht bei mir eigentlich keinen Sinn, denn wie gesagt habe ich es schon mit so ziemlich jeder vernünftigen Kombination versucht und das bisher ohne Erfolg, aber der Vollständigkeit halber hier die letzte Version der /etc/exports:

Code: Alles auswählen

/mnt/hdc        192.168.99.180(ro,root_squash,sync)
Die /etc/fstab spielt keine Rolle, weil ich die Freigabe manuell mounten will, z.B. mit:

Code: Alles auswählen

mount -t nfs 192.168.99.196:/mnt/hdc /mnt/hdc
Wohl gemerkt:
NFS funktioniert sonst auf allen diesen Rechnern problemlos. Ich kann EXT3, ReiserFS und auch VFAT Freigaben normal über NFS mounten. Nur halt bei NTFS klappt es nicht. Gibt es bei dem NTFS Treiber was besonderes zu beachten?

Beim Mounten von NTFS Freigaben bekomme ich auf dem Client immer diese Fehlermeldung:

Code: Alles auswählen

mount: 192.168.99.196:/mnt/hdc failed, reason given by server: Keine Berechtigung
Auf dem Server steht dann folgendes in der /var/log/messages:

Code: Alles auswählen

Dec 30 13:59:47 <servername> rpc.mountd: authenticated mount request from 192.168.99.180:714 for /mnt/hdc (/mnt/hdc)
Dec 30 13:59:47 <servername> rpc.mountd: getfh failed: Operation not permitted
Was vielleicht noch interessant ist: im gesamten Netzwerk werden die User- und GroupIDs per NIS vergeben.
Benutzeravatar
Knobi.697
Newbie
Newbie
Beiträge: 48
Registriert: 4. Okt 2004, 20:02

WinXP

Beitrag von Knobi.697 »

Hi!
Ich hatte ähnliche Probleme beim Zugriff auf die NTFS
-Partition lokal auf dem PC von Linux aus. Habe dann heraus gefunden, dass man mit Linux nicht auf die NTFS-Part zugreifen kann, wenn das Servicepack 2 für Win XP installiert ist. Vielleicht ist es bei dir ja auch so?!?

Knobi
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: WinXP

Beitrag von Martin Breidenbach »

Knobi.697 hat geschrieben:Habe dann heraus gefunden, dass man mit Linux nicht auf die NTFS-Part zugreifen kann, wenn das Servicepack 2 für Win XP installiert ist.
*Mounten* kann ich NTFS Partitionen die mit XPSp2 erstellt wurden auf zwei Rechnern mit SuSE 9.1 Pro ohne Probleme (halt readonly). Allerdings habe ich noch nicht versucht die wieder zu exportieren (mein NFS Server ist ein SuSE 9.2 Rechner ohne fremde Partitionen).
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
SLAW0
Newbie
Newbie
Beiträge: 6
Registriert: 30. Dez 2004, 18:14

Beitrag von SLAW0 »

Danke erst einmal für die Antworten.
Also das Mounten lokal auf dem Rechner an sich ist kein Problem (natürlich auch nur ro). Das Vorhandensein vom Servicepack spielt hier also keine Rolle, ich glaube sowieso, dass die Platten noch unter W2K formatiert wurden. Exportieren funktioniert prinzipiell auch, jedenfalls bekomme ich keine Fehlermeldungen und mit exportfs werden die Freigaben auch richtig angezeigt. Nur wenn die Platte auf einem anderen Rechner über NFS gemountet werden soll, gibt es irgendwelche Probleme auf dem Server, so dass der NFS Mount fehlschlägt (siehe oben).
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Zitat von folgender Seite:

http://www.linuxfibel.de/nfs_srv.htm
hide, nohide
Exportiert der Server ein Verzeichnis, in dem wiederum ein anderes Dateisystem gemeountet ist, so wird dieses nicht an einen Client exportiert (hide, Voreinstellung); die nohide-Option (also den impliziten Export) funktioniert jedoch nur, wenn es sich bei der Clientangabe um einen Rechnernamen (keine Wildcards, IP-Netzwerke und Netzgruppen!) handelt.
Ich versuche gerade mal selber das nachzuvollziehen und stoße auf das gleiche Problem. Die nohide Option hat mich aber noch nicht weitergebracht. Ich habe jetzt /windows exportiert. Wenn ich das nach /mnt mounte dann ist /mnt/C leer.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
SLAW0
Newbie
Newbie
Beiträge: 6
Registriert: 30. Dez 2004, 18:14

Beitrag von SLAW0 »

Kann das gerade nich ganz nachvollziehen.
Welcher Partition/welchem Verzeichnis auf dem Server entspricht denn /windows? Müsste der Inhalt von /windows nicht direkt unter /mnt stehen wenn du es unter /mnt mountest?

Ich denke das mit hide/nohide sollte kein Problem sein, denn ich mounte meine NTFS-Partition z.B. unter /mnt/hdc und das ist dann die oberste Ebene.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Auf dem 'server' ist /windows/C der mountpoint für die lokale NTFS-Partition /dev/hda1.

Ich habe erst versucht /windows/C freizugeben und bekam beim mounten nach /mnt 'permisson denied'. Dann habe ich das mal geändert und direkt /windows freigegeben. Dann kann ich /windows nach /mnt mounten aber /mnt/C ist leer (was /windows/C keinesfalls ist).
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
SLAW0
Newbie
Newbie
Beiträge: 6
Registriert: 30. Dez 2004, 18:14

Beitrag von SLAW0 »

OK, verstehe.
In diesem Fall könnte es sehr wohl was mit hide/nohide zu tun haben.
Das direkte NFS Mounten einer NTFS Partition funktioniert bei dir aber auch nicht, wie ich sehe... Ich denke, selbst mit nohide wirst du keinen Erfolg haben.
Ich hege langsam echte Zweifel daran, dass der NTFS driver das wirklich unterstützt. Oder der lokale Mount muss mit irgendwelchen hahnebüchenen Spezialoptionen gemacht werden.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Ich habe ja die nohide Option bereits erfolglos ausprobiert - auch mit expliziter Angabe des Rechners.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
SLAW0
Newbie
Newbie
Beiträge: 6
Registriert: 30. Dez 2004, 18:14

Beitrag von SLAW0 »

Tja, so wie es aussieht weiß niemand wie es geht
_Thomas_
Newbie
Newbie
Beiträge: 1
Registriert: 1. Mär 2007, 17:32

Beitrag von _Thomas_ »

Hi @,

habe das selbe Problem wie hier vor Monaten......... diskutiert.
Bei mir läuft openSuse 10.2 und zwei Festplatten (sda1 und sdb1) mit ntfs gemountet.

Könnte es sein das jemand eine Lösung für dieses Problem hätte?

Danke
Thomas
Antworten