Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

IMAP Mail Server, Cyrus, Postfix, Fetchmail, Linux-tin.org

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

IMAP Mail Server, Cyrus, Postfix, Fetchmail, Linux-tin.org

Beitrag von XeN »

Hallo,

ich google jetzt schon eine gute woche an meinem Problem rum. Vielleicht erstmal zur gesammt situation.

Unsere Firma möchte demnächst zur besseren Kommunikation einen Groupware server einsetzen. Die Groupware Software soll OpenXchange sein.

Es soll nattürlich auch eine eMail implementierung vorgenommen werden, diese sollte es beherschen einen "catch-all" account auf die einzelnen user aufzuteilen.

Beispiel ich aktiviere für die domain beispiel.de catch-all, heißt also das alles was ich an scheissegalwas@beispiel.de schicke an eine adresse weitergeleitet wird. diese adresse wollen wir abholen und in der Groupware an die user verteilen. Dies soll wohl irgendwie gehen. Es soll jedenfalls NICHT für jeden user ein Pop account beim Provider erstellt werden (soviele hätten wir auch nicht =)).

Ich habe nach dem Tutorial von linux-tin.org versucht einen mail server aufzusetzen, leider ist wohl beim Cyrus gewaltig der wurm drin. Ich kann mich mit cyradm einloggen, mailboxen erstellen. Diese werden allerdings nicht gespeichert und saslpasswd2 funktioniert nicht.

Ich Poste am besten einfach mal die Configs.

imapd.conf

Code: Alles auswählen

configdirectory: /var/lib/imap
partition-default: /var/spool/imap
sievedir: /var/lib/sieve
admins: cyrus root postfix
srvtab: /var/lib/imap/srvtab
allowanonymouslogin: no
autocreatequota: 10000
reject8bit: no
quotawarn: 90
timeout: 480
poptimeout: 10
dracinterval: 0
drachost: localhost
sasl_pwcheck_method: saslauthd
sasl_mech_list: plain login
lmtp_overquota_perm_failure: no
lmtpsocket: /var/lib/imap/socket/lmtp
#
# if you want TLS, you have to generate certificates and keys
#
#tls_cert_file: /usr/ssl/certs/cert.pem
#tls_key_file: /usr/ssl/certs/skey.pem
#tls_ca_file: /usr/ssl/CA/CAcert.pem
#tls_ca_path: /usr/ssl/CA
Es soll übrigends so sein das wir für jeden user ein systemaccount haben wollen. Ist für uns einfacher da unser server von der Wahrenwirtschaft schon alle accounts besitzt. Also müßten wir nur die shadow dateien austauschen.

Bitte sagt mir was ihr noch braucht, ich verzweifel langsam. Ich weiss auch das viel schon im internet steht, aber zu dem fehler

Code: Alles auswählen

Dec 29 11:30:30 groupware saslpasswd2: unable to open Berkeley db /etc/sasldb2: Invalid argument
Dec 29 11:30:30 groupware saslpasswd2: setpass failed for root: generic failure
Kann ich nichts finden
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

Hab noch was vergessen zu sagen. Das Ganze versuche ich auf Suses SLES 9.

Dake nochmal für eure Hilfe.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

Code:

Dec 29 11:30:30 groupware saslpasswd2: unable to open Berkeley db /etc/sasldb2: Invalid argument
Dec 29 11:30:30 groupware saslpasswd2: setpass failed for root: generic failure
wie rufst du denn den Befehl saslpasswd2 auf ?
ist saslauthd am laufen ?
gibt es die Datei /etc/sasldb2 ?
welche Rechte hat sie ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

oc2pus hat geschrieben: wie rufst du denn den Befehl saslpasswd2 auf ?
ist saslauthd am laufen ?
gibt es die Datei /etc/sasldb2 ?
welche Rechte hat sie ?
also saslpaswd2 rufe ich mit "saslpasswd2 -c cyrus" auf
sasl authd ist am laufen

Code: Alles auswählen

 5330 ?        Ss     0:00 /usr/sbin/saslauthd -a pam
 5331 ?        S      0:00 /usr/sbin/saslauthd -a pam
 5332 ?        S      0:00 /usr/sbin/saslauthd -a pam
 5333 ?        S      0:00 /usr/sbin/saslauthd -a pam
 5334 ?        S      0:00 /usr/sbin/saslauthd -a pam
 5472 pts/1    S+     0:00 grep saslauthd
die datei /etc/sasldb2 gibt es und hat folgende rechte

Code: Alles auswählen

groupware:/etc # ls -l /etc/sasldb2
-rw-r-----  1 cyrus mail 12289 Dec 27 09:57 /etc/sasldb2
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

dann probiere:
saslpasswd2 -c -u `postconf -h myhostname` exampleuser
Falls postconf -h myhostname nicht funtioniert dann eben den Hostname an dieser Stelle eintragen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

also wenn ich "saslpasswd2 -c -u `postconf -h myhostname` exampleuser" eingebe erhalte ich folgendes

Code: Alles auswählen

groupware:/etc # saslpasswd2 -c -u `postconf -h myhostname` cyrus
Password:
Again (for verification):
saslpasswd2: generic failure
in der auth.log steht

Code: Alles auswählen

Dec 29 13:19:38 groupware saslpasswd2: unable to open Berkeley db /etc/sasldb2: Invalid argument
Dec 29 13:19:38 groupware saslpasswd2: setpass failed for cyrus: generic failure
und wenn ich saslpasswd2 -c -u `postconf -h groupware` cyrus eingebe erhalte ich

Code: Alles auswählen

groupware:/etc # saslpasswd2 -c -u `postconf -h groupware` cyrus
postconf: warning: groupware: unknown parameter

This product includes software developed by Computing Services
at Carnegie Mellon University (http://www.cmu.edu/computing/).

saslpasswd2: usage: saslpasswd2 [-v] [-c [-p] [-n]] [-d] [-a appname] [-f sasldb] [-u DOM] userid
        -p      pipe mode -- no prompt, password read on stdin
        -c      create -- ask mechs to create the account
        -d      disable -- ask mechs to disable/delete the account
        -n      no userPassword -- don't set plaintext userPassword property
                                   (only set mechanism-specific secrets)
        -f sasldb       use given file as sasldb
        -a appname      use appname as application name
        -u DOM  use DOM for user domain
        -v      print version numbers and exit
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

saslpasswd2 -c -u `postconf -h groupware` cyrus
NEIN :)
saslpasswd2 -c -u <hostname> cyrus
ODER
saslpasswd2 -c -u <ip-des-server> cyrus

so war das gemeint :)

aber der erste Versuch sah doch gut aus ... dein Problem scheint die db-RPM zu sein.
unable to open Berkeley db /etc/sasldb2
Probiere:
1. lösche /etc/sasldb2 und probiere nochmals
2. setze die Rechte der sasldb2 mal auf 666 (testweise) und probiere nochmals

ansonsten poste die Ausgabe von rpm -qa | grep db
mich interessieren die Pakete db, db4, db41 und deren Versionsnummern.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

Also die eingabe des befehls ergab glaube ich ein gutes ergebnis, der fehler blieb jedenfalls aus.

Code: Alles auswählen

groupware:/etc # saslpasswd2 -c -u 192.168.194.99 cyrus
Password:
Again (for verification):
saslpasswd2: generic failure
groupware:/etc # rm sasldb2
groupware:/etc # saslpasswd2 -c -u 192.168.194.99 cyrus
Password:
Again (for verification):
das steht in der auth.log

Code: Alles auswählen

Dec 29 13:39:16 groupware saslpasswd2: setpass succeeded for cyrus
Dec 29 13:39:16 groupware saslpasswd2: error deleting entry from sasldb: DB_NOTFOUND: No matching key/data pair found
rpm -qa | grep db ergab

Code: Alles auswählen

groupware:/etc # rpm -qa | grep db
gdbm-devel-1.8.3-228.1
db-utils-4.2.52-86.3
gdb-6.1-1.7
db-4.2.52-86.3
db1-1.85-85.1
db1-devel-1.85-85.1
gdbm-1.8.3-228.1
db-devel-4.2.52-86.3
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

ok, dann stimmt etwas in deiner Namesnauflösung noch nicht. Aber wenn es mit der IP geht sind wir ein Stück weiter.

Die db-4.2.52-86 ist schon mehrfach aufgefallesn mit Problemen. Probiere ob du für dein SLES diese Version finden kannst db-4.2.52-85.
Für SuSE 9.1 könnte ich dir sagen woher, aber bei SLES90 muss ich passen.

Um den Verdacht mit der db zu erhärten: beobachte die Datei /var/log/messages wenn du deinen cyrus neustartest.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

also wenn ich anstelle der IP den Hostnamen eingebe funktioniert das auch, die IP ging mir nur schneller von der hand =).

Wenn ich cyrus neu starte erscheinen keine fehler in der messages. scheint wirklich alles okay zu sein. Hab eine mailbox angelegt, diese ist auch vorhanden.

Ich werde einfach mal mit dem Tutorial weiter machen. Kann ich mich bei eventuellen anderen fehlern auch an dich wenden?

Vielen Dank für deine Hilfe.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

XeN hat geschrieben:also wenn ich anstelle der IP den Hostnamen eingebe funktioniert das auch, die IP ging mir nur schneller von der hand =).
fein ;)
XeN hat geschrieben:Wenn ich cyrus neu starte erscheinen keine fehler in der messages. scheint wirklich alles okay zu sein. Hab eine mailbox angelegt, diese ist auch vorhanden.
na dann ist die Welt erst mal in Ordnung ...
XeN hat geschrieben:Ich werde einfach mal mit dem Tutorial weiter machen. Kann ich mich bei eventuellen anderen fehlern auch an dich wenden?
Poste dein Problem einfach, es sind viele fleissige Helferlein hier und lesen mit ... und meistens weiss einer was zu einem Problem :)

Bei Problemen immer die entsprechenden Konfigabschnitte und Log-Abschnitte mitposten. Das macht es einfacher und effizienter und spart Rückfragen. Du hast das teilweise sogar schon von dir aus getan, das ist sehr gut so!

Du kannst gerne auch mal im IRC-Chat vorbeischauen (Link ist in meiner Signatur) da geht vieles schneller!
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

werde mich wieder melden wenns Probleme gibt. IRC ist eine feine und schnelle sache, leider bin ich auf der Arbeit, und ich glaube die sehen das hier nicht so gerne. Bekomme schon einen drauf wenn ich auch nur an ICQ denke =).
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

Also ich hab doch noch einen scheinbar fehler. Wollte mal eine mail an den neuen server schicken. diese kommt zwar nicht an, aber der server möchte drauf gerne mit einem Mail delivery antworten, was ja schon mal eigendlich nicht schlecht ist.

Wenn ich nun versuche die queue zu flushen dann erhalte ich in der var/log/mail folgende meldung

Code: Alles auswählen

Dec 30 08:46:59 groupware postfix/qmgr[12488]: 0BA2538E64C: from=<sebasti@groupware.panno.int>, size=367, nrcpt=1 (queue active)
Dec 30 08:46:59 groupware postfix/smtp[12509]: warning: SASL authentication failure: GSSAPI Error:  Miscellaneous failure (see text) (open(/tmp/krb5cc_51): No such file or directory)
Dec 30 08:46:59 groupware postfix/smtp[12509]: 0BA2538E64C: to=<bjoern@calimo.de>, relay=smtp.udag.de[62.146.33.70], delay=1561, status=deferred (Authentication failed: cannot SASL authenticate to server smtp.udag.de[62.146.33.70]: generic failure)
Hast du da vielleicht noch eine idee??
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

ach ja, noch was vergessen. die sasl_passwd existiert, und die werte darin sind auch richtig.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

Dec 30 08:46:59 groupware postfix/smtp[12509]: warning: SASL authentication failure: GSSAPI Error: Miscellaneous failure (see text) (open(/tmp/krb5cc_51): No such file or directory)
du hast bei deinen AUTH Verfahren irgendwo noch einen Wurm drin.
Diese Fehlermeldung deutet auf kerberos hin ...

schau mal in dieser Datei nach:
/usr/lib/sasl2/smtpd.conf
pwcheck_method: saslauthd
mech_list: plain login

# Authentificate versus sasldb
pwcheck_method: auxprop
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

So, da binn ich wieder. Antworte erst jetzt weil ich seit Donnerstag nicht mehr auf der Arbeit war =). Allen hier ein Frohes neues jahr =).

also in meiner smtpd.conf steht folgendes

Code: Alles auswählen

pwcheck_method: saslauthd
mech_list: LOGIN plain login PLAIN
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

Habe deine setting mal eingefügt, doch ohne erfolg.

mfg XeN
Gesperrt