Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

digikam und MPEG-Encoder

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
dietmar
Member
Member
Beiträge: 67
Registriert: 10. Feb 2004, 10:51

digikam und MPEG-Encoder

Beitrag von dietmar »

Hallo Linux Gemeinde,
habe Suse 9.2 (i686) und möchte Digikam nutzen um mit dem Plugin "MPEG Encoder" SVCDs brennen zu können.

Nun gibt es in der Suse Distribution zwar die KIPI Plugins aber dort ist dieses Plugin nicht enthalten. Warum weiss der Henker..
Die Installation des Kipi Plugins für Suse 9.1 führt zwar das Plugin auf, jedoch stürzt das Programm ab, wenn man das Plugin aufruft.

Mit K3B und VCDImager kann man SVCDs erst brennen wenn man die Bilder in MPEG Dateien umgewandelt hat, und genau das macht der MPEG Encoder von Digikam.

Nun habe ich die tar-Datei herunter geladen welche auch für Suse 9.2 sein soll, dort ist das Plugin auch wieder zu finden.

Der Befehl "./configure" läuft bis zu einem Punkt durch und bricht mit Fehler ab. Dieser lautet:
"checking for libz... configure: error: not found.
Possibly configure picks up an outdated version
installed by XFree86. Remove it from your system.

Check your installation and look into config.log"

In der Config.lg steht dann was von ZLIB... aber die ist installiert.

Kann ich diesen Punkt irgentwie umschiffen oder kennt jemand einen guten und einfachen MPEG Encoder ??
Danke für rasche Hilfe....
Dietmar
einganzanderername

Beitrag von einganzanderername »

Hi,
ich habe dasselbe Problem. Für das MPEG-Kodierer-Plugin (MPEGEncoder) müssen wohl:
-libKipi
-kipi-plugins
-ImageMagick
-MjpegTools
installiert sein (http://extragear.kde.org/apps/kipi/#compilation , http://digikam.sourceforge.net/hand.../interface.html)

Ich habe alles installiert, (in den richtigen Versionen und in unterschiedlicher Reihenfolge), aber unter dem Menüpunkt "Extras" findet sich kein Eintrag "MPEG Kodierer" bzw. "MPEGEncoder". Weiss jemand woran das liegt?
(auch der Tipp hat nichts gebracht: http://kanotix.com/wiki/CoMa.php?CoMa=DigiKam)

Meine Softwareversionen:
SuSE 9.1
DigiKam 0.7.1
ImageMagick 5.5.7
MjpegTools 1.6.2

In der EasyLinux 06/2004 steht, dass noch "mpeg2enc" installiert sein muss. Ich habe jedoch herausgefunden, dass "mpeg2enc" ein Teil von MjpegTools ist. Ich kann es auch über die Konsole ansprechen.
Um ganz sicher zu gehen, habe ich auch noch alle anderen aufgelisteten Progs installiert:
-avifile
-libquicktime
-digikamimageplugins

Trotzdem kann ich das MPEG-Kodierer-Plugin nicht finden/nutzen. Wer hat eine Idee?
einganzanderername

Beitrag von einganzanderername »

Hier ist die Lösung:
http://forum.ebv4linux.de/viewtopic.php?p=3515#3515
Es lag am Kipi-Plugin. Ein anderes RPM hat es "repariert".
Antworten