Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

ping von linux und win-client

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

ping von linux und win-client

Beitrag von Azhrarn »

Moin Forum.

Ich kann von meinen WinXP-Clients keinen Ping an einige Internetadressen schicken. Vom Linux-Router allerdings schon. Demzufolge kann ich von den WinXP-Clients auch einige Internetseiten nicht ansehen. Vom Linux-Router per Textbrowser allerdings schon.

Beispiel:
Vom Linux-Router
server:/etc/sysconfig/network # ping -c4 google.de
PING google.de (216.239.39.104) 56(84) bytes of data.
64 bytes from 216.239.39.104: icmp_seq=1 ttl=238 time=114 ms
64 bytes from 216.239.39.104: icmp_seq=2 ttl=238 time=114 ms
64 bytes from 216.239.39.104: icmp_seq=3 ttl=238 time=115 ms
64 bytes from 216.239.39.104: icmp_seq=4 ttl=238 time=113 ms

--- google.de ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3002ms
rtt min/avg/max/mdev = 113.481/114.434/115.015/0.708 ms
server:/etc/sysconfig/network # ping -c4 inbetrachtung.com
PING inbetrachtung.com (62.112.156.121) 56(84) bytes of data.
64 bytes from kundenserver6hsgbr.de (62.112.156.121): icmp_seq=1 ttl=51 time=31.7 ms
64 bytes from kundenserver6hsgbr.de (62.112.156.121): icmp_seq=2 ttl=51 time=31.1 ms
64 bytes from kundenserver6hsgbr.de (62.112.156.121): icmp_seq=3 ttl=51 time=30.7 ms
64 bytes from kundenserver6hsgbr.de (62.112.156.121): icmp_seq=4 ttl=51 time=35.6 ms

--- inbetrachtung.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 30.798/32.326/35.675/1.974 ms
Vom WinXP-Client
C:\>ping google.de

Ping google.de [216.239.39.104] mit 32 Bytes Daten:

Antwort von 216.239.39.104: Bytes=32 Zeit=114ms TTL=237
Antwort von 216.239.39.104: Bytes=32 Zeit=115ms TTL=237
Antwort von 216.239.39.104: Bytes=32 Zeit=113ms TTL=237
Antwort von 216.239.39.104: Bytes=32 Zeit=115ms TTL=237

Ping-Statistik für 216.239.39.104:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 113ms, Maximum = 115ms, Mittelwert = 114ms

C:\>ping inbetrachtung.com
Ping-Anforderung konnte Host "inbetrachtung.com" nicht finden. Überprüfen Sie de
n Namen, und versuchen Sie es erneut.
Ich komme da irgendwie nicht weiter. Kann mir jemand vielleicht helfen?

ISP ist Freenet.
OS auf Linux-Router ist SuSE 9.1.
OS auf WinXP-Client ist Windows XP Professional SP2.
Browser sind Firefox und IE.
MTU ist auf 1454.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Wie sieht denn die DNS-Konfiguration auf beiden Rechnern aus ?
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Als DNS hab ich 217.237.150.33. Auf dem Linux-Router denselben. Hab aber auch schon andere probiert.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Das ist allerdings seltsam. Ich sehe momentan die Fehlerquelle nicht.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Ich stehe ja ebenso auf dem Schlauch. Aufgefallen ist mir die ganze Geschichte, als ich auf www.bioware.com wollte, sich aber nix tat und mein Browser nur meldete, dass die Seite nicht gefunden wurde. Ebenso verhielt es sich mit einigen anderen Internetseiten. Ein Freund von mir konnte aber alle Seiten aufrufen. Dann hab ich einfach mal angefangen zu pingen und bin letztendlich bei oben genannten Problem hängen geblieben. Erst dachte ich es liegt vielleicht an meinem Nameserver. Nachdem ich diesen aber deaktiviert hab, blieb das Problem weiterhin. Also habe ich verschiedene DNS probiert. Kein Erfolg. Vielleicht sollte ich erwähnen, dass sich einige Seiten garnicht anzeigen lassen. andere erst nach mehreren Klicks und die meisten ohne Probleme.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Die Sachen die ich checken wollte hast Du offenbar schon durch:

- Linux und Windows verwenden denselben DNS-Server
- MTU wurde schon verkleinert

Da die DNS-Auflösung für einige Seiten funktioniert liegt wohl auch kein Problem mit z.B. Firewall vor (wobei - ich hatte mal ne Firewall falsch konfiguriert indem ich für DNS nur UDP durchgelassen habe und das gab recht 'interessante' Effekte).
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Die Firewall ist meiner Meinung nach nicht das Problem, da ich schon ewig nicht mehr was geändert habe.
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Bin jetzt ohne Router mit dem Internet verbunden und alles läuft normal. Das Problem liegt also irgendwo beim Router.
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Also mein Problem liegt wohl beim DNS-Server, denn ein Ping an eine bereits aufgelöste Adresse funktioniert tadellos. Wenn ich hier meine named.conf poste, kann mir dann jemand helfen die richtig zu konfigurieren?
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

named.conf ist die Konfiguration für den DNS Server.

Die Konfiguration für DNS Client steht in resolv.conf.

Hast Du denn einen DNS-Server am Laufen ?
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Bind 9 läuft bei mir standardmässig. Hatte den aber gestern auch mal deaktiviert und nen externen DNS eingetragen.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Du hattest doch weiter oben geschrieben beide würden denselben DNS (217.237.150.33) verwenden ?

Grmbl.

Na dann poste mal Deine named.conf.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Ok, standardmässig läuft bei mir Bind 9 als Nameserver. Die Konfiguration könnt ihr unten entnehmen. Da ich aber die weiter oben genannten Probleme festgestellt habe, deaktivierte ich den Nameserver und verwendete externe DNS-Adressen auf dem Linux-Router und den WinXP-Clients. Nachdem ich meinen Nameserver heute wieder aktivierte, lief alles wieder seinen gewohnten Gang. Trotzdem möchte ich vorsichtshalber meine named.conf posten.

Code: Alles auswählen

# Copyright (c) 2001-2004 SuSE Linux AG, Nuernerg, Germany.
# All rights reserved.
#
# Author: Frank Bodammer, Lars Mueller <lmuelle@suse.de>
#
# /etc/named.conf
#
# This is a sample configuration file for the name server BIND 9.  It works as
# a caching only name server without modification.
#
# A sample configuration for setting up your own domain can be found in
# /usr/share/doc/packages/bind/sample-config.
#
# A description of all available options can be found in
# /usr/share/doc/packages/bind/misc/options.

options {
		
	# The directory statement defines the name server's working directory

	directory "/var/lib/named";
		
	# Write dump and statistics file to the log subdirectory.  The
	# pathenames are relative to the chroot jail.

	dump-file "/var/log/named_dump.db";
	statistics-file "/var/log/named.stats";
		
	# The forwarders record contains a list of servers to which queries
	# should be forwarded.  Enable this line and modify the IP address to
	# your provider's name server.  Up to three servers may be listed.

	forwarders { 217.237.150.33; 217.237.150.225;  };
	
	# Enable the next entry to prefer usage of the name server declared in
	# the forwarders section.

	forward first;

	# The listen-on record contains a list of local network interfaces to
	# listen on.  Optionally the port can be specified.  Default is to
	# listen on all interfaces found on your system.  The default port is
	# 53.

	listen-on port 53 { 127.0.0.1; 192.168.0.1; };
	
	# The listen-on-v6 record enables or disables listening on IPv6
	# interfaces.  Allowed values are 'any' and 'none' or a list of
	# addresses.

	listen-on-v6 { none; };
		
	# The next three statements may be needed if a firewall stands between
	# the local server and the internet.

	query-source address * port 53;
	#transfer-source * port 53;
	#notify-source * port 53;

	# The allow-query record contains a list of networks or IP addresses

	# to accept and deny queries from. The default is to allow queries
	# from all hosts.

	allow-query { 192.168.0.1; 192.168.0.2; 192.168.0.3; 192.168.0.4; 192.168.0.5; 192.168.0.6; 192.168.0.7; 192.168.0.8; };
	
	# If notify is set to yes (default), notify messages are sent to other
	# name servers when the the zone data is changed.  Instead of setting
	# a global 'notify' statement in the 'options' section, a separate
	# 'notify' can be added to each zone definition.

	notify no;
	max-cache-ttl 259200;
	max-ncache-ttl 259200;	
};

# To configure named's logging remove the leading '#' characters of the
# following examples.
logging {
	# Log queries to a file limited to a size of 100 MB.
	channel query_logging {
		file "/var/log/named_querylog"
			versions 3 size 100M;
		print-time yes;			// timestamp log entries
	};
	category queries {
		query_logging;
	};

	# Or log this kind alternatively to syslog.
#	channel syslog_queries {
#		syslog user;
#		severity info;
#	};
#	category queries { syslog_queries; };
#
#	# Log general name server errors to syslog.
#	channel syslog_errors {
#		syslog user;
#		severity error;
#	};
#	category default { syslog_errors;  };
#
#	# Don't log lame server messages.
#	category lame-servers { null; };
};

# The following zone definitions don't need any modification.  The first one
# is the definition of the root name servers.  The second one defines
# localhost while the third defines the reverse lookup for localhost.

zone "." in {
	type hint;
	file "root.hint";
};

zone "localhost" in {
	type master;
	file "localhost.zone";
	check-names fail;
	allow-update { none; };
};

zone "0.0.127.in-addr.arpa" in {
	type master;
	file "127.0.0.zone";
};

zone "helldemons" in {
	type master;
	file "helldemons.zone";
	allow-transfer { none; };
};
	
zone "0.168.192.in-addr.arpa" in {
	type master;
	file "192.168.0.zone";
	allow-transfer { none; };
};

# Include the meta include file generated by SuSEconfig.named.  This includes
# all files as configured in NAMED_CONF_INCLUDE_FILES from
# /etc/sysconfig/named

include "/etc/named.conf.include";

# You can insert further zone records for your own domains below or create
# single files in /etc/named.d/ and add the file names to
# NAMED_CONF_INCLUDE_FILES.
# See /usr/share/doc/packages/bind/README.SuSE for more details.
Was ist mit den DNS, die in der resolv.conf stehen? Sollten die auf meinen lokalen Nameserver verlinkt sein?


NACHTRAG: Geht eine Anfrage an meinen Nameserver werden nicht alle Domains aufgelöst.
Azhrarn
Newbie
Newbie
Beiträge: 39
Registriert: 11. Aug 2004, 09:09

Beitrag von Azhrarn »

Ich hab jetzt mal als forwarders die DNS von meinem ISP (Freenet) eingetragen. Ebenso steht der DNS vom ISP und mein lokaler DNS in meiner resolv.conf. Die Namensauflösung scheint jetzt wieder vernünftig zu funktionieren. Ich konnte bis jetzt auf alle problematischen Internetseiten zugreifen.

So wie es aussieht konnte mein lokaler DNS einige Namen nicht auflösen. Als er dann an den DNS von der Telekom (217.237.150.33) weiterleitete konnte der die Namen auch nicht auflösen hat aber anscheinend auch keine Anstalten gemacht an den nächsten DNS weiter zu leiten.

Sollte ich mit meiner Schlussfolgerung falsch liegen, bitte ich um Korrektur.

Bis dahin ...
Antworten