Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Postfix sendet keine Mails an Extern

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
benther
Newbie
Newbie
Beiträge: 2
Registriert: 27. Dez 2004, 19:24

Postfix sendet keine Mails an Extern

Beitrag von benther »

Habe ein Problem nach dem Einrichten von Postfix. Es werden beim Versenden von Mails keine an meinen Provider geroutet. Folgender Eintrag in der mail Log-Datei:

Dec 27 19:55:22 linuxserver postfix/smtp[11591]: A7129246EB: to=<fritz@mustermann-online.de>, relay=none, delay=76431, status=deferred (connect to 127.0.0.1[12
7.0.0.1]: server dropped connection without sending the initial SMTP greeting)

Wer kann mir einen Tipp geben.

Danke
Bentherjavascript:emoticon(':lol:')
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

deine mail geht an localhost!?!? hast du einen content_filter falsch konfiguriert?


poste bitte die main und master.cf !


.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
benther
Newbie
Newbie
Beiträge: 2
Registriert: 27. Dez 2004, 19:24

Beitrag von benther »

meine main.cf

readme_directory = /usr/share/doc/packages/postfix/README_FILES
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
program_directory = /usr/lib/postfix
inet_interfaces = 192.168.1.100
masquerade_domains =
mydomain = linuxserver.ny
myhostname = mail.linuxserver.ny
mydestination = $myhostname,localhost.$mydomain,$mydomain
mynetwoks = 127.0.0.0/8, 192.168.1.0/24
#defer_transports = smtp
disable_dns_lookups = no
relayhost = [smtp.1und1.com]
mailbox_command =
mailbox_transport =
strict_rfc821_envelopes = no
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/smtp_auth
smtp_sasl_security_options = noanonymous
#smtpd_sasl_auth_enable = no
#smtpd_use_tls = no
#smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000


und hier die master.cf

smtp inet n - n - 2 smtpd -o content_filter=smtp:[127.0.0.1]:10024
#smtps inet n - n - 2 smtpd -o smtpd_tls_wrappermode=yes -o content_filter=smtp:[127.0.0.1]:10024
# -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n - n - - smtpd
# -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes -o smtpd_etrn_restrictions=reject
#628 inet n - n - - qmqpd
pickup fifo n - n 60 1 pickup
cleanup unix n - n - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - n 300 1 oqmgr
#tlsmgr fifo - - n 300 1 tlsmgr
rewrite unix - - n - - trivial-rewrite
bounce unix - - n - 0 bounce
defer unix - - n - 0 bounce
trace unix - - n - 0 bounce
verify unix - - n - 1 verify
flush unix n - n 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - n - - smtp
relay unix - - n - - smtp
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - n - - showq
error unix - - n - - error
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
anvil unix - - n - 1 anvil
localhost:10025 inet n - n - - smtpd -o content_filter=
#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# maildrop. See the Postfix MAILDROP_README file for details.
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus unix - n n - - pipe
user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
procmail unix - n n - - pipe
flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

folgendes in der master.cf:

Code: Alles auswählen

smtp inet n - n - 2 smtpd -o content_filter=smtp:[127.0.0.1]:10024

was hast du auf diesem port laufen? amavis? antivir-mailgate?
dein postfix will seine angenommenen emails brav an den "content_filter" weiterleiten - da ist aber keiner :-)

entferne diesen eintrag einfach oder benutz einen content_filter (was ich dir sehr empfehlen kann! ;-))

.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
Gesperrt