Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SuSE9.0 + postfix + sasl2 probs

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
BuDDaH
Newbie
Newbie
Beiträge: 6
Registriert: 26. Dez 2004, 18:21
Kontaktdaten:

SuSE9.0 + postfix + sasl2 probs

Beitrag von BuDDaH »

Hallo Ihr,

ich hab nen Rootserver, den ich nu als Mailserver aufsetzen will, da ich div. Vereinsmitgliedern einen Account anbieten will. Ich habe versucht nach div. HowTos nen Mailserver aufzusetzen, nur hab ich das Problem dass postfix anscheinend nicht mitbekommt dass der saslauthd laeuft.

Code: Alles auswählen

baytits:/home/buddah # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 mail.baytits.de ESMTP Mailserver
helo localhost
250 mail.baytits.de
quit
221 Bye
Connection closed by foreign host.
Da fehlt dieses 250 Smtp-Auth und so

postconf -n sagt:

Code: Alles auswählen

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
inet_interfaces = all
local_recipient_maps =
mail_owner = postfix
mail_spool_directory = /var/spool/mail
mailbox_size_limit = 0
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_exceptions = root
mydestination = $myhostname, localhost.$mydomain, $mydomain, mail.$mydomain, www.$mydomain, ftp.$mydomain
mydomain = baytits.de
myhostname = mail.baytits.de
mynetworks_style = host
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
relay_domains = $mydestination
relayhost =
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP Mailserver
smtpd_client_restrictions = reject_invalid_hostname, reject_rbl_client relays.ordb.org
smtpd_helo_restrictions = reject_invalid_hostname,
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
strict_rfc821_envelopes = yes
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550
virtual_alias_domains = faelle.net, buddah.de
virtual_alias_maps = hash:/etc/postfix/virtual_domains
/usr/lib/sasl2/smtpd.conf

Code: Alles auswählen

pwcheck_method: saslauthd
mech_list: plain login
sasl laeuft als daemon
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

zion@~ > telnet mail.baytits.de 25
Trying 62.75.222.207...
Connected to mail.baytits.de.
Escape character is '^]'.
220 mail.baytits.de ESMTP Mailserver
ehlo www.klehr.de
250-mail.baytits.de
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
zion@~ >


naja, sieht doch gut aus...

diese ausgabe bekommt man mit "ehlo" - nicht mit "helo" !!!
sende mal ne email und lass tail -f /var/log/mail und tail -f /var/log/messages mitlaufen...


.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
BuDDaH
Newbie
Newbie
Beiträge: 6
Registriert: 26. Dez 2004, 18:21
Kontaktdaten:

Beitrag von BuDDaH »

ich fass es nicht....

es war wirklich nur dadran gelegen, ich habs seit tagen immer nur mit helo anstatt ehlo probiert....

kein wunder dass dann nix kam :roll:

vielen dank fuer die hilfe, den klapps aufm hinterkopf hab ich gebraucht
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

geht das ausliefern der email mit smtpd_auth oder wo war das problem?
hast du das garnicht erst probiert? :-)
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
BuDDaH
Newbie
Newbie
Beiträge: 6
Registriert: 26. Dez 2004, 18:21
Kontaktdaten:

Beitrag von BuDDaH »

ich habs gar nicht erst probiert, da irgendwo stand, dass wenn eben dieses 250 smtp-auth kommt, alles passt...

nachdems nicht kam, hab ich erst hier versucht einen fehler zu finden...

versenden geht so halbwegs, die mails werden angenommen, aber nicht verschickt (status=deferred) aber da komm ich jetzt hoffentlich auch noch dahinter :)
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

zeig her...
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
BuDDaH
Newbie
Newbie
Beiträge: 6
Registriert: 26. Dez 2004, 18:21
Kontaktdaten:

Beitrag von BuDDaH »

bei machen hosts kommt ein connection timed out, zu anderen hosts gehn mails durch.

(connect to dns.fh-hof.de[194.95.60.5]: Connection timed out)
relay=gsmtp171.google.com[64.233.171.27], delay=8, status=sent (250 2.0.0 OK 1104090518)
zwoelfdreisieben
Newbie
Newbie
Beiträge: 16
Registriert: 9. Dez 2004, 19:20

Beitrag von zwoelfdreisieben »

Hängt der Server an einer festen IP?
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

das mit der festen IP ist nicht wichtig in diesem fall:

Code: Alles auswählen

dig fh-hof.de MX

; <<>> DiG 9.2.3 <<>> fh-hof.de MX
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45347
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;fh-hof.de.                     IN      MX

;; ANSWER SECTION:
fh-hof.de.              84600   IN      MX      10 dns.fh-hof.de.

;; Query time: 18 msec
;; SERVER: 212.227.39.251#53(212.227.39.251)
;; WHEN: Mon Dec 27 05:12:40 2004
;; MSG SIZE  rcvd: 47
die jungs haben ihren dns nicht im griff wie es scheint....


.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
BuDDaH
Newbie
Newbie
Beiträge: 6
Registriert: 26. Dez 2004, 18:21
Kontaktdaten:

Beitrag von BuDDaH »

hat sich auch erledigt, hab heut ne mail vom rz bekommen,
Am Heiligabend (ca. 6 Uhr) kam es jedoch zu einem Ausfall der
Internetanbindung nach extern, was zur Folge hatte,
daß die FH-Dienste (z.B. mail, ftp) von extern nicht mehr erreicht werden
konnten.
Heute früh wurden die Probleme vom RZ behoben, seit ca. 9 Uhr stehen alle
Dienste wieder zur Verfügung.
das problem hat sich somit erledigt.
danke nochmals
BuDDaH
Newbie
Newbie
Beiträge: 6
Registriert: 26. Dez 2004, 18:21
Kontaktdaten:

Beitrag von BuDDaH »

hab seit heute ein weiteres problem:
server wurde neugestartet und nun kommt folgende meldung:

postfix/smtpd: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory

daemon laeuft aber..
saslauthd -d sagt:
saslauthd[28644] :main : no authentication mechanism specified
...
ok...

in der /etc/init.d/saslauthd steht:
AUTHD_BIN=/usr/sbin/saslauthd
test -x $AUTHD_BIN || exit 5
SASLAUTHD_AUTHMECH=pam
test -f /etc/sysconfig/saslauthd && . /etc/sysconfig/saslauthd

in der etc/sysconfig/saslauthd:

START=yes
SASLAUTHD_AUTHMECH=shadow
MECHANISMS=shadow

nachdems mich gewundert hat, das in beiden dateien fuer saslauthd_authmech unterschiedliche werte stehn, hab ich jeweils eins auskommentiert, bringt aber auch nichts.

weiss hier einer rat?
Gesperrt