Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Samba Verzeichnis nicht mehr schreibbar nach Kernel Update

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Fischi
Newbie
Newbie
Beiträge: 4
Registriert: 5. Jun 2004, 13:14
Wohnort: Berlin

Samba Verzeichnis nicht mehr schreibbar nach Kernel Update

Beitrag von Fischi »

Hallo zusammen,


Habe einen SuSE 9.1 Server und einen SuSE 9.1 Desktop. Nach (Online-)Update kann ich nun NICHT mehr korrekt auf per smbfs gemountete Verzeichnisse SCHREIBEN.

Folgendes SuSE Update durchgeführt:
- Alle Patches Stand 2004-12-10
- Incl. Samba update von 3.0.2a-x auf 3.0.4.-x
- Incl. Kernel update auf 2.6.5-7.x

Im Konqueror funktioniert gut:
- Lesen, umbenennen, löschen

Im Konqueror (oder anderem Filemanager) funktioniert NICHT:
- Schreiben (also "Hinkopieren") von Files oder Verzeichnissen

Nach Abbruch ist das File mit 0Byte vorhanden, ansonsten lange warten etc.... Ich erhalte auch den bekannten Fehler "Berechtigungen lassen sich nicht ändern für..." Der Fehlerzustand tritt immer dann ein, wenn ich versuche das Serververzeichnis per smbfs versuche zu mounten (per /etc/fstab oder manuell, z.B. mit):

mount -t smbfs -o username=XXXX,password=XXXX //192.168.0.32/data /data

Witzigerweise funktioniert es jetzt perfekt, auf Serververzeichnisse (z.B. im Konqueror) per smb:// zu zugreifen und zu schreiben. Das hatte vor den updates nicht geklappt!

smb://XXXX@192.168.0.32/data

Ich denke der Fehler liegt also "in der Gegend von smbfs" ((Kernel-)bug oder eine erweiterte Sicherheitseinstellung). Auch ein update auf die aktuellste von SuSE bereitgestellte Kernelversion (kernel-xxxx-2.6.5-7.111.19.i586.rpm) brachte keine Abhilfe.

Als Workaround habe ich das smbfs Problem beseitigen können durch Downgrade des Desktops (Samba-Client) auf Original SuSE 9.1 Kernelversion (kernel-xxxx-2.6.4-52.i586.rpm). Ist aber nicht so richtig zufriedenstellend.

Hier und in einem anderen Forum fand ich bisher keine Lösung. Hat jemand von euch ähnliche Erfahrungen? (Habe es schon an SuSE per Bugreport gemeldet.)

Danke und freundliche Grüße,
Fischi
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Da muß ich doch mal wieder die Frage stellen - warum benutzt Du nicht NFS ?
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Fischi
Newbie
Newbie
Beiträge: 4
Registriert: 5. Jun 2004, 13:14
Wohnort: Berlin

Beitrag von Fischi »

Hallo Martin,

Ja, mit NFS würd's prima klappen! Leider bin ich nicht "allein am Server". Mein Freund (mit Windows) möchte auch zugreifen können (das klappt übrigens *grübel*).

Freundliche Grüße,
Uwe
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Du kannst beides gleichzeitig verwenden - das mache ich selber so.

NFS für linux<->linux

Samba für linux<->windows
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Fischi
Newbie
Newbie
Beiträge: 4
Registriert: 5. Jun 2004, 13:14
Wohnort: Berlin

Beitrag von Fischi »

Zwischenlösung:

Anstelle von "smbfs":
mount -t smbfs -o username=XXXX,password=XXXX //192.168.0.32/data /data

sollte man "cifs" verwenden:
mount -t cifs -o username=XXXX,password=XXXX,iocharset=iso8859-1 //192.168.0.32/data /data

Das löst das Problem für mich! ("iocharset=iso8859-1" dient der Beseitigung von Umlautproblemen.) Vielen Dank an nbkr :D !!! Siehe:

smb: im Konquerer schnell, mount -t langsam

Freundliche Grüße,
Fischi
Antworten