Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

shutdown -k 00:01

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
smiling_cobra
Newbie
Newbie
Beiträge: 20
Registriert: 18. Dez 2004, 22:26

shutdown -k 00:01

Beitrag von smiling_cobra »

Ich hab

Code: Alles auswählen

shutdown -k 00:01
eingegeben. Ich wollte das nach einer Minute an die anderen Terminals die Meldung geschickt wird, dass der PC herunter gefahren wird. Im Terminal wo ich dieser Befehl eingegeben hab, geht nichts mehr, ausser bei CTR+ALT+DEL kommt die Nachricht

Code: Alles auswählen

shutdown: already running.
Diese Meldung kommt auch wenn ich in den anderen Terminals versuche den PC neu zu booten.

1. Frage: Was ist am Befehl: "shutdown -k 00:01" falsch?
2. Frage: Was kann ich nun tun?
gaw
Hacker
Hacker
Beiträge: 464
Registriert: 28. Sep 2004, 16:33

Beitrag von gaw »

In der man page zu shutdown steht bei der Option -k

Don't really shutdown; only send the warning messages to everybody.


...was deine Frage eigentlich beantworten sollte. Da du shutdown im Vordergrund startest, blockiert es deine shell. Ein & befördert ein Programm in den Hintergrund.

Um shutdown zu einem späteren Zeitpunkt auszuführen nutze ich die Option -t:
shutdown -t 20 -r now
Das ist sehr hilfreich weil der Befehl den Rechner jetzt runterzufahren verzögert wird. Zum Beispiel kann man sich per ssh auf seinem Router einloggen, den Befehl absetzen und hat noch genügend Zeit die ssh Sitzung zu verlassen.


mfG
gaw
Benutzeravatar
smiling_cobra
Newbie
Newbie
Beiträge: 20
Registriert: 18. Dez 2004, 22:26

Beitrag von smiling_cobra »

Ok mir ist alles klar, ebenso hab ich gemerkt dass 00:01 in disem Fall nicht heisst, der Befehl wird nach 1 Minute ausgeführt, sondern er wird eine Minute Nach Mitternacht ausgeführt.

Danke für die Antwort, der Parameter -t macht genau das, was ich brauche.
Antworten