Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Postfix - Zentraler Mailserver

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
geist_der_foren
Newbie
Newbie
Beiträge: 39
Registriert: 15. Dez 2003, 11:44

Postfix - Zentraler Mailserver

Beitrag von geist_der_foren »

Hi @all,
wir haben ca. 30 Linux - Maschinen hier stehen, auf jeder dieser Maschinen läuft SLES8. Einer dieser Maschinen hat die Möglichkeit Mails nach ausen zu verschicken. Jetzt möchte ich diesen Server als Zentraler Mailserver einrichten. So das die restlichen 29 Server die ganzen Mails über den Server schicken. Aber leider habe ich kein plan wie ich das machen soll :( Ich hab auch schon gegoogelt, aber leider nichts gefunden. Hat mir jemand ein paar tipps bzw. qullen wo ich schauen könnte ?
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

trag bei den 29 server folgendes in der /etc/postfix/main.cf ein:

Code: Alles auswählen

relayhost = [ip_des_gateways]
dann rcpostfix restart

jetzt leitet der entsprechende postfix seine emails an das gateway weiter.


.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
geist_der_foren
Newbie
Newbie
Beiträge: 39
Registriert: 15. Dez 2003, 11:44

Beitrag von geist_der_foren »

HI danke für deine Antwort, dass habe ich gera gemacht und in der /var/log/mail bekomme ich folgenden Fehler

Code: Alles auswählen

Dec 21 16:26:16 linux29 postfix/qmgr[11815]: 515103E5AD: to=<username@system.com>, relay=none, delay=0, s
tatus=deferred (connect to 10.206.156.181[10.206.156.181]: Connection refused)
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

wie laesst dein gateway-postfix senden zu? smtpd_auth oder hast du dein netzwerk nicht in die mynetwork eingetragen?

lass die server intern am besten mit der definition von deinem netzwerk auf dem gateway emails ausliefern - das macht fuers erste am wenigsten stress. auf dem gateway-postfix musst du mit

Code: Alles auswählen

mynetworks_style = subnet
mynetworks = <dein_netzwerk>, 127.0.0.0/8

smtpd_client_restrictions =
    permit_mynetworks
    ...

smtpd_recipient_restrictions =
    permit_mynetworks,
    ...

poste mal die /var/log/mail vom gateway und vom "client-server"...
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
Benutzeravatar
ThomasF
Hacker
Hacker
Beiträge: 578
Registriert: 1. Mai 2004, 12:37
Wohnort: Köln

Beitrag von ThomasF »

Hmm,

ich weiß nicht wie das bei einer SLES 8 ist aber bei einer "normalen" SuSE gibt es in der /etc/sysconfig/mail einen Eintrag der gesetzt sein muß damit der MTA auch Mails von außen annimmt...

Code: Alles auswählen

SMTPD_LISTEN_REMOTE="yes"
Danach braucht es noch ein SuSEconfig damit die Änderung aktiv wird.

Kann Dir leider nicht sagen was das jetzt genau im System bewirkt, würde mich ja eigentlich auch interessieren, hab aber noch keine Zeit gefunden da mal zu recherieren ...

So long

ThomasF
______________________

Ich bin /root, ich darf das !
geist_der_foren
Newbie
Newbie
Beiträge: 39
Registriert: 15. Dez 2003, 11:44

Beitrag von geist_der_foren »

@dermichel

Also ich hab die Einstellungen vorgenommen, aber leider funkt das immer noch nicht :?
Ich hab es auch mal Testweiße so Versucht

Code: Alles auswählen

mynetworks_style = subnet 
mynetworks = 0.0.0.0
Aber nichts geht ...

Ich poste dir mal auch die main.cf von Mail Server, von hier aus, kann ich Mails verschicken

Code: Alles auswählen

mynetworks_style = subnet
#mynetworks = 10.206.176.153, 10.206.176.217, 10.206.176.79, 127.0.0.0/8
mynetworks = 0.0.0.0/8
readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = g8ser007.mvs.telekom.de
inet_interfaces = 127.0.0.1
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain, 10.206.176.153
defer_transports =
disable_dns_lookups = no
relayhost = mailbb.de 
content_filter =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions = permit_mynetworks
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,check_relay_domains
alias_maps = hash:/etc/aliases
Aber er nihmt keine an, wenn ich von einem anderen Client auf dem Server Sende ?!
Hier hast du mal die Log von Mail-Client

Code: Alles auswählen

Dec 22 09:52:41 linux.gateway postfix/pickup[20048]: 95A1C3EC72: uid=0 from=<root>
Dec 22 09:52:41 linux.gateway postfix/cleanup[23190]: 95A1C3EC72: message-id=<20041222085241.95A1C3EC72@linux.gateway.de>
Dec 22 09:52:41 linux.gateway postfix/qmgr[20049]: 95A1C3EC72: from=<root@linux.gateway.de>, size=320, nrcpt=1 (queue active)
Dec 22 09:52:41 linux.gateway postfix/cleanup[23190]: A21F63EC71: message-id=<20041222085241.95A1C3EC72@linux.gateway.de>
Dec 22 09:52:41 linux.gateway postfix/local[23192]: 95A1C3EC72: to=<msp@linux.gateway.de>, relay=local, delay=0, status=sent (forwarded as A21F63EC71)
Dec 22 09:52:41 linux.gateway postfix/qmgr[20049]: A21F63EC71: from=<root@linux.gateway.de>, size=460, nrcpt=1 (queue active)
Dec 22 09:52:41 linux.gateway postfix/smtp[23193]: connect to 10.206.176.153[10.206.176.153]: Connection refused (port 25)
Dec 22 09:52:41 linux.gateway postfix/smtp[23193]: A21F63EC71: to=<username@domain.de>, relay=none, delay=0, status=deferred (connect to 10.206.176.153[10.206.176.153]: Connection refused)
Der Server generiert leider keine log :(

@ThomasF
Danke dir für den Tipp, die einstellungen waren auf no gesellt, aber nach dem ich die Änderungen vorgenommen habe, hat sich leider auch nichts geändert :?:
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

mynetworks = 0.0.0.0/8

hast du da nicht ne "1" vergessen?

mynetworks = 10.0.0.0/8
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
geist_der_foren
Newbie
Newbie
Beiträge: 39
Registriert: 15. Dez 2003, 11:44

Beitrag von geist_der_foren »

Hallo, danke für die Hilfe, ich hab das endlich hinbekommen, und zwar habe ich inet_interfaces auf ALL gesetzt (inet_interfaces = ALL) und jetzt geht auch :D
Ich werde dann alles rechner eintragen, die mailen dürfen, aber jetzt weiß ich wenigstens wie das funkt :D
THX noch mal
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

stimmt, haette mir gleich auffallen muessen:

inet_interfaces = 127.0.0.1

der hat die ganze zeit nur auf localhost gehoert :-)
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
geist_der_foren
Newbie
Newbie
Beiträge: 39
Registriert: 15. Dez 2003, 11:44

Beitrag von geist_der_foren »

dermichel hat geschrieben:stimmt, haette mir gleich auffallen muessen:

inet_interfaces = 127.0.0.1

der hat die ganze zeit nur auf localhost gehoert :-)
Mach nichts, das mit dem relayhost = [ip_des_gateways] was du oben schon beschrieben hattest, wuste ich auch nicht ;) Viellendank noch mal für die Hilfe.
Braucht man den eintrag, den ThomasF genannt hatte ?

Code: Alles auswählen

SMTPD_LISTEN_REMOTE="yes"
Oder kann man das jetzt auch weg lassen und für was steht er eigentlich ?
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

das ist yast und suse-krempel - da kenne ich mich nicht aus. ich setze meine parameter selbst und lasse mir meine config-dateien nicht vom suse-config "verbollern" :-)
ich hab die main.cf selbst aufgebaut mit kommentaren etc - da brauche ich keinen newbie-yast :-)

.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
geist_der_foren
Newbie
Newbie
Beiträge: 39
Registriert: 15. Dez 2003, 11:44

Beitrag von geist_der_foren »

sagen wir mal so, ich mach das auch lieber selber, aber ich wollt nur wissen ob man das jetzt braucht bzw. für was das jetzt gut sein soll ?!
Gesperrt