Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

PDA mit Suse Linux 9.2 verbinden! Wie?

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
fredi2_de
Newbie
Newbie
Beiträge: 31
Registriert: 30. Jun 2004, 19:24

PDA mit Suse Linux 9.2 verbinden! Wie?

Beitrag von fredi2_de »

Hallo, habe einen HP IPAQ 5550 Pocket PC. Wollte nun fragen wie den PDA mit Linux syncronisieren kann?

Wäre um Hilfe sehr dankbar

Mfg
fredi2_de
Benutzeravatar
spidernob
Newbie
Newbie
Beiträge: 10
Registriert: 26. Feb 2004, 19:50
Wohnort: bei Hildesheim

Beitrag von spidernob »

Hallo Fredi2_de,

es wäre toll, wenn Du mal erwähnen würdest, was du schon versucht hast. Suche mal unter google nach SynCE, da solltest Du weitere Hilfe finden.

Ich experimentiere schon länger mit einem DELL Axim, wenn es bei mir hinhaut, werde ich versuchen eine HowTo daraus zu machen.

Gru0 von Spider
Benutzeravatar
onkelchentobi
Guru
Guru
Beiträge: 1899
Registriert: 11. Feb 2005, 15:54
Wohnort: BW - Stuttgart
Kontaktdaten:

Beitrag von onkelchentobi »

bei mir ist genau das gleiche auf meinem ipaq 2210
allerdings kann man wenn der pde bluetooth hat ihn mit dem pc verbinden. allerdings braucht man am pc auch einen usb bluetooth stick. ich habe mir einen besorg und es funktioniert. mit hilfe von

bluetooth obex object push client

kann ich auf den pda zugreifen meine daten hin und her schicken usw... kanns jedem nur empfehlen es mit bluetooth zu versuchen.
GNU/Debian Linux - Testing 32 Bit / Kernel 2.6.30.2 Vanilla / Ion3 - 20090110 / i2p

*** NO E-PATENTS ***
schuelsche
Newbie
Newbie
Beiträge: 5
Registriert: 7. Jun 2004, 22:10

Beitrag von schuelsche »

Spidernob hat geschrieben: Ich experimentiere schon länger mit einem DELL Axim, wenn es bei mir hinhaut, werde ich versuchen eine HowTo daraus zu machen.
Hallo, da ich mit dem Gedanken spiele, mir einen Dell Axmin zuzulegen, würde ich gerne wissen, ob die Anbindung an SuSE 9.2 geklappt hat und wenn ja, wie Du das gemacht hast.

Grüsse
schuelsche
schuelsche
Newbie
Newbie
Beiträge: 5
Registriert: 7. Jun 2004, 22:10

Beitrag von schuelsche »

Hallo,

nachdem bei mir die Anbindung vom Dell Axim X50 mit SuSE 9.2 / SuSE 9.3 teilweise geklappt hat, hier eine kurze Anleitung.

Allerdings habe ich noch das Synchronisationsproblem. Das heisst, ich kann zwar mit den Kommandozeilentools von synce auf das Gerät zugreifen und auch Daten hin- und herschieben. Allerdings ist bei mir der Synchronisationsknopf von Raki grau hinterlegt und ich kann mit nix synchronisieren.

Aber ich beschreibe mal kurz, was ich gemacht habe:
Ich habe zunächst synce 0.9.0, synce-kde 0.8.0 und synce-devel 0.9.0 von der SuSE CD installiert.
Ausserdem alle multisync-Pakete, die ich auf der CD gefunden habe.

Dann habe ich den PDA an das System angeschlossen und mit usbview nach der vendor- und product-Number geschaut. Wichtig ist hier, dass in usbview nur zwei Endpoints angezeigt werden.
Die vendor- und product-Nummer habe ich dann in /etc/modprobe.conf in einer Zeile eingetragen:

options ipaq vendor=0x.... product=0x....

Das Gerät habe ich dann erst mal wieder vom USB-Anschluss entfernt. Es ist ganz sinnvoll, die ganze Zeit als root "tail -f /var/log/messages" mitlaufen zu lassen, damit man sieht, was passiert.

Bevor der PDA dann wieder eingesteckt wird, sollte man das Modul ipaq laden. Ich weiss leider nicht genau, wo das standardmässig eingetragen wird, ich habe keine - wie im synce-Tutorial angegeben - /etc/rc.local. Vielleicht weiss da jemand anderes was, wo man den Befehl /sbin/modprobe ipaq dann einträgt...

Wenn man den PDA wieder einsteckt, dann sollte in den messages folgendes stehen:

kernel: usb 1-1: new full speed USB device using address 4
kernel: ipaq 1-1:1.0: PocketPC PDA converter detected
kernel: usb 1-1: PocketPC PDA converter now attachedto ttyUSB0
/etc/dev.d/tty/50-visor.dev[9554]: add tty device /class/tty/ttyUSB0

Man startet dann als user (!! - nicht als root) dccm (einfach auf der Konsole dccm eingeben).

Dann gibt man als root folgenden Befehl auf der Konsole ein:
synce-serial-config ttyUSB0

Es sollte dann die Meldung erscheinen:
You can now run synce-serial-start to start a serial connection.

Dann gibt man als root ein:
synce-serial-start

Die Ausgabe sieht dann so aus:
Serial connection established.
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB0
local IP address 192.168.131.102
remote IP address 192.168.131.201
Script /etc/ppp/ip-up finished (pid 9607), status = 0x0

Ob die Verbindung wirklich steht, sieht man dann, wenn man zB als User einen ping auf 192.168.131.201 macht. Ausserdem aber auch mit dem Befehl pstatus.

Wenn man dann Dateien hin- und herschieben will, dann macht man das folgendermassen (Befehlsübersicht siehe http://synce.sourceforge.net/synce/tools.php):
pls / => zeigt das Inhaltsverzeichnis auf dem PDA an
pls /Programme/ => zeigt das Inhaltsverzeichnis von Programme
(wichtig ist, immer einen / am Ende zu machen, wenn es sich um ein Verzeichnis handelt).

Dateien kopieren kann man dann mit:
Pcp :/programme/dateiname.txt dateiname.txt

Wichtig ist dabei das grosse P!

Um die Verbindung zu beenden, entweder dccm beenden (über den kill-Befehl) oder aber als Root mit STRG+C die Verbindung, die mit synce-serial-start begonnen wurde, beenden. Oder mit synce-serial-stop.

Naja, soweit bin ich also schonmal gekommen. Langt wenigstens zum Sichern des Backups auf dem PDA.

Unter SuSE 9.2 hat Raki genau einmal funktioniert, danach nie wieder. Unter SuSE 9.3 funktioniert Raki irgendwie immer. Allerdings kann ich in beiden Versionen nicht synchronisieren. Habe verzweifelt versucht, das synce-multisync-plugin zu installieren. Das funktioniert aber irgendwie nicht. Auch das eigenhändige Kompilieren von multisync, um dann die nötigen Header für die multisync-plugin-Installation zu haben, scheitert an irgendwelchen fehlenden Dateien. Da komme ich nicht weiter.

Hat das mal jemand geschafft unter SuSE 9.2/9.3 multisync richtig zum Laufen zu bringen?! Und wenn ja, wie?? Ich würde gerne mit evolution synchronisieren...

Grüsse
schuelsche
Benutzeravatar
roemi
Advanced Hacker
Advanced Hacker
Beiträge: 822
Registriert: 1. Apr 2004, 19:01
Wohnort: Hanau
Kontaktdaten:

Beitrag von roemi »

habe ich doch glatt übersehen ... verschieb ich mal zu usb
Martin.Fay
Newbie
Newbie
Beiträge: 5
Registriert: 21. Aug 2004, 20:59
Wohnort: Neu-Isenburg

Beitrag von Martin.Fay »

schuelsche hat geschrieben:Hallo,


Unter SuSE 9.2 hat Raki genau einmal funktioniert, danach nie wieder. Unter SuSE 9.3 funktioniert Raki irgendwie immer. Allerdings kann ich in beiden Versionen nicht synchronisieren. Habe verzweifelt versucht, das synce-multisync-plugin zu installieren. Das funktioniert aber irgendwie nicht. Auch das eigenhändige Kompilieren von multisync, um dann die nötigen Header für die multisync-plugin-Installation zu haben, scheitert an irgendwelchen fehlenden Dateien. Da komme ich nicht weiter.

Hat das mal jemand geschafft unter SuSE 9.2/9.3 multisync richtig zum Laufen zu bringen?! Und wenn ja, wie?? Ich würde gerne mit evolution synchronisieren...

Grüsse
schuelsche
Also ich habe unter 9.3 wehnigstens Raki korrekt zum laufen bekommen. Die Firewall ist der Übeltäter: YAST>Sys-Config-Editor\
Network\Firewall\SuseFirewall2\ Key FW_FORWARD=192.168.131.102,192.168.131.201 eintragen und das gibt scon mal die Ip's frei.
zusätzlich habe ich noch die Ports 5801 5901 in FW_SERVICES_EXT_TCP eingetragen bei denen ich mir aber nicht so sicher bin.

Eine Anbindung zu Evolution ist mir bis jetzt aber damit leider auch noch nicht geglückt.
BlueT anbindung geht eigentlich garnicht zu meinem PDA (Typhoon/ETEN M500)
Vieleicht kann da ein mitleser helfen ???

Beste Grüße
Martin Fay
Martin.Fay
Newbie
Newbie
Beiträge: 5
Registriert: 21. Aug 2004, 20:59
Wohnort: Neu-Isenburg

Beitrag von Martin.Fay »

Update:

Also eine Anbindung meines M500 mit Multisync ist mir jetzt geglückt,
aber nur unter Ubuntu Linux (debian basierende distro).
Dort ist mit dem auf APT basirendem Install von Multisync die wohl
aktuelleste Version verwendet worden (CVS5) mit dieser Version können
alle Funktionen des Evolution Plugins genutzt werden. (Hura!) :D

Bleibt nur zu hoffen das bald jehmand für die SuSE 9.3 die passenden RPM's 'backt' und die Suse-Gemeinde damit beglückt.:P

Beste Grüße

Martin
Antworten