Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

apt für x86_64

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
wdso
Newbie
Newbie
Beiträge: 24
Registriert: 19. Dez 2004, 15:27

apt für x86_64

Beitrag von wdso »

Hi,

Ich bin gerade dabei apt unter SuSE 9.2 64bit einzurichten. Im x86_64 Verzeichnis sind leider keine apt rpms zu finden. Die Installation der i386 Pakete schlägt fehl:

Code: Alles auswählen

error: Failed dependencies:
librpm-4.1.so is needed by apt-0.5.15cnc6-rb.suse092.6
librpmdb-4.1.so is needed by apt-0.5.15cnc6-rb.suse092.6
librpmio-4.1.so is needed by apt-0.5.15cnc6-rb.suse092.6
librpm-4.1.so is needed by apt-libs-0.5.15cnc6-rb.suse092.6
librpmdb-4.1.so is needed by apt-libs-0.5.15cnc6-rb.suse092.6
librpmio-4.1.so is needed by apt-libs-0.5.15cnc6-rb.suse092.6
Was nicht verwunderlich, da ich das 64bit rpm installiert habe. Diese stellt folgende .so Dateien bereit (provides)

Code: Alles auswählen

rpm -q --provides rpm
rpminst
librpm-4.1.so()(64bit)
librpmbuild-4.1.so()(64bit)
librpmdb-4.1.so()(64bit)
librpmio-4.1.so()(64bit)
perl(RPM::Specfile) = 1.02
rpm = 4.1.1-191
Ich habe auch schon versucht die src.rpms per rpmbuild --rebuild für 64bit zu übersetzen, aber das klappte nicht (vermutlich der Grund, warum das Verzeichnis leer ist).

Was nun?

Danke schon mal im voraus,
Tristan
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

die apt RPMs für 9.2-64bit stehen im Repository suser-jmorris ;)

http://ftp.gwdg.de/pub/linux/suse/apt/S ... r-jmorris/

Nachtrag:
(die apt RPMs für 9.1-64bit stehen im Repository suser-rbos)
Zuletzt geändert von oc2pus am 19. Dez 2004, 15:58, insgesamt 1-mal geändert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
wdso
Newbie
Newbie
Beiträge: 24
Registriert: 19. Dez 2004, 15:27

Beitrag von wdso »

danke, das ging fix!
:D
Antworten