Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] mplayer-Installation auf SuSE 9.1 64Bit?

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
ManuLöwe
Newbie
Newbie
Beiträge: 46
Registriert: 30. Jul 2004, 11:09
Kontaktdaten:

[solved] mplayer-Installation auf SuSE 9.1 64Bit?

Beitrag von ManuLöwe »

Hallo zusammen,

da xine bei mir nach wie vor spinnt (berüchtigtes Piepsen aus dem Lautsprecher samt nachfolgendes verrücktes Verhalten der Tastatur), wollte ich mplayer probieren, der mir oft empfohlen wurde.

Das Problem ist, ich habe einen 64Bit-Rechner samt SuSE 9.1 64bit. Ich habe mir von Packman alles geholt, was ich brauche, und die "failed dependencies", die beim ersten Installationsversuch gemeldet wurden, nach und nach abgearbeitet. Nun sind aber zwei übrig, um die ich einfach nicht herumkomme.

Wenn ich jetzt als root eingebe:

Code: Alles auswählen

rpm -ivh MPlayer-1.0pre5-pm.1.i686.rpm
dann erscheint die Meldung:

Code: Alles auswählen

warning: MPlayer-1.0pre5-pm.1.i686.rpm: V3 DSA signature: NOKEY, key ID 5f6842a4
error: Failed dependencies:
        libdv.so.2 is needed by MPlayer-1.0pre5-pm.1
        liblirc_client.so.0 is needed by MPlayer-1.0pre5-pm.1
Das Seltsame ist, daß ich sowohl libdv und lirc installiert habe. Unter /usr/lib64 werden beide Dateien aufgelistet. Ich ging davon aus, daß der mplayer (weil ein 32-Bit-Programm) nichts mit diesen Bibliotheken anfangen kann, und versuchte also, die 32-Bit-Pakete von lirc und libdv zu installieren: Keine Chance, da von beiden installierten 64-Bit-Paketen zuviel abhängt (u. a. auch die xmms-Plugins), als daß eine Ersetzung durch die Packman-Versionen möglich wäre.
Eine manuelle Kopie der beiden Dateien von /usr/lib64 nach /usr/lib half auch nicht. Meine einzige Hoffnung ist jetzt, die Dateien in der 32-Bit-Version irgendwoher zu bekommen und nach /usr/lib zu kopieren.

Hat irgend jemand von Euch ein ähnliches Problem bzw. kann mir helfen? Oder gibt es 64-Bit-RPMs für den mplayer? Irgendwie hab ich so langsam das dumme Gefühl, daß ich mit meinem AMD64 hier so ziemlich auf verlorenem Posten sitze. :cry:
mainboard
Newbie
Newbie
Beiträge: 18
Registriert: 20. Nov 2004, 19:43
Wohnort: S/A

Beitrag von mainboard »

nimm mal das http://ftp.gwdg.de/pub/linux/suse/apt/S ... x86_64.rpm
spielt bei mir alles (*.mov leider ohne Ton)
ManuLöwe
Newbie
Newbie
Beiträge: 46
Registriert: 30. Jul 2004, 11:09
Kontaktdaten:

Beitrag von ManuLöwe »

Hey, mainboard, ich danke Dir! :D Auch da gab es erst ein paar Abhängigkeiten zu lösen, aber dank der von Dir gelinkten Seite war das kein Problem (bei der Gelegenheit flogen natürlich die 32-Bit-RPMs wieder weg, heh).

mplayer läuft also jetzt wunderbar. Sag, gibt's dazu eigentlich auch ne GUI (ähnlich wie bei xine)? Das fehlt mir jetzt noch zu meinem Glück. Achja, und weißt Du *zufällig* (ich laß keine Gelegenheit zu fragen aus :wink: ), ob es irgendwo ein RPM von OpenOffice.org 1.1.4 für 9.1 64 Bit gibt? ...

Dickes Dankeschön, mainboard! :) :idea:
mainboard
Newbie
Newbie
Beiträge: 18
Registriert: 20. Nov 2004, 19:43
Wohnort: S/A

Beitrag von mainboard »

den mplayer einfach mit gmplayer aufrufen.
verschiedene skin´s kannste dir nach ~/.mplayer/Skin/ packen
OO rpm´s - keine Ahnung.
ManuLöwe
Newbie
Newbie
Beiträge: 46
Registriert: 30. Jul 2004, 11:09
Kontaktdaten:

Beitrag von ManuLöwe »

mainboard hat geschrieben:den mplayer einfach mit gmplayer aufrufen.
Ach! Cool! Manchmal ist es halt so einfach! :) Danke Dir.

edit: Eine Frage hätte ich aber noch. Wenn ich mit mplayer DVDs abspiele (was bei mir funktioniert :P ), läuft der Film sofort los, ohne vorher das Menü anzuzeigen. Mit xine ist dem nicht so, alle Menüs erscheinen normal. Brauche ich da ein bestimmtes Plugin für mplayer?
Antworten