Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

smbpasswd

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Peak
Newbie
Newbie
Beiträge: 13
Registriert: 5. Jul 2004, 09:27

smbpasswd

Beitrag von Peak »

ich habe einen redhat 9 server mit samba 3.09 am laufen. das ganze funktioniert bis an einen gewissen punkt sehr gut.
wenn ich versuche einen rechner an die domain zu nehmen, dann kommt die meldung, dass der benutzer nicht gefunden werden konnte.

wenn ich smbpasswd -a root eingebe kommt folgendes:

Code: Alles auswählen

> smbpasswd -a root
Can't load /etc/samba/smb.conf - run testparm to debug it
params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/smb.conf":
	No such file or directory
die smb.conf liegt eigentlich bei /usr/local/samba/lib/smb.conf

wenn ich nun smbpasswd aus dem verzeichnis /usr/local/samba/bin ausführe, dann scheint alles wunderbar zu gehen. der user wird auch in /usr/local/samba/private/smbpasswd eingetragen. das problem liegt darin, dass wenn ich nun den client an die samba domain nehmen will, der benutzer noch immer nicht gefunden wird. auch im webmin unter samba->sambabenutzer wird angezeigt, dass keine sambabanutzer eingerichtet worden sind.

kann mir jemand sagen, wo das problem liegt?

ursprünglich war auf dem server das samba rpm von redhat, samba 2.7 installiert. dieses habe ich deinst, die sources von samba.org heruntergeladen, kompiliert und installiert.

falls noch infos notwendig sind, bitte sagen. ich werde diese natürlich gerne geben.
Nukem36
Hacker
Hacker
Beiträge: 337
Registriert: 28. Okt 2004, 08:58
Wohnort: Im schwarzen Walde

Beitrag von Nukem36 »

Hallo Peak!

du hast meiner Meinung nach ein simples Pfad- Problem! Wenn Du Samba compilierst, wird in die Programme fest eingebunden, wo sie die smb.conf, smbpasswd etc. suchen. An diesem Ort musst Du auch deine Files ablegen.

Schau Dir das mal in Deine Sourcen an. Hoffe das hilft etwas weiter! Mit ./configure --help bekommst Du die Variablen, über die Du steuern kannst welche Pfade verwendet werden sollen:

schnipp....
By default, `make install' will install all the files in
`/usr/local/samba/bin', `/usr/local/samba/lib' etc. You can specify
an installation prefix other than `/usr/local/samba' using `--prefix',
for instance `--prefix=$HOME'.

For better control, use the options below.

Fine tuning of the installation directories:
--bindir=DIR user executables [EPREFIX/bin]
--sbindir=DIR system admin executables [EPREFIX/sbin]
--libexecdir=DIR program executables [EPREFIX/libexec]
--datadir=DIR read-only architecture-independent data [PREFIX/share]
--sysconfdir=DIR read-only single-machine data [PREFIX/etc]
--sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
--localstatedir=DIR modifiable single-machine data [PREFIX/var]
--libdir=DIR object code libraries [EPREFIX/lib]
--includedir=DIR C header files [PREFIX/include]
--oldincludedir=DIR C header files for non-gcc [/usr/include]
--infodir=DIR info documentation [PREFIX/info]
--mandir=DIR man documentation [PREFIX/man]
Wenn Deine Progs /etc/samba als Pfad erwarten, mach es Dir doch einfach und kopiere die smb.conf und smbpasswd da hin!?


Bis denn
Nukem36
Sie brauchen einen neuen Monitor? Dann bitte hier (X) bohren!
Peak
Newbie
Newbie
Beiträge: 13
Registriert: 5. Jul 2004, 09:27

Beitrag von Peak »

Danke Nukem36

Nach dem das auch nicht wirklich so funktioniert hat wie es eigentlich sollte, habe ich den Samba 3.09 mittels make uninstall wieder deinst und das original rpm von Redhat wieder drauf gespeielt. Jetzt ist Samba 2.27 drauf. Die smb.conf habe ich von der vorherigen konfig übernommen.

Weiter habe ich auch das original rpm vom samba-swat inst. So weit so gut.

Wenn ich nun die Winbox an den samba hängen will, dann kommt:

Code: Alles auswählen

Bei dem Versuch der Domäne "ts-management" beizutreten, trat der folgende Fehler auf:

Mit diesem Konto kann man sich nicht von diesem Computer aus anmelden. 
Versuche ich nun den Benutzer root in die smbpasswd einzutragen kommt folgende meldung raus:

Code: Alles auswählen

> smbpasswd -a root
New SMB password:Retype new SMB password:Unknown parameter encountered: "ldap ssl"
Ignoring unknown parameter "ldap ssl"
Unknown parameter encountered: "add machine script"
Ignoring unknown parameter "add machine script"
load_client_codepage: filename /usr/share/samba/codepages/codepage.850 does not exist.
load_unicode_map: filename /usr/share/samba/codepages/unicode_map.850 does not exist.
load_unicode_map: filename /usr/share/samba/codepages/unicode_map.ISO8859-1 does not exist.


unable to open passdb database.
Nach eingabe und wiederholung des zu verwenden Passwortes für den root, kommt aber trotz dem:
Added user root.

Ich hoffe, ich habe alle nötigen infos geposted. Falls etwas fehlen sollte, bitte sagen. Dann werde ich Auskunft geben.
Nukem36
Hacker
Hacker
Beiträge: 337
Registriert: 28. Okt 2004, 08:58
Wohnort: Im schwarzen Walde

Beitrag von Nukem36 »

Hallo Peak!

war ne Weile beschäftigt. Was deinem Samba fehlt ist ein Maschinenaccount für die Windows-Kiste. Im Moment "hängt" er am erstellen des Maschinen-Accounts. Den kannst Du auch zu Fuß anlegen. Sieh Dir die man-pages zu smbpasswd an. In deiner smb.conf kannst Du auch einen Eintrag vornehmen, der für neue Maschinen einen Maschinen-Account anlegt.

Bei mir sieht der so aus:

Code: Alles auswählen

add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
Wichtig: Welches Windows greift zu?? XP Home wirst Du nicht einbinden können, wenn Samba als Domänen-Controller läuft! Geht per se nicht, da XP Home hierzu Funktionalitäten fehlen. So bringt MS die Leute dazu von Home auf Professional upzudaten!

Bis denn
Nukem36
Sie brauchen einen neuen Monitor? Dann bitte hier (X) bohren!
Antworten