Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

mkisofs

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
lega
Newbie
Newbie
Beiträge: 29
Registriert: 9. Dez 2003, 16:03

mkisofs

Beitrag von lega »

Hallo User,
ich möchte mir von meiner SuSE-DVD eine Sicherungs-DVD machen und die Originale schonen.
Das Erstellen der Daten hat gut geklappt; aber bei der ISO-Erstellung habe ich immer den gleichen Fehler:

INFO: UTF-8 character encoding detected by locale settings.
Assuming UTF-8 encoded filenames on source filesystem,
use -input-charset to override.
mkisofs: Missing pathspec.
Usage: mkisofs [options] file...

Use mkisofs -help
to get a list of valid options.

Alles wurde als Benutzer im root-Terminal eingegeben.
Wer kann mir dazu Hilfestellung geben?
Danke
lega
gaw
Hacker
Hacker
Beiträge: 464
Registriert: 28. Sep 2004, 16:33

Beitrag von gaw »

Wie wäre es mit dd?

mfG
gaw
reini123

Re: mkisofs

Beitrag von reini123 »

Hi,
hab mal ein paar Scripte zu diesen Thema erstellt.
Findest unter http://www.call4wall.com/bash/
iso-tools installiert unter /usr/bin 3 kleine scripte .... vielleicht hilft Dir das weiter !?

Mƒg ®êïñï

Ps.: Wenn Du die genaue Syntax die Du verwendest hast gepostet haettest waere es leichter die Ursache zu ermitteln #fg#
}-Tux-{
Hacker
Hacker
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ »

Hi

probiere es am Besten so:

mkisofs -v -r -J -o ZIEL DATEI

ZIEL ersetzt du dann durch Speicherort wo das Ganze gespeichert werden soll und DATEI ersetzt in deinem Fall durch den Mountpoint des DVD-Laufwerks indem sich die DVD befindet.

mfg }-Tux-{
reini123

Re: mkisofs

Beitrag von reini123 »

hmm ....
obwohl die dd variante was fuer sich hatt ?¿
dd if=/dev/hda1 | gzip -c - | cdrecord -v dev=1,0 speed=8 -
( natuerlich must Du Dein dev und Deinen Speed anpassen )
Waere zumindest compakter !

Mƒg ®êïñï
gaw
Hacker
Hacker
Beiträge: 464
Registriert: 28. Sep 2004, 16:33

Beitrag von gaw »

dd habe ich zunächst vorgeschlagen um ein Image der dvd zu erzeugen.

dd conf=noerror, sync if=/dev/xxx of=susesicherungsimage bs=2048

Das lässt sich anschließend mit cdrecord brennen ohne mit mkisofts überhaupt in Berührung zu kommen.


mfG
gaw
reini123

Beitrag von reini123 »

Natuerlich gaw,
war Dein Vorschlag LOL
Es tut mir leid wenn Du den Eindruck gewonnen hast ich will Dir Deinen Vorschlag wegnehmen #grins#
Wollte ihn nur um eine Syntax ergaenzen hehehe

Mƒg ®êïñï
gaw
Hacker
Hacker
Beiträge: 464
Registriert: 28. Sep 2004, 16:33

Beitrag von gaw »

Ich habe nicht diesen Eindruck gewonnen, sondern wollte nur verdeutlichen wie ich das meinte. Übrigens ist conv=noerror, sync besonders bei DVD und CD's eine interessante Option...

mfG
gaw
Claus-Peter
Newbie
Newbie
Beiträge: 5
Registriert: 30. Mai 2004, 23:47

Re: mkisofs

Beitrag von Claus-Peter »

lega hat geschrieben:Hallo User,
ich möchte mir von meiner SuSE-DVD eine Sicherungs-DVD machen und die Originale schonen.
Das Erstellen der Daten hat gut geklappt; aber bei der ISO-Erstellung habe ich immer den gleichen Fehler:

INFO: UTF-8 character encoding detected by locale settings.
Assuming UTF-8 encoded filenames on source filesystem,
use -input-charset to override.
mkisofs: Missing pathspec.
Usage: mkisofs [options] file...

Use mkisofs -help
to get a list of valid options.

Alles wurde als Benutzer im root-Terminal eingegeben.
Wer kann mir dazu Hilfestellung geben?
Danke
lega
Hallo lega,
ich weiß nicht, ob das Problem noch aktuell ist, aber ich hatte gestern das gleiche Problem. Die Fehlersuche ergab folgendes:

"Note #1: If you are getting this error: mkisofs: Missing pathspec, you have
missed out the final period in the command line. Go take a careful look
again. The period is important as it tells mkisofs to include all
files/subdirectories in the current directory to the ISO image."

Auf Deutsch: ans Ende der Kommandozeile gehört noch ein Punkt (".")
Den hatte ich vergessen. Danach lief's wie geschmiert.

Gruß
CP
Antworten