Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

postfix -wie mails veschicken?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
nu-FLow
Newbie
Newbie
Beiträge: 29
Registriert: 13. Mai 2004, 14:36

postfix -wie mails veschicken?

Beitrag von nu-FLow »

Hoi,

also ich habe folgendes setup:
-SuSE 9.1
-lampp Server (Apache2, php4, mysql)
apache und php funktionieren einwandfrei.

So, ich habe ein Kontaktforumular geschireben, wass zB bei meinem provider webspace problemlos funktioniert.
(nutzt die mail() funktion von php)
mail("$to", "$subject", "$name has sent you a message on $datum.\n\n
Thanx $firma","From: $from\n"); usw...

So, wenn ich das beim provider hochlade, mail mir das script so wie es soll.

So, wenn ich das bei mir in die /htdocs hänge, kann ich mit dem browser auch drauf zu greifen, rufe das formualr
auf, fülle es aus, clicke auf den senden button, ausgabe mail erfolgreich verschickt - doch es kommt nix an.

also kommt postfix ins spiel?
Zusammenfassen, wie kann ich von meinem kontaktformuilar, was bei mir zuhause auf einem rechner mit apache + php liegt,mailen?
(Der rechner ist mit fester IP im internet)

BZW, wie ist die syntax, um einfach auf der Konsole mit der "mail"-Funktion zu testen, obn man mail verschicken kann?

[# mail test@domain.de Subject: usw]
Oder kann das ohne weiters gar nicht funktionieren?

Ich habe SuSE 9.1 komplett installiert und daher startet postfix automatisch mit

danke leute
__

h.a.nice.d

__
Benutzeravatar
ThomasF
Hacker
Hacker
Beiträge: 578
Registriert: 1. Mai 2004, 12:37
Wohnort: Köln

Beitrag von ThomasF »

Hi,

ich glaube Du hast ein ganz anderes Problem ....

Du verwendest ja lampp, und Du kannst ja mal suchen aber in /opt/lampp wirst Du kein Postfix finden .... ;-)

Lampp arbeitet sozusagen in einer chroot-Umgebung, also hast Du keinen direkten Zugriff auf Postfix, das mußt Du strickt trennen !!!

Da ich mich mit lampp nicht so gut auskenne weiß ich nicht ob Du aus dem lampp mit PHP direkt einen SMTP Server ansprichst oder über den "mail" Befehl aus dem lampp Verzeichis gehst.

Such doch mal hier im lampp Bereich :

http://www.linux-club.de/viewforum.php?f=22

oder im Forum von apachefriends.de

Grundsätzlich gibt es zwei Varianten um von der Konsole aus Mails zu schicken :

a. mit dem mail Befehl siehe man mail oder mail --help

b. mit telnet auf Port 25 des Mailservers um dann SMTP zu sprechen ;-)

So long

ThomasF
______________________

Ich bin /root, ich darf das !
kleineso
Newbie
Newbie
Beiträge: 33
Registriert: 28. Apr 2004, 23:14
Wohnort: Düsseldorf
Kontaktdaten:

Beitrag von kleineso »

Hallo,


entgegen dem was Thomas schrieb, bin ich der Meinung das es eine Konfigurationssache ist.

Dein Script kenne ich nicht, aber bei fertigen PHP-Scripts ist es ja so, dass man zumindest einen SMTP Server angeben muss usw.
Abhängig von deiner Postfixkonfiguration, die du uns leider auch verheimlicht hast, benötigt man evtl. noch Authentifizierung.

Was sagen denn die Logs darüber? # tail -f /var/log/mail (etc.)


Grüße, olli
nu-FLow
Newbie
Newbie
Beiträge: 29
Registriert: 13. Mai 2004, 14:36

Beitrag von nu-FLow »

hi,

danke schomal für eure posts.

Also vielleicht lassen wir das mail script erstmal aussenvor, ich will ja zunächst zusehen, dass ich überhaupt ne mail rauskriege...:)

Postfix startet also beim boot mit....
Wie gesagt nur den lampp installiert fertig. Was mewinst du mit postfix konfiguration? Die main.cf? Die habe ich noch nichtmal angeschaut ;)
Sollte ich wohl, was?^^ Muss ich da einen SMTP eintragen, nen externen vom provider oder ähnliches, bzw welche informationen wären da relevant?

ich bin morgen wieder am testrechner, dann poste ich mal die logs.

danke schonmal
__

h.a.nice.d

__
Benutzeravatar
ThomasF
Hacker
Hacker
Beiträge: 578
Registriert: 1. Mai 2004, 12:37
Wohnort: Köln

Beitrag von ThomasF »

Hmmm,

gut auf den zweiten Blick ist es dann wohl ein Postfix Problem ;-)

Mich hat die Erwähnung von Lampp etwas verwirrt ...

Also fang doch mal lieber mit Deinem PHP Script an, ich denke dort hast Du einen SMTP Server eingetragen ...
Steht dort localhost oder die IP Deines Rechners ?

Du hast die Config von Postfix nicht geändert ?

Standardmässig läuft Postfix nur für den Empfang lokaler Mails ...

Damit er auch Mails auf seiner IP annimmt sollte erst mal in /etc/sysconfig/mail folgendes stehen SMTPD_LISTEN_REMOTE="yes"

Außerdem glaube ich nicht das Du Mails direkt an den Empfänger ausliefern willst, also mußt Du den SMTP Server Deines Providers angeben ...

Für einfache Einstellungen von Postfix versuche es mal mit Yast oder in der Datei /etc/sysconfig/postfix (Nach Änderungen per Hand immer SuSEconfig ausführen)

Wenn es dann immer noch nicht klappt beobachte während des Sendversuchs die Maillogs "tail -f /var/log/mail "


So long

ThomasF
______________________

Ich bin /root, ich darf das !
Gesperrt