Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Pixelige und schlecht lesbare Schriftendarstellung - KDE

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

olaflange
Newbie
Newbie
Beiträge: 18
Registriert: 13. Feb 2004, 18:29

Pixelige und schlecht lesbare Schriftendarstellung - KDE

Beitrag von olaflange »

Hallo,

ich hab nun schon ziemlich viel im Netz gesucht und rumprobiert, leider stehe ich immernoch vor folgendem Problem unter Suse 9.0, KDE 3.1:

Alle Schriften werden auf meinem Notebook sehr pixelig und dadurch schlecht zu lesen dargestellt (in allen Programmen). Auf einem anderem Rechner auf dem Suse 8.1 installiert ist, ist die Schrift deutlich lesbarer und einbandfrei. Wie erreiche ich diese Darstellung nun auch auf meinem Notebook?

Schließe ich übrigens mein Notebook an den Bildschirm des anderen Rechners an, ist die Darstellung weiterhin schlecht, es scheint also nicht an dem Bildschirm ansich zu liegen, unter Windows war die Ausgabe auf dem Notebook einbandfrei.

Der Rechner mit dem Schriftenproblem ist ein Notebook mit folgenden
Merkmalen:

- Marke Asus (L8400K Serie, 850MHZ, 256 RAM)
- Grafikkarte laut Hersteller S3 Savage/MX 2X AGP VGA chip
- Monitor: 14.1" active matrix color TFT (1024*786 Auflösung)

Die Grafikkarte wird von Linux anscheinend richtig erkannt und als Bildschirm habe ich einen LCD mit entsprechender Auflösung ausgewählt, auch ein "Vesa" Bildschirm mit der Auflösung löst nicht das Problem.

Auch das ein- bzw. ausschalten von Kantenglättung (Anti-Alaising) bzw. Sub-Pixel-Hinting hat nichts gebracht, keinen sichtbaren Unterschied. Bilder und Grafiken werden übrigens - für mein Empfinden - einbandfrei dargestellt. Das Problem liegt ausschließlich in der schlechten Darstellung der Schrift. Das ganze wirkt so, als wenn man einbischen viel gesoffen hat, ne Brille braucht oder auf 800x600 Auflösung auf einem 1024er LCD fährt ...

Hat jemand ne Idee, wie ich die alle Schriften richtig auf meinem Gerät darstellen kann?

Freue mich über Antwort und schon mal Danke für Eure Hilfe,
Gruss Olaf
Gerd
Member
Member
Beiträge: 56
Registriert: 13. Feb 2004, 10:57

Beitrag von Gerd »

Hallo.

guckst du hier http://www.linux-club.de/viewtopic.php?t=2094
Vielleicht hilfts Dir das ja auch.

Gerd
olaflange
Newbie
Newbie
Beiträge: 18
Registriert: 13. Feb 2004, 18:29

Beitrag von olaflange »

Hallo Gerd,

erstmal danke für den Tipp! Ich sollte das vielleicht wirklich mal ausprobieren.

Gibt es keine "einfachere" Lösung? Das klingt für mich als "Linux-Neuling" irgendwie nach ner recht komplizierten Sache. Ich dachte irgendwie, dass es vielleicht an etwas viel einfacherem liegt...

Gruss Olaf
SharkMan66
Newbie
Newbie
Beiträge: 6
Registriert: 12. Feb 2004, 01:28
Kontaktdaten:

Beitrag von SharkMan66 »

und da ist es wieder das problem. wenn man hier als anfänger eine frage stellt bekommt man nur sehr selten eine gescheite antwort. ist den tollen cracks hier ohl zu blöd drauf zu antworten. soviel zum thema linuxer helfen gerne. da gibt es aber wesentlich freundlichere win-foren :(
Gerd
Member
Member
Beiträge: 56
Registriert: 13. Feb 2004, 10:57

Beitrag von Gerd »

olaflange hat geschrieben:Hallo Gerd,

erstmal danke für den Tipp! Ich sollte das vielleicht wirklich mal ausprobieren.

Gibt es keine "einfachere" Lösung? Das klingt für mich als "Linux-Neuling" irgendwie nach ner recht komplizierten Sache. Ich dachte irgendwie, dass es vielleicht an etwas viel einfacherem liegt...

Gruss Olaf
Hallo Olaf,
ich bin auch erst seit einer Woche bei Linux, aber vielleicht ist meine Erklährung oben zu dürfitg ausgefallen (tschuldigung). Da ich aber bis vor kurzem meine Kommunikation unter Windows erledigt hatte, musste ich vieles aus dem Kopf nachvollziehen (beim dem mir auch noch nicht vertrautem Pfad-Gewussel unter Linux nicht so einfach).
Wenn ich am Sonntag mal Zeit habe, verfasse ich eine detailiertere Fassung. Ist ja auch für andere Linux-NGs dann geeignet.

@SharkMan66: TROLL

viele Grüße,
Gerd
olaflange
Newbie
Newbie
Beiträge: 18
Registriert: 13. Feb 2004, 18:29

Beitrag von olaflange »

Hallo Gerd,

das wäre natürlich total super!!!

Ich kann mir gut vorstellen, dass sich so mein Problem lösen lässt. Und ich suche echt schon seit ein paar Tagen im Netz nach ner Lösung :cry: wäre Dir also super dankbar!

Gruss und schönes Wochenende,
Olaf
the0dor
Newbie
Newbie
Beiträge: 17
Registriert: 14. Feb 2004, 13:19

@Gerd

Beitrag von the0dor »

Hallo, Gerd!

Ich bin der "Gast" der den anderen Thread wg. Schrift begonnen hat. Vielen Dank für den Tipp, ich werde es mal versuchen. Ansonsten fänd ich es auch total gut, wenn Du es noch idiotensicherer beschreiben würdest, ich bin auch so'n blutiger Anfänger :?

Nachtrag an olaflange:
Endlich mal einer, der das Problem genauso beschreibt, wie ich es auch kenne :D . Ich kam mir schon wie ein Idiot vor in anderen Foren...
olaflange
Newbie
Newbie
Beiträge: 18
Registriert: 13. Feb 2004, 18:29

Beitrag von olaflange »

Hallo Ihr,

ich sehe schon hier haben sich die Richtigen gefunden :wink:

Erstmal nochmal sorry, dass ich hier einen extra Thread aufgemacht habe, der andere war ja eigentlich auch schon mit diesem Thema. Habe ich irgendwie damals verpeilt.

Nunja also ich hoffe wir finden jetzt irgendwie ne Lösung, ich baue da ja ganz auf die kommende Beschreibung von Gerd :)

Ansonsten kann ich euch noch empfehlen in folgendes Forum zu schauen, dort habe ich auch mein Problem geschildert und ne interessante Antwort erhalten, der Link: http://linuxforum.lxforum.de/linuxforum ... ?p=798#798

Gruss Olaf
Gerd
Member
Member
Beiträge: 56
Registriert: 13. Feb 2004, 10:57

unscharfe Schriften in KDE beseitigen.

Beitrag von Gerd »

Hallo,

auf mehrfachen Wunsch hin veröffentliche ich hier mal eine detailiertere Anweisung um Schriften unter KDE besser lesbarer zu machen. Ich kann jeden der das hier anwendet nur raten alles vorher noch mal selber genau durchzugehen, vor allem die von mir angegebenen Komandozeilenparameter mittels den man-pages oder Info-Seiten zu überprüfen. Fehler schleichen sich immer wieder mal ein und als root sowas ausgeführt kann einem innerhalb der kürzestens Zeit ein ganz anderes Look and Feel geben. Vor allem ein anderes Feeling.
Solltet ihr Fehler bei meinen Ausführungen entdecken, würde ich mich freuen, wenn ihr mir das meldet.

Um unter SuSE 9.0 in KDE die Schriften lesbarer zu machen, d.h. die Unschärfe herauszubekommen, habe ich zwei Dinge unternommen: 1. freetype2 neu kompiliert und installiert, 2. TrueType-Schriftarten aus Windows installiert und alle in KDE verwendeten Fonts durch einen TTF ersetzt.
Ich beschreibe jetzt das Vorgehen in vertauschter Reihenfolge. Vielleicht reicht ja schon die Verwendung von TTFs um das Problem zu lösen. Wenn nicht muss doch auch noch freetype2 neu kompiliert werden. Ansonsten kann man sich zurücklehen und freuen, dass es so einfach ging.

A.) TrueType-Fonts installieren:
Wenn man eine Windows-Installation hat, hat man wahrscheinlich schon einige TTFs in C:\WINNT\Fonts. Wenn nicht, mal nach TrueType-Fonts zum Downloaden googlen.
  • 1.Kontrollzentrum öffnen
    2.Systemverwaltung/Schriften-Installation
    3.Hier müsste alles selbsterklärend sein. Nur darauf achten, dass im rechten Fenster „Installieren In“ der Auswahl-Balken auf TrueType steht. Links den Pfad zu seinen TrueType-Schriften angeben.
    4.Dann im Kontrollzentrum/Erscheinungsbild & Design/Schriften für alle aufgeführten Schriften eine von den neu installierten TTFs nehmen. Ich persönlich nehme für alles Tahoma und bei fester Breite Courier New.
    5.AntiAliasing für schriften von 5,0 – 16,0 pt ausschalten.
    6.Ich selber hab noch Sub-Pixel-Hinting für RGB aktiviert. Hier vielleicht selber mal rumprobieren.
Wenn jetzt alles gut aussieht: FREUEN :-)

Ansonsten:

B.) freetype2 neu kompilieren:
Für die folgenden Operationen seid ihr am Besten als Root eingelogged.

I. Das Source-rpm für freetype2 installieren:
  • 1. Ich habe die 2. Seite der DVD dafür genommen. Wer nur die CDs hat muss selber mal nach der Datei suchen.
    2.Konqueror öffnen. Nach /media/dvd/suse /src gehen. Auf das File freetype2-2.1.4-65.src.rpm klicken. Dann mit YAST installieren wählen.
II. Die Sourcen anpassen:
  • 1.Jetzt müsste in /usr/src/packages/SPECS die Datei freetype2.spec zu finden sein.
    2.Diese mit seinem Lieblingseditor öffnen.
    3.Nach %patch100 -p 1 -b .bytecode suchen und # davor entfernen
    4.Eine Konsole öffnen und folgendes ausführen:
    5.rpmbuild -bb /usr/src/packages/SPEC/freetype2.spec
III. Die enstandenen RPMs installieren:
Im Verzeichnis /usr/src/packages/RPMS/i586 (oder entsprechend seiner Hardware) befinden sich jetzt 2 freetype2-*.rpm Dateien. Diese wie gehabt mit Komquerer oder auf Komandozeile via rpm installieren.

Das war ja dann auch nicht so schwer :-)

viele Grüße,
Gerd
olaflange
Newbie
Newbie
Beiträge: 18
Registriert: 13. Feb 2004, 18:29

Beitrag von olaflange »

Hallo Gerd,

erstmal vielen Dank für die ausführliche Beschreibung!

Bis zu dem Punkt "B)II.5" gibt es bei mir keine Probleme, nur kann ich das Paket nicht richtig neukompilieren. Erst erhilt ich eine Fehlermeldung, dass das Paket "automake" fehlte, welches ich aber nachinstallieren konnte, danach entstand dann folgende Fehlermeldung, wo ich nicht mehr weiter weiß:

Code: Alles auswählen

[...]
drwxr-xr-x freetype/freetype      0 2003-04-08 11:15:21 freetype-2.1.4/ 
tests/ 
-rw-r--r-- freetype/freetype    720 2002-08-19 08:06:44 freetype-2.1.4/ 
tests/Jamfile 
-rw-r--r-- freetype/freetype  39511 2002-08-27 22:20:29 freetype-2.1.4/ 
tests/gview.c 
+ STATUS=0 
+ '[' 0 -ne 0 ']' 
+ cd freetype-2.1.4 
++ /usr/bin/id -u 
+ '[' 0 = 0 ']' 
+ /bin/chown -Rhf root . 
++ /usr/bin/id -u 
+ '[' 0 = 0 ']' 
+ /bin/chgrp -Rhf root . 
+ /bin/chmod -Rf a+rX,g-w,o-w . 
+ echo 'Patch #1 (freetype-bdf-pcf-drivr.patch):' 
Patch #1 (freetype-bdf-pcf-drivr.patch): 
+ patch -p1 -b --suffix .bdf-pcf-drivr -s 
+ echo 'Patch #2 (freetype2-bitmap-style.patch):' 
Patch #2 (freetype2-bitmap-style.patch): 
+ patch -p1 -b --suffix .bitmap-style -s 
+ echo 'Patch #3 (freetype2-bitmap-foundry.patch):' 
Patch #3 (freetype2-bitmap-foundry.patch): 
+ patch -p1 -b --suffix .bitmap-foundry -s 
+ echo 'Patch #4 (gzip-eof.patch):' 
Patch #4 (gzip-eof.patch): 
+ patch -p1 -b --suffix .gzip-eof -s 
+ echo 'Patch #100 (freetype2-bc.patch):' 
Patch #100 (freetype2-bc.patch): 
+ patch -p1 -b --suffix .bytecode -s 
+ AUTOMAKE_DIR=/usr/share/automake 
+ '[' -d /usr/share/automake ']' 
+ AUTOMAKE_DIR=/usr/share/automake* 
+ '[' -d /usr/share/automake-1.7 ']' 
+ test -f ./config.sub -a '!' ./config.sub -ef /usr/share/automake-1.7/ 
config.sub 
+ test -d . -a '!' -f ./depcomp -a -f /usr/share/automake-1.7/depcomp 
+ cp -f /usr/share/automake-1.7/depcomp ./depcomp 
+ echo 'please add depcomp to sources for new automake!' 
please add depcomp to sources for new automake! 
+ test -f ./missing -a '!' ./missing -ef /usr/share/automake-1.7/missing 
+ test -f ./config.guess -a '!' ./config.guess -ef /usr/share/ 
automake-1.7/config.guess 
+ test -d . -a '!' -f ./depcomp -a -f /usr/share/automake-1.7/depcomp 
+ test -f ./missing -a '!' ./missing -ef /usr/share/automake-1.7/missing 
+ test -f ./ltconfig 
+ test -f ./ltmain.sh 
+ export 'CFLAGS=-O2 -g -march=i586 -mcpu=i686 -fmessage-length=0 -g ' 
+ CFLAGS=-O2 -g -march=i586 -mcpu=i686 -fmessage-length=0 -g 
+ make setup 'CFG=--prefix=/usr --libdir=/usr/lib --without-zlib' 
/var/tmp/rpm-tmp.29244: line 85: make: command not found 
error: Bad exit status from /var/tmp/rpm-tmp.29244 (%prep) 
RPM build errors: 
    Bad exit status from /var/tmp/rpm-tmp.29244 (%prep) 
Eine Idee warum der Fehler entsteht?

Kannst Du mir vielleicht ansonsten das neukompilierte Paket via E-Mail zusenden, damit ich da mal weiterkomme? (Meine Mailaddy: pfadi@olaflange.de) Das wäre echt klasse!

Ansonsten sind mir noch zwei Kleinigkeiten bei Deiner Beschreibung aufgefallen, der Vollständigkeits wegen hier:

- B)I.2 Das konnte ich nicht nachvollziehen, ich hab deswegen die Sache einfach über die Konsole mit "rpm -i pfad" (pfad natürlich ersetzen) installiert
- B)II.5 fehlt ein S im Pfad: "SPECS" ist richtig

Gruss Olaf
the0dor
Newbie
Newbie
Beiträge: 17
Registriert: 14. Feb 2004, 13:19

Beitrag von the0dor »

Hi Gerd!

Auch von mir ein Dankeschön, ich werde das mal die nächsten Tage ausprobieren und hoffe, es wird auch klappen. Nur die TTF's installieren hat mir noch nicht geholfen, da muss ich also mehr aufbieten...
the0dor
Newbie
Newbie
Beiträge: 17
Registriert: 14. Feb 2004, 13:19

Beitrag von the0dor »

Bei mir gibt's den selben Fehler wg. automake. Wie kann ich das denn installieren?
Frage an Gerd: Hat das bei Dir auch gefehlt?
olaflange
Newbie
Newbie
Beiträge: 18
Registriert: 13. Feb 2004, 18:29

Beitrag von olaflange »

Hallo Ihr,

ich will Euch noch mal den letzen Stand meiner Schriften-Probleme mitteilen, vielleicht helfen Euch ja die Informationen.

Also erstmal noch mal vielen Dank an Gred, er hat mir das neukompilierte Package geschickt und damit geht es super (zumindest was die Windows-Schriften angeht, aber wenn man alles auf die umstellt ist die Darstellung einbandfrei. Ein entspannendes Gefühl für die Augen...) :)

Ansonsten habe ich vor ein paar Tagen noch mal bei Suse im Support nachgefragt, worauf ich folgende Antwort bekommen habe. Ich habe das gerade mal getesten, kann aber keinen Unterschied feststellen... Aber vielleicht hilft es Euch ja weiter.
[...]
Von dem Display des Laptop kommen anscheinend keine brauchbaren Werte,
um eine zufriedenstellende Darstellung zu erreichen. Das Problem ist
aber durch einen speziellen Parameter zu beheben, der entweder bei der
Konfiguration mit YaST2/SaX2 mit eingetragen werden kann, oder Sie können
diesen Parameter auch manuell als root mit einem Texteditor, wie z.B.
vi, pico oder mcedit in der Konfigurationsdatei für den Xserver eintragen.
Letzteres ist wahrscheinlich ein wenig schneller zu erledigen, da YaST2
oder SaX2 immer ein wenig Zeit für den Start benötigt.

Ich schlage vor, Sie starten das System in den Runlevel 3 (Textmodus),
indem Sie in der Zeile "Boot Options:" des Bootmenues die Ziffer "3"
eingeben und diese Eingabe mit der ENTER Taste bestätigen.
Melden Sie sich als root an, die Eingabe des Passwortes muss quasi
"blind" erfolgen, weil es keine optische RÜckmeldung gibt. Wenn Sie
als root eingeloggt sind öffen Sie die Datei /etc/X11/XF86Config mit
einem Texteditor, hier am Beispiel mcedit:

mcedit /etc/X11/XF86Config

Suchen Sie weiter unten den folgenden Abschnitt:

Section "Device"
BoardName "86C270-294 Savage/MX-/IX"
BusID "1:0:0"
Driver "savage"
Identifier "Device[0]"
VendorName "S3"
EndSection


und ändern diesen in:


Section "Device"
BoardName "86C270-294 Savage/MX-/IX"
BusID "1:0:0"
Driver "savage"
Option "UseBIOS"
Identifier "Device[0]"
VendorName "S3"
EndSection


Speichern Sie diese Änderung (F2 = save) und beenden Sie mcedit (F10 = exit).
Wieder im Textmodus geben Sie

init 5

ein, um in den grafischen Modus (Runlevel 5) zu gelangen. Testen Sie die
Funktion. Grundsätzlich lässt sich diese zusätzlich Option auch im
"Expert" bzw. "Erweitert" Menue für die Grafikkarte innerhalb von
YaST2/SaX2 markieren und wird dann in die Konfigurationsdatei eingetragen.
[...]
Und theOdor: Automake kannst Du über das Yast einfach nachinstallieren, ist auf der Suse DVD 1 drauf. Allerdings komme ich danach dann auch noch nicht weiter, wenn ich das Paket neukompilieren will... Naja, wenn ich Dir das neukompilierte Paket zusenden soll, schick mir einfach ne E-Mail. Ansonsten noch viel Glück!

Gruss Olaf
the0dor
Newbie
Newbie
Beiträge: 17
Registriert: 14. Feb 2004, 13:19

Beitrag von the0dor »

Goooooiiiiiillllll :D :D :D

Tausendfachen Mega-Dank an Gerd und Olaf, ich habe einfach nicht nachgelassen, mittlerweile habe ich suse neuinstalliert, dann ging es plötzlich mit den neukompilierten Paketen und ich habe die TTF von Windows wie von Gerd beschrieben installiert.
Jetzt frage ich mich nur: wie um alles in der Welt kommt jemand auf sowas, und wieso kriegt das SuSE nicht von selbst gebacken?
Naja, eh wurscht, ich finde es einfach nur super!!!
Und Gerd: bleib dem Forum ja erhalten :wink:

...kleiner Nachtrag: und tschüss, Windows!
Gast

Beitrag von Gast »

Ja Geil!!
Das hat alles super geklappt. Besten Dank!

Wenn Ich jetzt noch meine TV Karte in Gang kriege brauch Ich kein Windows mehr *freu*

Also nochmal.... DANKE! :D
Gast

Beitrag von Gast »

>Eine Idee warum der Fehler entsteht?

Damit das funktioniert müssen die Kernel Sourcen installiert sein.
Ansonsten kommt dieser fehler. Jedenfalls war es bei mir so.
GLehnhoff

ES KLAPPT NICHT !!!

Beitrag von GLehnhoff »

Ach, dass ist doch alles so frustrierend. Ich babe keine Lust, Kopfschmerzen zu bekommen und werde wieder zu Windows wechseln müssen, wenn dass mit den Schriften nicht endlich klappt.

Der Vorschlag der Suse-Hotline weiter oben bringt gar nichts. So viel zu der Qualität der Hotline.

Und dann das von Gerd: Ich mache genau, was er sagt, ABER, /usr/src/packages/SPECS ist und bleibt leer.

Kann ich vielleicht auch das kompilierte Paket haben? Und kann Gerd mir vielleicht sagen, was ich damit machen muss? Meine eMAil: Leni008@web.de.

Danke im Voraus - vielleicht bringt es ja doch noch was mit Linux. An solch "Kleinigkeiten" hängt die Akzeptanz.

mfg Gerhard
GLehnhoff
Newbie
Newbie
Beiträge: 25
Registriert: 12. Apr 2004, 16:56
Wohnort: Wächtersbach / Germany
Kontaktdaten:

Hab's gepackt

Beitrag von GLehnhoff »

Nach Jahren, vielen Postings und ewiger Suche habe ich es auch gepackt:

Ich habe einigermaßen klare Schriften.

Ich habe Gerds Anweisung und die Kommentare befolgt. Nur der Konqueror wollte nicht entpacken. Der Kommandozeilenbefehl hat's dann aber getan. Den hatte ich aus dem Verweis zu einem anderen Thema, auch von Gerd.

Und, ja, es ist besser, mit 3 Ausnahmen: Mozilla (mail und browser), OpenOffice und MicrosoftOffice (über CrossOver). Vielleicht klappt's ja damit auch noch irgendwann.

Man muss danach aber noch viel mit Schriften experimentieren, und speziell mit Größen. Ich bin jetzt erst mal bei Microsoft Sans Serif mit Schriftgröße 7 hängen geblieben. So ganz überzeugt mich das aber noch nicht.

Kantenglättung ist eingeschaltet. Alle weiteren Experimente führten zu nix.

Gerd, fühle dich geküsst.

Warum das allerdings Suse nicht in den Griff bekommt, ist mir ein Rätsel. Noch merh Rätsel ist mir, dass Gerd der Einzige war, der die Lösung hatte - und ich suche wirklich schon 2 Jahre danach.

mfg gl :D
the0dor
Newbie
Newbie
Beiträge: 17
Registriert: 14. Feb 2004, 13:19

Beitrag von the0dor »

Und, ja, es ist besser, mit 3 Ausnahmen: Mozilla (mail und browser), OpenOffice und MicrosoftOffice (über CrossOver). Vielleicht klappt's ja damit auch noch irgendwann.
Hast Du unter OpenOffice die Kantenglättung deaktiviert? Das muss man nämlich dort separat einstellen (nicht über KDE-Kontrollzentrum).
OpenOffice --> Extras --> Optionen --> Ansicht --> Häkchen bei "Bildschirmschriften glätten" deaktivieren.
Man muss danach aber noch viel mit Schriften experimentieren, und speziell mit Größen. Ich bin jetzt erst mal bei Microsoft Sans Serif mit Schriftgröße 7 hängen geblieben. So ganz überzeugt mich das aber noch nicht.
Ich benutze Tahoma, Größe 8...

Ich frage mich nur, warum Du Kantenglättung eingeschaltet hast, wenn ich das mache, sieht's genauso besch*** aus wie vorher.
GLehnhoff
Newbie
Newbie
Beiträge: 25
Registriert: 12. Apr 2004, 16:56
Wohnort: Wächtersbach / Germany
Kontaktdaten:

Beitrag von GLehnhoff »

Also,

es scheint alles doch ein wenig komplizierter zu sein.

Generell (Suse 9, KDE 3.1 und Gnome 2. irgendwas):
Ich verwende jetzt Verdena 7. Verdena 8 sieht schrecklich aus. Verdena 7, Arial 7, Tohama 7, machen kaum einen Unterschied. Also ist es die Größe der Schriften, die zumindest bei mir mit ausschlaggebend für die Qualität ist. Dies mag vielleicht etwas mit meinem LCD-Bildschirm (Asus Laptop 1400x1028) und dessen Auflösung zu tun haben. Wer weiß. Aber, wie bereits gesagt, unter Windows habe ich keinerlei Probleme mit Schriften, egal welche und welche Größe.

Schriften sind weiterhin unter Windows, selbst im VWware-Fenster, besser.

Kantenglättung ein oder aus machen weder bei KDE noch bei Gnome einen Unterschied, mit einer (bis jetzt gefundenen) Ausnahme: Konqueror! Mit Kantenglättung sind die Schriften der aufgerufenen Webseiten deutlich schlechter. Weiße Schrift auf schwarzem Hintegrund verschwindet teilweise. Deswegen ist Kantenglättung bei mir jetzt ausgeschaltet, weil Konqueror der einzige Browser ist, der überhaupt aufgerufene Webseiten am besten anzeigt (mehr dazu weiter unten)

OpenOffice (Version 1.1, gilt für KDE und Gnome):
Schalte ich die Kantenglättung in OpenOffice aus, ist die Schrift ganz schrecklich, irgendwie so abgehackt und teilweise verschwindend (im Verlauf des Striches des i zum Beispiel). Schalte ich die Kantenglättung ein, ist die Schrift auf jeden Fall deutlich besser, aber mit verschwommenen Rändern. Ein wenig bessere Resultate bekam ich dadurch, dass ich die Schriftgröße auf 90% setze. OpenOffice verhält sich damit umgekehrt zu Konqueror ... das soll einer verstehen ...

OpenOffice/Windows (auch unter VMWare):
Unter Windows ist OpenOffice Sahne.

Mozila/Gnome:
Mozilla (1.6) unter Gnome (Menuleisten, etc.) sieht nun gut aus. Schriften und Größen verhalten sich analog zu Gnome. Die Einstellungen in Mozilla unter Erscheinungsbild/Schriftarten scheinen keinen Einfluß zu haben.
ABER: Die aufgerufenen Web-Seiten sind teilweise schrecklich und kaum lesbar (weiße Schrift auf schwarzen Untergrund z. B. kaum lesbar. Das gleiche Problem wie das obige mit dem i unter OpenOffice).

Mozilla/KDE:
Alles Schrecklich! Schriften (Menuleisten) viel zu groß! Schrecklich im Aussehen. Aufgerufene Webseiten genauso beschissen wie unter Gnome.

Mozilla/Windows (inkl. VMware):
Sahne.

Konqueror (KDE + Gnome):
Verhalten wie Desktop. Aufgerufene Web-Seiten 1a (wenn unter KDE die Kantenglättung ausgeschaltet ist).

Epiphany 1.0.8/Gnome:
Sieht gut aus (Menüleisten, etc.). Aufgerufenen Webseiten genauso beschissen wie bei Mozilla (liegt wahrscheinlich auch darunter).

Fazit:
Also kurz gesagt: meine Euphorie von gestern ist eigentlich schon wieder verschwunden. Ja, es ist eine Besserung durch Gerds Änderung eingetreten. Aber, umhauen tut sie mich nicht und wichtige Programme, mit denen ich arbeite, kommen weiterhin nicht im Leisesten an Windows-Qualität heran.

Tja, so isses eben mit Linux. Jetzt habe ich aber genug Zeit damit verbracht und muss mal wieder ein wenig produktiv arbeiten. Ich schaue in ein paar Tagen nochmals hier herein um zu sehen, ob es noch Überlegungen gibt.

Vielleicht, vielleicht kommen wir aber auch gar nicht in dieser Diskussion weiter, weil Sehen und Geschmacksempfindung sehr relativ sind. Was ich für schlecht halte, mag ein Anderer als akzeptabel empfinden. Vielleicht sollten wir es mal mit Screenshots probieren. Vielleicht mache ich das mal ... vielleicht ...
Antworten