Seite 1 von 1

Bei kinternet-protokoll: pppd options error (exit code2)

Verfasst: 4. Dez 2004, 17:18
von murov
suse 9.2: Wenn ich eine Internetverbindung aufbauen will, wird beim Protokoll sofort "disconnected" und "ppp[0] died: pppd options error (exit code 2)" angezeigt. Ich habe das Modem neu konfiguriert und die Verbindungsdaten kontrolliert - dabei ist mir nichts Ungewhnliches aufgefallen. Wie kann ich prüfen, ob das Modem richtig funktioniert (bei Windows ist es kein Problem. Internes Modem, Laptop, analog)? Ich habe den neuesten Treiber von Conexant (so dass also auch dieses winmodem funktionieren sollte) installiert. Vielleicht habe ich aber auch was bei kinternet vergessen oder irgendein Modul nicht geladen (smpppd und ppp sind geladen)? Wer kann weiterhelfen :?:

Verfasst: 6. Dez 2004, 11:04
von NeoMan
Der Exit-Code 2 deutet meist auf ein nichtgeladenes Modul oder bei Problemen mit dem Provider bzw. bei DSL mit der DSL-Leitung hin. Es kann auch sein, das die Geräteschnittstelle nicht korrekt konfiguriert ist.

Ich würde erst prüfen ob dein Modem den Treiber von Intel 536 braucht. Wenn ja installieren diesen und stelle unter Modemgerät /dev/536ep ein.


MfG NeoMan

Verfasst: 6. Dez 2004, 14:26
von murov
Vielen Dank für die Bemühung um Hilfe! Ich bin inzwischen selbst fündig geworden: Über die Installation von "minicom" (kleines Internettool bei linux) konnte ich die Funktionsfähigkeit des Modems überprüfen. Schließlich stellte ich fest, dass Yast2 die falsche Konfigurationsdatei wählte (/dev/tty...). Diesen Fehler verbesserte ich und dann ging's. Auch die Berechtigung musste geändert werden (Zugehörigkeit zu Gruppe uucp).

Jetzt ist aber immer noch das Problem, dass der konqueror unerwartet die Internetverbindung löst, wenn z.B. ein Server nicht gefunden wird.

MfG DR