Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

AMAVIS richtig einstellen

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

AMAVIS richtig einstellen

Beitrag von BiZNiZ »

Ich weiss ...

... es steht hier schon x-mal was zum Thema AMaVis ...

... aber mein "problemchen" finde ich nicht ....

1. in der amavis.conf steht zwar alles wunderbar drin, so wie es sein soll, und auch in den mails mit den Virus-Meldungen findet sich völlig korrekt die Zeile

The message has been quarantined as:

/var/virusmails/virus-20041201-173612-14416

... ein Blick in /var/virusmails zeigt aber deutlich, dass der Ordner leer ist ...

Wo also finde ich diese mails wieder ???

2. Mails mit infizierten Anhängen werden komplett geblockt - nicht nur der Anhang ...

3. Die testmail von c't mit dem Bagle-Virus wird trotzdem zugestellt !!!

4. obwohl in der conf eingetragen ist, dass auch der recipient eine info erhalten soll, passiert dies nicht ...
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

in der amavis.conf steht zwar alles wunderbar drin
dann zeig uns diese wunderbare Konfiguration mal :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

mach ich ...

Beitrag von BiZNiZ »

... und zwar gleich morgen früh, wenn ich wieder @work bin ;)

'ne Frage vorab habe ich dennoch:

Das ganze läuft bei uns auf 'nem SLOX 4.1 mit cyrus, postfix, spamassassin und amavis-d ...

Da hier fast alle Tipps auf dem amavisd-new basieren, spiele ich mit dem Gedanken, diesen zu installieren ...

Da mittlerweile schon einige mit der freien Variante OX und amavisd-new arbeiten, sollte es doch "eigentlich" keine Probleme geben ...
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

einen Schritt weiter ...

Beitrag von BiZNiZ »

... bin ich schon mal ...

Die "infifzierten" mails werden jetzt auch abgelegt. Lag an den Zugriffsrechten auf den Ordner ....

Mittlerweile läuft meine mail-queue voll und in /var/log/mail steht immer der Eintrag:

Code: Alles auswählen

Dec  2 11:41:18 slox postfix/qmgr[10330]: warning: connect to transport smtp-amavis: Connection refused 
irgendwas scheint in den config's noch zu fehlen ...

Deshalb mal auszugsweise die einzelnen configs:

amavisd.conf:

Code: Alles auswählen

# Norman Virus Control 
$norman = "/usr/bin/nvcc";

# requeue if all virus scanners failed
$requeue_on_scanner_errors = "yes";


#
# Part II - Logging
#

# yes - syslog, no - file logging
$DO_SYSLOG = "yes";

# Directory to put log entries (if not using syslog)
$LOGDIR = "/var/spool/vscan/amavis";
$LOGFILE = "amavis.log";

# 0: default - startup/exit/failure messages
# 1: args passed from client
# 2: virus scanner output
# 3: server client
# 4: decompose parts
$log_level = 2;

#
# Part III - Virus stuff
#

# Notify admin/sender/recipient?
$warnadmin = "yes";
$warnsender = "yes";
$warnrecip = "yes";

# Notify off-site recipients?
$warn_offsite = "no";

# List of local domains
# e.g. @local_domains = qw( dom.ain other.dom.ain );
@local_domains = qw(vhs-heidekreis.de it-basics.de);

# Location to put infected mail - empty for not quarantining
$QUARANTINEDIR = "/var/virusmails";

# Add X-Virus-Scanned line to mail?
$X_HEADER_TAG = "X-Virus-Scanned";
# Leave empty to add no header
$X_HEADER_LINE = "by AMaViS snapshot-20020531";

####################################################

#
# Part IV - External programs
# (perl modules do not exist for these yet)
#

$arc = "/usr/bin/arc";
$bunzip = "/usr/bin/bunzip2";
$file = "/usr/bin/file";
$lha = "/usr/bin/lha";
$unarj = "/usr/bin/unarj";
$uncompress = "/usr/bin/uncompress";
$unrar = "/usr/bin/unrar";
$zoo = "/usr/bin/zoo";

#
# Part V - MTA specific stuff
#

# Qmail-specific
$QMAILDIR = "/bin";

# postfix-specific
$smtp_port = "10025";
$localhost_name = "localhost";
$localhost_ip = "127.0.0.1";

# sendmail-specific
# Do we use amavis on a mail relay/gateway type setup?
$enable_relay = "no";

#
$sendmail_cf_orig = "";

# What sendmail wrapper to use
$sendmail_wrapper = "/usr/sbin/sendmail";
$sendmail_wrapper_args = "-i -t";

#
# Part VI - Misc
#

# The next three are resource limitations - exit with EX_TEMPFAIL if exceeded
# Maximum recursion level for extraction/decoding
# default: 20 - DO NOT SET THIS TO 0
$MAXLEVELS = 20;

# Maximum nesting level for compressing archive formats
# default: 3. If set to 0, feature is disabled
$MAX_ARCHIVE_NESTING = 3;

# Maximum number of extracted files
# default: 500. If set to 0, feature is disabled
$MAXFILES = 500;

# Magic number to detect DoS attacks
# default: 14. if set to 0, feature is disabled (change with care!)
$threshold = 14;

# Who reports are sent from
$mailfrom = 'postmaster';

# Where to send virus reports
$mailto = 'virusalert';

# Display AMaViS credits to users
$credits = "no";
 
hier der Auszug aus der main.cf

Code: Alles auswählen

content_filter=  
und hier die master.cf

Code: Alles auswählen

# ==========================================================================
# service type	private	unpriv	chroot	wakeup	maxproc	command + args
# 		(yes)	(yes)	(yes)	(never)	(50)
# ==========================================================================
smtp	  inet	n	-	n	-	-	smtpd -o content_filter=vscan:
#smtps	  inet	n	-	n	-	-	smtpd -o content_filter=vscan: -o smtpd_tls_wrappermode=yes
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission	inet	n	-	n	-	-	smtpd
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628	  inet	n	-	n	-	-	qmqpd
pickup	  fifo	n	-	n	60	1	pickup
cleanup	  unix	n	-	n	-	0	cleanup
qmgr	  fifo	n	-	n	300	1	qmgr
#qmgr	  fifo	n	-	n	300	1	nqmgr
tlsmgr	  fifo	-	-	n	300	1	tlsmgr
rewrite	  unix	-	-	n	-	-	trivial-rewrite
bounce	  unix	-	-	n	-	0	bounce
defer	  unix	-	-	n	-	0	bounce
flush	  unix	n	-	n	1000?	0	flush
smtp	  unix	-	-	n	-	-	smtp
showq     unix	n	-	n	-	-	showq
error     unix	-	-	n	-	-	error
local	  unix	-	n	n	-	-	local
virtual	  unix	-	n	n	-	-	virtual
lmtp	  unix	-	-	n	-	-	lmtp
localhost:10025 inet	n	-	n	-	-	smtpd -o content_filter=procmail:spamfilter
#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
# The Cyrus deliver program has changed incompatibly.
#
cyrus	  unix	-	n	n	-	-	pipe
  flags=R user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -m ${extension} ${user}
uucp	  unix	-	n	n	-	-	pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
vscan     unix  -       n       n       -       10       pipe
  user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}
procmail  unix  -       n       n       -       -       pipe
  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/imap/procmailrc ${sender} ${recipient} 
Hier noch ein Log-File von Amavis, nachdem der Bagle-Virus durchgelassen wurde ...

Code: Alles auswählen

Dec  2 11:32:29 slox amavisd[16001]: starting.  amavisd snapshot-20020531 Tue Sep 30 18:23:48 UTC 2003
Dec  2 11:32:39 slox amavisd[16031]: /var/spool/vscan/amavis/amavis-XXbguqH4: from=<emailcheck-robot@ct.heise.de>, to=<rpatzke@it-basics.de>
Dec  2 11:32:39 slox amavisd[16031]: Using /usr/bin/nvcc
Dec  2 11:32:39 slox amavisd[16031]: Norman Virus Control Version 5.70.01  Jun 15 2004 10:37:11
Copyright (c) 1993-2003 Norman ASA

NSE revision 5.70.26
nvcbin.def revision 5.70 of 2004/11/29 (59034 variants)
nvcmacro.def revision 5.70 of 2004/11/24 (10037 variants)
Total number of variants: 69071


No infections found.
0 archives unpacked, 1 files found.
1 files, 1 kbytes scanned.

Total scanning time: 0 min. 00 secs.
1 kbytes per second.

Dec  2 11:32:39 slox amavisd[16031]: do_exit:344 - ending execution with 0 
In der Hoffnung, dass jemand eine Idee hat ...
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

... connect to transport smtp-amavis: Connection refused ...
dieser transport ist nicht definiert in deiner Konfiguration ....

sowas sollte in deiner main.cf stehen ....
#####################################
# Tell Postfix to start forwarding all mail it receives to amavisd-new for content inspection.
#####################################
content_filter = smtp-amavis:[127.0.0.1]:10024
und das in der master.cf

Code: Alles auswählen

smtp      inet  n       -       n       -       -       smtpd
    -o content_filter=smtp-amavis:[127.0.0.1]:10024
smtp-amavis unix -      -       n       -       3       lmtp
    -o smtp_data_done_timeout=1800
    -o disable_dns_lookups=yes
127.0.0.1:10025 inet n  -       n       -       -  smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o mynetworks_style=host
    -o strict_rfc821_envelopes=yes
dieses musst du nur für deine "Welt" anpassen ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

das versuche ich ja ...

Beitrag von BiZNiZ »

... aber ich weiß nicht, wo ich den Fehler suchen soll ...

Wenn ich die o.a. Einträge in die main.cf und die master.cf aufnehme ( was ich schon einmal probiert hatte ... ), dann erscheint folgendes in meiner /var/log/mail:

Code: Alles auswählen

Dec  2 14:38:21 slox postfix/postfix-script: starting the Postfix mail system
Dec  2 14:38:21 slox postfix/master[7967]: fatal: bind 127.0.0.1 port 10025: Address already in use
Dec  2 14:39:22 slox postfix/postqueue[8199]: fatal: Cannot flush mail queue - mail system is down 
Also scheint doch der Port 10025 schon irgendwie "belegt" zu sein ...

habe in der amavis.conf diesen Port asl smtp-port eingetragen (default-Einstellung):

Code: Alles auswählen

# postfix-specific
$smtp_port = "10025";
$localhost_name = "localhost";
$localhost_ip = "127.0.0.1"; 
dementsprechend muss doch in der main.cf folgendes stehen:

Code: Alles auswählen

content_filter = smtp-amavis:[127.0.0.1]:10024 
... damit die mails erst einmal an amavis weitergeleitet werden ...

so sollte dann die master.cf so aussehen:

Code: Alles auswählen

smtp      inet  n       -       n       -       -       smtpd
    -o content_filter=smtp-amavis:[127.0.0.1]:10024
smtp-amavis unix -      -       n       -       3       lmtp
    -o smtp_data_done_timeout=1800
    -o disable_dns_lookups=yes
127.0.0.1:10025 inet n  -       n       -       -  smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o mynetworks_style=host
    -o strict_rfc821_envelopes=yes 
... damit die mails anschließend auch wieder an den Port 10025 geschickt werden ...

Welchen Eintrag muss ich denn anpassen ???

Vielleicht nochmals zur Info:

Ich habe hier auf dem SLOX amavis-d ! NICHT den amavisd-new !
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

ob amavis oder amavisd-new spielt doch keine Rolle ...

(25)postfix -> (10024)amvisd-new -> (10025)postfix
(xx) = port

du musst deine transport Definitionen überprüfen und anpassen.

dein "port in use" kommt von hier:
localhost:10025 inet n - n - - smtpd -o content_filter=procmail:spamfilter
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

kann ich den einfach ändern ???

Beitrag von BiZNiZ »

... dachte, dass dieser port von postfix verwendet wird, um überhaupt die mails von amavis annehmen zu können ?!

Welchen sollte ich denn ändern ?

den in der amavis.conf ?
oder den in der master.cf ?

Ich dachte, die mails gehen auf port 25 ein, werden über den content_filter - Eintrag an amavis gegeben und von dort über port 10025 zurück an postfix ?!

habe ich hier einen Denkfehler ???
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
theBruce
Newbie
Newbie
Beiträge: 25
Registriert: 25. Nov 2004, 15:07

Beitrag von theBruce »

Hallo,

also ich bin auch etwas neu in der Materie,aber:
localhost:10025 inet n - n - - smtpd -o content_filter=procmail:spamfilter
Ich würde es mal so versuchen:
localhost:10025 inet n - n - - smtpd -o content_filter=
Ich versteh nicht ganz was in deinem Eintrag passiert, gibst du es da wieder an einen anderen Spamfilter weiter? Am Ende der Kette muss ein Eintrag mit content_filter= stehen ohne etwas dahinter, sonst wird die Mail in eine Endlosschleife gejagt und immer und immer wieder gescannt.

Du übergibst die Mail im Moment nicht von Amavis an Postfix sondern an procmail:spamfilter.

lg theBruce
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

aber gescannt wird sie trotzdem ...

Beitrag von BiZNiZ »

... jedenfalls kommen die "erfolgsmeldungen" von amavis bei mir an ...

ich habe jetzt mal das procmail:spamfilter entfernt ... und es sieht nicht anders aus als vorher ...

die mails kommen gescannt an ...
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: aber gescannt wird sie trotzdem ...

Beitrag von oc2pus »

BiZNiZ hat geschrieben:... jedenfalls kommen die "erfolgsmeldungen" von amavis bei mir an ...

ich habe jetzt mal das procmail:spamfilter entfernt ... und es sieht nicht anders aus als vorher ...

die mails kommen gescannt an ...
kannst du dich mal etwas klarer ausdrücken ? Was geht denn jetzt und was geht nicht ?

und bitte poste die entsprechenden logfile Ausschnitte ...
und keine Konfig-Schnipsel sondern die komplette Konfigdatei ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

was geht und was nicht geht ...

Beitrag von BiZNiZ »

ich kann nur sagen, was ich hier sehe:

Es läuft nicht so, wie es laufen soll - sofern ich das ganze hier richtig verstehe ...

Alle mails kommen erst einmal auf dem Server an.
Sie werden dann ( so, wie's aussieht... ) von amavis gescannt und zugestellt ...

wenn ich nun in die mailqueue schaue, sehe ich aber mails, bei denen ich nicht verstehe, warum diese dort sind und dort hängen ....

hier die ausgabe von mailq:

Code: Alles auswählen

-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
0169129C09*    2075 Wed Dec  1 17:54:36  postmaster@vhs-heidekreis.de
                                         virusalert@vhs-heidekreis.de

4E47D1BAF7*    2137 Thu Dec  2 16:46:27  moenk@linux-club.de
                                         rpatzke@vhs-heidekreis.de

5C08429B69    10376 Thu Dec  2 10:52:57  postmaster@vhs-heidekreis.de
                                                           (temporary failure)
                                         emailcheck-robot@ct.heise.de

8BFB96612    524377 Thu Dec  2 16:55:36  hnorden@vhs-heidekreis.de
                                                    (transport is unavailable)
                                         rpatzke@vhs-heidekreis.de

9490F29C56     9246 Thu Dec  2 10:53:00  postmaster@vhs-heidekreis.de
                                                           (temporary failure)
                                         rpatzke@it-basics.de

9D61729BCE    10812 Thu Dec  2 10:52:59  postmaster@vhs-heidekreis.de
                                                           (temporary failure)
                                         virusalert@vhs-heidekreis.de

-- 547 Kbytes in 6 Requests. 
in /var/log/mail steht auch immer noch der Eintrag:

Code: Alles auswählen

Dec  3 09:01:28 slox postfix/qmgr[23794]: warning: connect to transport smtp-amavis: Connection refused 
ich habe jetzt erst einmal wieder den Zustand hergestellt, den ich bei Beginn des threads hatte, da dieser wenigstens das versenden von mails ermöglicht, was nicht mehr machbar ist, wenn ich die Einträge in main.cf und master.cf ändere !!!

Hier also (auch Wunsch) die komplette main.cf und master.cf:
main.cf:

Code: Alles auswählen

queue_directory= /var/spool/postfix
command_directory= /usr/sbin
daemon_directory= /usr/lib/postfix
debug_peer_level= 2
debugger_command= PATH=/usr/bin:/usr/X11R6/bin
     xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path= /usr/sbin/sendmail
newaliases_path= /usr/sbin/sendmail
mailq_path= /usr/bin/mailq
setgid_group= maildrop
manpage_directory= /usr/share/man
sample_directory= /usr/share/doc/packages/postfix/samples
readme_directory= /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory= /var/mail
canonical_maps= hash:/etc/postfix/canonical
virtual_maps= ldap:ldapvuser,hash:/etc/postfix/virtual
relocated_maps= hash:/etc/postfix/relocated
transport_maps= hash:/etc/postfix/transport,ldap:ldaptransport
sender_canonical_maps= hash:/etc/postfix/sender_canonical
masquerade_exceptions= root
masquerade_classes= envelope_sender, header_sender, header_recipient
myhostname= slox.vhs-heidekreis.de
inet_interfaces= all
masquerade_domains= $mydomain
mydestination= $myhostname, localhost.$mydomain, ldap:ldapvdom
defer_transports=
disable_dns_lookups= no
relayhost= rechner4.hofmann-online.com
content_filter=
mailbox_command=
mailbox_transport= lmtp:unix:public/lmtp
smtpd_sender_restrictions= hash:/etc/postfix/access
smtpd_client_restrictions= permit_sasl_authenticated
smtpd_helo_required= no
smtpd_helo_restrictions=
strict_rfc821_envelopes= no
smtpd_recipient_restrictions= ldap:ldapmailenab,permit_tls_clientcerts,permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
alias_maps= hash:/etc/aliases,hash:/etc/aliases.d/slots,ldap:ldapaliases
alias_database= hash:/etc/aliases,hash:/etc/aliases.d/slots
local_destination_concurrency_limit= 10
mailbox_size_limit= 0
message_size_limit= 30000000
myorigin= $mydomain
recipient_delimiter= +
# relay_clientcerts= ldap:ldaprelcert
# smtpd_tls_CAfile= /etc/ssl/CA/usedCA.pem
smtpd_tls_ask_ccert= yes
# smtpd_tls_cert_file= /etc/ssl/certs/cert.pem
# smtpd_tls_key_file= /etc/ssl/certs/skey.pem
smtpd_tls_received_header= yes
# smtpd_use_tls= yes
tls_daemon_random_source= dev:/dev/urandom
tls_random_source= dev:/dev/urandom

# alias database for SuSE Linux Openexchange Server
ldapaliases_server_host= localhost
ldapaliases_server_port= 389
ldapaliases_bind= no
ldapaliases_timeout= 20
ldapaliases_search_base= dc=vhs-heidekreis,dc=de
ldapaliases_query_filter= (|(alias=%s)(&(fn=%s)(objectclass=SuSEIMAPFolderObject)))
ldapaliases_result_attribute= uid,mailDeliveryProgram,deliverToUID
ldapaliases_scope= one

# virtual user database for SuSE Linux Openexchange Server
ldapvuser_server_host= localhost
ldapvuser_server_port= 389
ldapvuser_bind= no
ldapvuser_timeout= 20
ldapvuser_search_base= dc=vhs-heidekreis,dc=de
ldapvuser_query_filter= (|(&(objectclass=SuSEVirtUserObject)(vaddress=%s))(&(objectclass=dNSZone)(relativeDomainName=@)(zoneName=%s)(MTALocaldomain=%s)))
ldapvuser_result_attribute= uid,MTALocaldomain
ldapvuser_scope= sub

# this is used to enable/disable mail reception
ldapmailenab_server_host= localhost
ldapmailenab_server_port= 389
ldapmailenab_bind= no
ldapmailenab_timeout= 20
ldapmailenab_search_base= dc=vhs-heidekreis,dc=de
ldapmailenab_query_filter= (reject=%s)
ldapmailenab_result_attribute= mailenabled
ldapmailenab_scope= one

# this is used for client certificate based relaying
ldaprelcert_server_host= localhost
ldaprelcert_server_port= 389
ldaprelcert_bind= no
ldaprelcert_timeout= 20
ldaprelcert_search_base= dc=vhs-heidekreis,dc=de
ldaprelcert_query_filter= (relayClientcert=%s)
ldaprelcert_result_attribute= uid
ldaprelcert_scope= one

# this is used for mail transport maps
ldaptransport_server_host= localhost
ldaptransport_server_port= 389
ldaptransport_bind= no
ldaptransport_timeout= 20
ldaptransport_search_base= ou=MailTransports,dc=vhs-heidekreis,dc=de
ldaptransport_query_filter= (&(objectclass=SuSEMailTransportObject)(smtpDomain=%s))
ldaptransport_result_attribute= smtpDomainTransportNexthop
ldaptransport_scope= one

# this is used for mydestination map
ldapvdom_server_host= localhost
ldapvdom_server_port= 389
ldapvdom_bind= no
ldapvdom_timeout= 20
ldapvdom_search_base= o=DNS,dc=vhs-heidekreis,dc=de
ldapvdom_query_filter= (&(objectclass=dNSZone)(relativeDomainName=@)(zoneName=%s)(MTALocaldomain=true))
ldapvdom_result_attribute= zoneName
ldapvdom_scope= sub

#SMTP-RELAY-CONFIG
smtpd_sasl_security_options= noanonymous
smtpd_sasl_auth_enable= yes
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_password_maps = hash:/etc/postfix/saslpasswd
 
und hier ist die master.cf

Code: Alles auswählen

 ==========================================================================
# service type	private	unpriv	chroot	wakeup	maxproc	command + args
# 		(yes)	(yes)	(yes)	(never)	(50)
# ==========================================================================
smtp	  inet	n	-	n	-	-	smtpd -o content_filter=vscan:
#smtps	  inet	n	-	n	-	-	smtpd -o content_filter=vscan: -o smtpd_tls_wrappermode=yes
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission	inet	n	-	n	-	-	smtpd
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628	  inet	n	-	n	-	-	qmqpd
pickup	  fifo	n	-	n	60	1	pickup
cleanup	  unix	n	-	n	-	0	cleanup
qmgr	  fifo	n	-	n	300	1	qmgr
#qmgr	  fifo	n	-	n	300	1	nqmgr
tlsmgr	  fifo	-	-	n	300	1	tlsmgr
rewrite	  unix	-	-	n	-	-	trivial-rewrite
bounce	  unix	-	-	n	-	0	bounce
defer	  unix	-	-	n	-	0	bounce
flush	  unix	n	-	n	1000?	0	flush
smtp	  unix	-	-	n	-	-	smtp
showq     unix	n	-	n	-	-	showq
error     unix	-	-	n	-	-	error
local	  unix	-	n	n	-	-	local
virtual	  unix	-	n	n	-	-	virtual
lmtp	  unix	-	-	n	-	-	lmtp
#localhost:10025 inet	n	-	n	-	-	smtpd -o content_filter=procmail:spamfilter
localhost:10025 inet	n	-	n	-	-	smtpd -o content_filter=

cyrus	  unix	-	n	n	-	-	pipe
  flags=R user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -m ${extension} ${user}
uucp	  unix	-	n	n	-	-	pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
vscan     unix  -       n       n       -       10       pipe
  user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}
procmail  unix  -       n       n       -       -       pipe
  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/imap/procmailrc ${sender} ${recipient} 
[/code]
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

Dec 3 09:01:28 slox postfix/qmgr[23794]: warning: connect to transport smtp-amavis: Connection refused
da du derzeit keinen transportweg für smtp-amavis in deiner Konfig stehen hast, wird diese mail nicht weiter bearbeitet. Der qmgr merkt sich die Transportwege für eine Mail.

Als dieses mail von postfix bearbeitet wurde, gab es diesen Transportweg in deiner Konfiguration... d.h. du solltest deine queue mal flushen. Ohne einen Transportweg smtp-amavis wird die NIE weitertransportiert.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

mailqueue flushen ...

Beitrag von BiZNiZ »

wenn ich das bislang immer richtig gemacht haben sollte, dann sollten doch nach "postsuper -d all" alle mails aus der queue verschwunden sein ...

sind sie aber nicht ...

auch nach x-mal postsuper -d all befinden sich noch immer mails in der queue ...

Code: Alles auswählen

-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
0169129C09*    2075 Wed Dec  1 17:54:36  postmaster@vhs-heidekreis.de
                                         virusalert@vhs-heidekreis.de

4E47D1BAF7*    2137 Thu Dec  2 16:46:27  moenk@linux-club.de
                                         rpatzke@vhs-heidekreis.de

8BFB96612    524377 Thu Dec  2 16:55:36  hnorden@vhs-heidekreis.de
                                                    (transport is unavailable)
                                         rpatzke@vhs-heidekreis.de

-- 516 Kbytes in 3 Requests. 
verwende ich hier schon immer den falschen Befehl ???
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

man postsuper
The postsuper command does maintenance jobs on the Postfix queue. Use of the command is restricted to the superuser. See the postqueue command for unprivileged queue operations such as listing or flushing the mail queue.

By default, postsuper performs the operations requested with the -s and -p command-line options on all Postfix queue directories - this includes the incoming, active and deferred directories with mail files and the bounce, defer, trace and flush directories with log files.
und wenn diese 3 mails das postsuper überleben, dann stehen sie NICHT in incoming, active, deferred, ....
schau in /var/spool/postfix/* nach den IDs und du findest diese mails.

wenn du den postfix neu startest, sollte auch im logfile ziemlich genau stehen was mit dieses mails passiert, bzw was der postfix probiert um sie zuzustellen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
BiZNiZ
Member
Member
Beiträge: 106
Registriert: 24. Aug 2004, 12:30
Wohnort: Munster, Lüneburger Heide
Kontaktdaten:

so ... und nu nochmal von vorne ...

Beitrag von BiZNiZ »

Um nochmal schnell die beim Eröffnen des Threads aufgezählten Punkte teilweise abzuhaken:

Code: Alles auswählen

1. in der amavis.conf steht zwar alles wunderbar drin, so wie es sein soll, und auch in den mails mit den Virus-Meldungen findet sich völlig korrekt die Zeile

The message has been quarantined as:

/var/virusmails/virus-20041201-173612-14416

... ein Blick in /var/virusmails zeigt aber deutlich, dass der Ordner leer ist ...

Wo also finde ich diese mails wieder ???

2. Mails mit infizierten Anhängen werden komplett geblockt - nicht nur der Anhang ...

3. Die testmail von c't mit dem Bagle-Virus wird trotzdem zugestellt !!!

4. obwohl in der conf eingetragen ist, dass auch der recipient eine info erhalten soll, passiert dies nicht ...
zu 1.: Klappt ... war ein Rechte-Problem mit dem Ordner ...
zu 2.: klappt noch immer nicht ... aber besser, die mail ist ganz weg, als dass der Virus beim User ankommt ...
zu 3.: Tja ... der Bagle kommt noch immer durch ... mail wird zwar gescannt, Virus wird aber scheinbar nicht erkannt ... scheint eher ein Problem des Scanners zu sein ...
zu 4.: das klappt jetzt auch ... musste in der amavis.conf noch die local domain eintragen ....

damit wären wohl alle Punkte erst einmal abgehakt, die ich im Thread aufgebracht habe ...

übrigens:

zu dem Eintrag in meiner master.cf:

Code: Alles auswählen

localhost:10025 inet   n   -   n   -   -   smtpd -o content_filter=procmail:spamfilter
das "procmail:spamfilter" wird eingetragen, wenn ich in der Admin-Oberfläche des SLOX unter postfix-config den Spamfilter aktiviere ...

Könnte es damit zusammenhängen, dass dadurch mein port 10025 permanent "already in use" war ???

Dumm ist nur, dass amavis-d den Spamassassin nicht ansprechen kann. Somit muss ich den Spamfilter ja auf diesem Weg aktivieren. Das muss ich dann wohl erst einmal hinnehmen, da ich auch mit allen Anleitungen amavisd-new auf dem SLOX nicht zum Laufen kriege.
Ein Freund ist jemand, der Dich kennt ( ... und trotzdem mag ) !!!
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

Dumm ist nur, dass amavis-d den Spamassassin nicht ansprechen kann. Somit muss ich den Spamfilter ja auf diesem Weg aktivieren. Das muss ich dann wohl erst einmal hinnehmen, da ich auch mit allen Anleitungen amavisd-new auf dem SLOX nicht zum Laufen kriege.
warum sollte das nicht gehen?
Dem Postfix ist das doch egal wen er als content-filter anspricht. Was hat SLOX damit zu tun ?

um den amvisd-new einzubinden brauchst du drei Einträge in deiner master.cf. Und einen Eintrag in der main.cf.
master.cf

Code: Alles auswählen

smtp      inet  n       -       n       -       -       smtpd
    -o content_filter=smtp-amavis:[127.0.0.1]:10024
smtp-amavis unix -      -       n       -       3       lmtp
    -o smtp_data_done_timeout=1800
    -o disable_dns_lookups=yes
127.0.0.1:10025 inet n  -       n       -       -  smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o mynetworks_style=host
    -o strict_rfc821_envelopes=yes
main.cf

Code: Alles auswählen

# Tell Postfix to start forwarding all mail it receives to amavisd-new for content inspection.
content_filter = smtp-amavis:[127.0.0.1]:10024
max_use = 10
Und der amavisd-new wird in seiner eigenen Konfig Datei konfiguriert.
amavisd.conf

Code: Alles auswählen

# @bypass_virus_checks_maps = (1);  # uncomment to DISABLE anti-virus code
# @bypass_spam_checks_maps  = (1);  # uncomment to DISABLE anti-spam code

$inet_socket_port = 10024;   # listen on this local TCP port(s) (see $protocol)
$notify_method  = 'smtp:[127.0.0.1]:10025';
$forward_method = 'smtp:[127.0.0.1]:10025';  # set to undef with milter!
Dazu noch einen Virenscanner deiner Wahl und fertig ist die Laube.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
maggilin

AMAVIS läuft nicht

Beitrag von maggilin »

Hallo,

nun hab ich wirklich alles mögliche schon ausprobiert. Die Telnetbefehle auf Port 10024 und 10025 funktioneieren, doch die Mails werden immer noch nicht durchgereicht.

In der Mail-Log folgende Meldung:

Dec 5 02:21:27 Mailserver postfix/smtpd[4941]: connect from localhost[127.0.0.1]
Dec 5 02:21:30 Mailserver postfix/smtpd[4941]: disconnect from localhost[127.0.0.1]
Dec 5 02:22:08 Mailserver postfix/qmgr[4818]: warning: connect to transport smtp_amavis: No such file or directory
Dec 5 02:23:08 Mailserver postfix/qmgr[4818]: warning: connect to transport smtp_amavis: No such file or directory
Dec 5 02:24:08 Mailserver postfix/qmgr[4818]: warning: connect to transport smtp_amavis: No such file or directory
Dec 5 02:25:08 Mailserver postfix/qmgr[4818]: warning: connect to transport smtp_amavis: No such file or directory
Dec 5 02:26:08 Mailserver postfix/qmgr[4818]: warning: connect to transport smtp_amavis: No such file or directory

Wo muss ich da ansetzen? Hat mir jemand einen Tipp?

gruß Maggilin
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Re: AMAVIS läuft nicht

Beitrag von carsten »

maggilin hat geschrieben:Dec 5 02:26:08 Mailserver postfix/qmgr[4818]: warning: connect to transport smtp_amavis: No such file or directory
Wie wärs mit smtp-amavis? Der Strich ist falsch in irgend ner .conf. Danach ein restart (ggfs. reicht schon reload) des betroffenen Moduls und ein flush

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

@oc2pus:

master.cf

Code: Alles auswählen

smtp-amavis unix -      -       n       -       3       lmtp
    -o smtp_data_done_timeout=1800
    -o disable_dns_lookups=yes 
UNNOETIG!! postfix uebergibt das mit dem protokoll "smtp"
direkt an den contentfilter. diesen eintrag braucht man nur
wenn man den "deliver" nutzen will.


main.cf:

Code: Alles auswählen

falsch:
content_filter = smtp-amavis:[127.0.0.1]:10024

richtig:
content_filter = smtp:[127.0.0.1]:10024

und schon geht das....

.
Mr. Postfix - /* Ubuntu- und SuSE-Linux /*
Gesperrt