Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

rpm-Fehler

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
tomlif
Member
Member
Beiträge: 93
Registriert: 14. Jun 2004, 11:56

rpm-Fehler

Beitrag von tomlif »

Hallo:

folgende Fehlermeldung, die ich mir nicht erklären kann, wenn ich ein RPM-Paket install. will:

rpm -i apcupsd-3.8.6-24.i586.rpm
error: failed dependencies:
insserv is needed by apcupsd-3.8.6-24
libc.so.6(GLIBC_2.3) is needed by apcupsd-3.8.6-24


Die fehlenden Sachen sind aber vorhanden:

\sbin\insserv
\lib\libc.so.6


Was mach ich falsch?
Gruß
t.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

tja typischer Fall von denkste :)

RPM überprüft die Abhängigkeiten aufgrund der RPM-Datenbank und NICHT aufgrund von installierten Dateien.

überprüfe mit rpm -q insserv ob das insserv-RPM installiert ist.
überprüfe mit rpm -q glibc ob du die glibc in der Version 2.3 installiert hast
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
tomlif
Member
Member
Beiträge: 93
Registriert: 14. Jun 2004, 11:56

Beitrag von tomlif »

Hallo:

tja:

package insserv is not installed
glibc-2.2.5-164


Ich glaub, ich schau mich nach einem älteren RPM um. Die LIB kann ich nicht ändern...

Danke...

Gruß
t.
Antworten