Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SSH login dauert lange

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

SSH login dauert lange

Beitrag von SySdaemon »

Hallo Zusammen,

ich habe Debian auf meine Sparc läufen.

Aber der login per SSH von meine Win-Kiste aus dauert über 60 Sek, bis ich dann meinen Benutzername+PWD eingeben kann.

- CheckIP in der /etc/ssh_config ist schon auf no gesetzt!
- Win-Kiste ist auch in der hosts eingetragen!

Was könnte denn noch das Problem sein ?

cya :P

Danke schon mal für Eure Hilfe.
Benutzeravatar
scg
Hacker
Hacker
Beiträge: 399
Registriert: 4. Jul 2004, 09:56
Wohnort: Nürnberg (SuSE-City)
Kontaktdaten:

Beitrag von scg »

Wie heißt denn genau die Befehlszeile, mit der du dich einloggst ?
CU scg
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

Re:

Beitrag von SySdaemon »

Hallo,

ich mache den Login per puTTY (WIN) aus.

- Dieses Phänomen trat nur bis jetzt bei Debian (Sparc) auf.
- SuSE 7.3 (sparc) -> kein Problem
- Sowie bei allen x86 gab es auch keine Probleme.

Login bei allen auch über puTTY ...

eine Idee ?

cya :wink:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

welches ssh Protokoll verwendest du ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

Re:

Beitrag von SySdaemon »

Hi,

SSH 1

Alles soweit standart auf dem SSH Server.
(bis auf CheckIP no)

bye :roll:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

dann probiere mal das SSH2 Protokoll
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

RE:

Beitrag von SySdaemon »

Hallo,

SSH 2 ist sogar gelaufen !

Weitere Idee ?

thx u 8)
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

ssh2 ist der neue Standard ...
(bei SuSE ab 9.0, bei den anderen weiss ich es nicht)

dann stell dein putty um und gut is :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

RE:

Beitrag von SySdaemon »

Hey:

:wink:

puTTY ist leider nicht das Problem.
winSCP hat z.B. auch das Problem.

Müsste also Serverseitig sein.

:shock:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

/etc/ssh/sshd_config

Protocol 2,1 <== damit stellst du die Reihenfolge des Protokolls ein
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
TranceTip
Newbie
Newbie
Beiträge: 13
Registriert: 13. Mai 2004, 14:18

Beitrag von TranceTip »

Das scheint ein DNS-Problem zu sein (hatte ich auch schon, da hat es ebenfalls immer ca. 1 Minute gedauert). Hat der Server vollen DNS-Zugriff?

Welche sshd-Version benutzt Du?

Eine Option "CheckIP" gibt es übrigens nicht. Für den Client gibt es eine Option "CheckHostIP" (meintest Du die?). Die ist für Dein Problem aber nicht relevant, denn es dürfte am Server liegen.

Es gibt "ReverseMappingCheck" für den SSH-Daemon (standardmäßig aber auf "no" eingestellt). Schau mal auf dem Server in /etc/ssh/sshd_config nach, was dort eingestellt ist.

Code: Alles auswählen

    ReverseMappingCheck
             Specifies whether sshd should try to verify the remote host name
             and check that the resolved host name for the remote IP address
             maps back to the very same IP address.  The default is ``no''.
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

RE:

Beitrag von SySdaemon »

Hi,

also DNS habe ich nicht groß im Einsatz.
Über ein gekreutztes Kabel greif ich auf die Lin-Kiste zu.
In der Hosts ist der andere Rechner eingetragen.

SSH2 habe ich im Einsatz.

ReverseMappingCheck stand auf "yes"
Teste jetzt mal mit "no"

Update: leider keine Veränderung


bye :roll:

hier mal meine /etc/ssh/sshd_config

Code: Alles auswählen

# Package generated configuration file
# See the sshd(8) manpage for defails

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# ...but breaks Pam auth via kbdint, so we have to turn it off
# Use PAM authentication via keyboard-interactive so PAM modules can
# properly interface with the user (off due to PrivSep)
PAMAuthenticationViaKbdInt no
# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 600
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# rhosts authentication should not be used
RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Uncomment to disable s/key passwords
#ChallengeResponseAuthentication no

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes


# To change Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#AFSTokenPassing no
#KerberosTicketCleanup no

# Kerberos TGT Passing does only work with the AFS kaserver
#KerberosTgtPassing yes

X11Forwarding no
X11DisplayOffset 10
PrintMotd no
#PrintLastLog no
KeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net
-------> ReverseMappingCheck no    <---------------

Subsystem       sftp    /usr/lib/sftp-server
SUN Sparc Server 10 (2x 75 MHz)
We have joy, We have fun, We run Linux on a SUN.
SySdaemon
Newbie
Newbie
Beiträge: 47
Registriert: 20. Apr 2004, 12:30
Wohnort: 127.0.0.1

Beitrag von SySdaemon »

jemand noch eine Idee ?
Benutzeravatar
coerdt
Newbie
Newbie
Beiträge: 11
Registriert: 8. Nov 2004, 08:39
Wohnort: Timmerhorn
Kontaktdaten:

Beitrag von coerdt »

Hallo,

woran es liegt weiß ich leider auch nicht...

Vielleicht kannst du mehr sehen, wenn du mal

Code: Alles auswählen

ssh -v hostname
eingibts.
 DON'T PANIC!
       Christian

http://www.coerdt.de
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

Protocol 2
du solltest Protocol 2,1 hinschreiben
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
White_Wolf
Newbie
Newbie
Beiträge: 1
Registriert: 4. Jan 2005, 15:48

Auflösung !?

Beitrag von White_Wolf »

Kann deine Linux Kiste sich selbst auflösen ? Das ist sehr häufig das Problem bei langsamen anmeldevorgängen.

cu
Antworten