Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit Suse 9 als DNS server

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
fOB
Newbie
Newbie
Beiträge: 8
Registriert: 8. Feb 2004, 16:13

Problem mit Suse 9 als DNS server

Beitrag von fOB »

Moin,

ich benutze mein Suse Rechner auch als DNS Server. Damit ich, wenn ich meine dyndns Adresse aus dem Netzwerk aufrufe, nicht auf meinem Router lande habe ich die in der /etc/hosts mit der Lokalen Netzwerkadresse eingetragen.
Auf dem Linux PC geht das natürlich alles einwandfrei.
Das Problem ist das das natürlich auch von den anderen Rechnern im Netzwer funktionieren soll ohne das bei jedem die hosts Datei vom Windows angepasst werden muss.
(Der Linux rechner ist überall schon als DNS-Server eingetragen.)

Der DNS Server scheint die /etc/hosts einfach zu ignoriert, weil ich weiterhin auf meinem Router lande ... und das will ich ja nicht ...
Unter Suse 8 hat das mit dnsmasq mal funktioniert.
Um Missverstendnisse zu vermeiden: Jetzt benutze ich diesen DNS-Server den man so schön, mit ein paar klicks, über Yast aktivieren kann ;)

MfG fOB
cybermailer

Re: Problem mit Suse 9 als DNS server

Beitrag von cybermailer »

Hallo foB,

ich glaub da liegen bei dir in Bezug auf DNS einige Verständnisprobleme vor. Eine Linux-Rechner wird nicht dadurch zum Domain Name Server indem ich seine hosts-Datei konfiguriere, und dann die IP-Adresse des Rechners auf den anderen PC's als Nameserver eintrage.

Wenn ich die Namensauflösung über die Hosts-Datei machen möchte, muß diese natürlich auf allen Rechnern im Netzwerk identisch sein.

Wenn dein Linux-Pc als Nameserver fungieren soll, muß zunächst einmal das Bind-Paket installiert werden. Dann ist die named.conf anzupassen, und es sind Zonendateien zu erstellen, die dann mit den nötigen Einträgen versehen werden müssen.
fOB
Newbie
Newbie
Beiträge: 8
Registriert: 8. Feb 2004, 16:13

Beitrag von fOB »

Also wie ich grad festgestellt hab ist Bind installiert. Das scheint dan das zu sein was ich mit "Jetzt benutze ich diesen DNS-Server den man so schön, mit ein paar klicks, über Yast aktivieren kann" meinte ;)

Das mit der named.conf war der hinweiß den ich brauchte um weiter zu kommen.
thx @ cybermailer

MfG fOB
Antworten