Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Anmeldung über ssh schlägt fehl

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
capser
Member
Member
Beiträge: 62
Registriert: 22. Nov 2004, 10:09

Anmeldung über ssh schlägt fehl

Beitrag von capser »

Hallo,
Seit heute haben wir einen neuen Rechner bekommen auf dem zu meinem erstaunen sogar schon Linux komplett fertig installiert ist.
War ich natürlich dankbar und scheint auch soweit alles zu funktionieren, nur die anmeldung über ssh von Putty aus klappt leider nicht.

Habe ganz normal im Verzeichniss .ssh einen schlüssel erzeugt über
ssh-keygen -t dsa
so wie bei allen anderen maschinen auch.

Ich vermute mal das was an der sshd_config falsch eingestellt ist. bevor ich aber die großen Sicherheitslücken öffne wollte ich fragen ob vielleicht jemand sofort sieht woran es liegt.
Hier meine sshd_config :

Code: Alles auswählen

#	$OpenBSD: sshd_config,v 1.68 2003/12/29 16:39:50 millert Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

Port 22
Protocol 2
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile	.ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication no
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
# mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
# in this release. The use of 'gssapi' is deprecated due to the presence of 
# potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
#GSSAPIEnableMITMAttack no

# Set this to 'yes' to enable PAM authentication (via challenge-response)
# and session processing. Depending on your PAM configuration, this may
# bypass the setting of 'PasswordAuthentication' and 'PermitEmptyPasswords'
UsePAM yes 

#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes 
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem	sftp	/usr/lib/ssh/sftp-server
Als Feherlmeldung bekomme ich immer "Server refused our key"

ist aber eingerichtet wie immer.

Vielen dank für Hilfe gruß
Nils
Gamic
Member
Member
Beiträge: 109
Registriert: 26. Jun 2004, 15:16

Beitrag von Gamic »

Tip: Du benutzt SuSE 9.2 und die Firewall blockt den Port 22
capser
Member
Member
Beiträge: 62
Registriert: 22. Nov 2004, 10:09

Beitrag von capser »

Das ist vermutlich ein guter Tipp.

Das ist wohl der Nachteil wenn man den PC nicht selber installiert hat.

Mit SuSEfirewall habe ich allerdings noch nie gearbeitet und muß echt mal kurz nachhacken wie man die deaktivieren kann.

p.s. habe jetzt mit susefirewall2 stop das ganze gestoppt.
Ist wohl richtig so oder?
danach über status noch die chains ausgeben lassen und es waren auch keine mehr gesetzt und alles auf accept gesetzt.

Leider ging es anschließen immer noch nicht und ich habe in der log datei andauernd

martian source
stehen worauf in google kam das irgendwo in der Netzkonfiguration ein fehler liegen muss kann mir da vielleicht auch jemand weiterhelfen?
Antworten