Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit Umlauten bei Freigabe einer VFAT-Partition

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
steos
Member
Member
Beiträge: 57
Registriert: 17. Jul 2004, 14:23
Wohnort: Wien

Problem mit Umlauten bei Freigabe einer VFAT-Partition

Beitrag von steos »

Ich nutze Samba 3 mit W2K-Clients. Der Share auf den zugegriffen wird ist eine VFAT-Partition, die unter /home/Xfer gemountet und ansprechbar ist. In der /etc/fstab ist die Partition für alle User -- gleich ob unter W2K oder Linux eingeloggt -- freigegeben und kann beliebig manipuliert werden:
[Xfer]
#
# This is supposed to be a general purpose transfer directory, accessible
# for users listed in the valid users section.
#
# descriptive string for the resource to be displayed in Windows:
comment = Data Exchange Directory
#
# The following directory shall be provided for data exchange purposes:
path = /home/Xfer
#
# both read and/or write access is allowed on this resource:
read only = No
#
# the following line is needed to allow Windows to list all directories
# and files stored in the Xfer resource:
browseable = Yes
#
# access may be granted to the following user(s) only (list items again to
# be separated by blanks):
valid users = user1 user2
Ich habe in smb.conf unter [global] die obigen Parameter ergänzt:
dos charset = 850
unix charset = ISO-8859-15
display charset = ISO-8859-15
Problem: Unter W2K werden die Sonderzeichen ohne die obigen Angaben korrekt dargestellt, mit den obigen Parametern jedoch falsch, nur unter Linux stehen in beiden Fällen kryptische Zeichen. Hat jemand eine Idee, was unter "unix charset" bzw. "display charset" einzutragen ist? Auch die Angabe von ISO-8859-1 hat bei mir leider nicht zu Erfolg geführt. Googeln hat leider auch nichts gebracht... :(

Ich würde jedoch gerne unter W2K und Linux einen korrekte Darstellung der Umlaute haben. Möglicherweise ein Effekt der VFAT-Partition?
AMD Athlon XP 1800+
MSI KT3 Ultra, 1GB RAM
D-Link NIC DFE-550TX
nVidia GeForce4 Ti 4600
Benutzeravatar
steos
Member
Member
Beiträge: 57
Registriert: 17. Jul 2004, 14:23
Wohnort: Wien

Beitrag von steos »

Gelöst!

Ich habe mich schlicht vertippt; unter [global] genügen die Parameter
# Specify the charset the unix machine Samba runs on uses. Samba needs to
# know this in order to be able to convert text to the charsets other
# SMB clients use:
unix charset = ISO8859-15
#
# Specifies the charset that samba will use to print messages to stdout
# and stderr and SWAT will use. Should generally be the same as the
# unix charset:
display charset = ISO8859-15
und die Umlaute werden unter beiden Systemen korrekt dargestellt. :D
AMD Athlon XP 1800+
MSI KT3 Ultra, 1GB RAM
D-Link NIC DFE-550TX
nVidia GeForce4 Ti 4600
Antworten