Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

verliert der Windows PC die Verbindung zum Linuxrechner?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Kurt M
Hacker
Hacker
Beiträge: 408
Registriert: 24. Sep 2004, 12:39
Wohnort: Bayrischer Wald
Kontaktdaten:

verliert der Windows PC die Verbindung zum Linuxrechner?

Beitrag von Kurt M »

ich suche noch eine Erklärung für diesen Effekt, vielleicht kann ein Spezialist helfen ?

Ich habe einen Windows und Linux PC mit Samba verbunden und auch Cups zum Drucken eingerichtet.

Zuerst läuft alles perfekt, keine Probleme.
Plötzlich nach einiger Zeit (Stunden, Tage.. ich weiss nicht genau), verliert der Windows PC die Verbindung zum Linuxrechner. Entweder kann er nicht mehr Drucken, oder auch nicht auf Files zugreifen oder beides.

Inzwischen habe ich herausgefunden:
Wenn ich anstelle des Rechnernamens nur mit IP Adressen konfiguriere, dann läuft es auch auf Dauer zuverlässig. Nur bei der Verwendung von Rechnernamen, geht es nur für eine gewisse Zeit lang.

Irgendwie hab ich keine Idee was da dahinterstecken könnte ?
switcher51
Member
Member
Beiträge: 142
Registriert: 1. Okt 2004, 19:18

Beitrag von switcher51 »

Wie werden bei dir denn die Rechnernamen aufgelöst? (hosts-Datei, Nameserver, ....)
Läuft DHCP?
Wie sieht die KOnfiguration von Samba aus?

Gruß switcher51
Benutzeravatar
gelbeseiten
Newbie
Newbie
Beiträge: 32
Registriert: 19. Okt 2004, 12:12
Wohnort: Bremen

Beitrag von gelbeseiten »

hallo Kurt M,

ist bei dir der wins-server dienst aktiv und hast du diesen in der smb.conf eingetragen?

-----------------------------------------
[global]

wins support = yes
-----------------------------------------

und läuft der nmb deamon?

testen kannst du das so:

rcnmb status

wenn er nicht gestartet ist solltest du diesen auf jedenfall in den runlevels 3 und 5 starten lassen. was über yast bei suse kein probelm dastellt!
yast > system > runlevel-editor > und dann den nmb dienst aktivieren!

du kannst aber auch mal die logs durchgucken, ob da fehlermeldungen beim zugriff auf den rechner erscheinen.

tail -f /var/log/samba/log.nmbd
tail -f /var/log/samba/log.smbd

diese kannst du ja ggf. noch mal posten

gruß

volkmar
Antworten