Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Fehlermelung beim Installieren

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
12earn
Newbie
Newbie
Beiträge: 20
Registriert: 23. Mai 2004, 20:56

Fehlermelung beim Installieren

Beitrag von 12earn »

Hallo,

erstmal der Fehler:

rpmdb: /var/lib/rpm/Packages: unexpected file type or format
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
rpmdb: /var/lib/rpm/Packages: unexpected file type or format
error: cannot open Packages database in /var/lib/rpm


Autreten:

Egal ob mit der Konsole per SSH
oder über Webmin
oder direkt an der Kiste.

Er sagt immer das er die Datei Packages nicht öfnnen/lesen kann, vorhanden ist sie und rechte hat der root auch alle, ich hab daran nichts geändert.

Aufgetreten ist es das erste mal beim Installieren eines Vieren Scanners mit dem datei namen clamav-0.80rc4.tar.tar

Geladen hab ich sie von hier:
http://www.clamav.net

Wer kann mir sagen wie ich das wieder in Griff bekomme ?

Grüße Thomas
Apache/2.0.48 (Linux/SuSE 9.0) PHP 4.3.3
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Moin,
rpmdb: /var/lib/rpm/Packages: unexpected file type or format
Das ist kein rpm!
clamav-0.80rc4.tar.tar
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
12earn
Newbie
Newbie
Beiträge: 20
Registriert: 23. Mai 2004, 20:56

Beitrag von 12earn »

admine hat geschrieben:Moin,
rpmdb: /var/lib/rpm/Packages: unexpected file type or format
Das ist kein rpm!
clamav-0.80rc4.tar.tar
Ich habe es nochmal geladen dann die clamav-0.80.tar.gz die war es bei der ich das Problem bekommen hab sorry hatte das verwechselt...

Aber es ist wurscht was ich Installieren will wenn rpm dann geht es nicht.

Auch mit Yast geht nix zu installieren weil er nicht weiss was installiert ist.

Grüße Thomas
Apache/2.0.48 (Linux/SuSE 9.0) PHP 4.3.3
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

bei einem tar.gz musst du entpacken und die INSTALL bzw. README lesen
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
12earn
Newbie
Newbie
Beiträge: 20
Registriert: 23. Mai 2004, 20:56

Beitrag von 12earn »

admine hat geschrieben:bei einem tar.gz musst du entpacken und die INSTALL bzw. README lesen
Ich hab das ja auch Entpackt....


Ich glaub du verstehts mein Problem nicht, es hakt weder am Installiern noch am Entpcken oder am Lesen.


AUCH YAST kann nichts mehr finden was installiert ist.

Weder das ich webmin deinstallieren kann noch sonst was !

Hoffe du versteht jetzt was mein Problem ist.

Yast liest die datei Packages nicht weil ... keine Ahnung warum.

Grüße Thomas
Apache/2.0.48 (Linux/SuSE 9.0) PHP 4.3.3
Benutzeravatar
12earn
Newbie
Newbie
Beiträge: 20
Registriert: 23. Mai 2004, 20:56

Beitrag von 12earn »

Hat mir keiner eine Antwort ?


Ichb weiss nicht was hilft, kann man das RPM eigentlich neu Installieren oder die Packages löschen und neu erstellen lasssen ?

Oder muss ich das Ganze System neu Installieren ?

Grüße Thomas
Apache/2.0.48 (Linux/SuSE 9.0) PHP 4.3.3
quizzmaster
Member
Member
Beiträge: 73
Registriert: 11. Mai 2004, 17:10
Wohnort: Frankfurt/Main
Kontaktdaten:

Beitrag von quizzmaster »

nur zum Verständnis, nach der installation des vierenscanners hat er keinen zugriff mehr auf die RPM Paketdatenbank?
greetz
quizzmaster

Ordnung braucht nur der Dumme, das Genie beherrscht das Chaos Albert Einstein
Benutzeravatar
12earn
Newbie
Newbie
Beiträge: 20
Registriert: 23. Mai 2004, 20:56

Beitrag von 12earn »

quizzmaster hat geschrieben:nur zum Verständnis, nach der installation des vierenscanners hat er keinen zugriff mehr auf die RPM Paketdatenbank?
Die Installation hat auch nicht funktioniert.

Während der Install kam die Fehlermeldung, ob es vom Installieren kommt kann ich aber nicht sagen.

Grüße Thomas
Apache/2.0.48 (Linux/SuSE 9.0) PHP 4.3.3
Antworten