Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit windows-Partition per NFS

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Problem mit windows-Partition per NFS

Beitrag von rbest »

hi Leute,
bis 9.1 funktionierte die Einbindung meiner Windows-Laufwerke per NFS problemlos. Jetzt wird nichts mehr angezeigt (also im Dateimanager). Hab keinen Plan. Der Eintrag in fstab:

Code: Alles auswählen

192.168.0.1:/windows	/home/roland/r1/windows	nfs	defaults 0 0
Eintrag in exports:

Code: Alles auswählen

/windows/	*(rw,root_squash,sync)
Danke für eure Hilfe.
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Windows-LW und NFS ... :roll:

Wie genau sieht die Konstellation aus?
Win-Partition im Linux gemountet und dann freigegeben?
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Problem gelöst

Beitrag von rbest »

hi admine,
das ist doch zum Mäusemelken. Plötzlich seh ich alles. :?

Zumindest lokal. Was noch nicht geht, ist windows über NFS. Andere Verzeichnisse machen kein Problem. Woran könnte das den liegen?
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Problem gelöst

Beitrag von admine »

rbest hat geschrieben:hi admine,
das ist doch zum Mäusemelken. Plötzlich seh ich alles. :?

Zumindest lokal. Was noch nicht geht, ist windows über NFS. Andere Verzeichnisse machen kein Problem. Woran könnte das den liegen?
Noch mal meine Frage:

Wie mit Windows?
Partiton in Linux gemountet ?
Ansonsten doch eher Samba.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: Problem gelöst

Beitrag von Martin Breidenbach »

rbest hat geschrieben:Was noch nicht geht, ist windows über NFS.
Welche NFS Software hast Du unter Windows laufen ? Windows selber beinhaltet keinen NFS Server.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Problem mit windows-Partition per NFS

Beitrag von rbest »

hallo,
nein, nicht unter windows. Ich hab eine windows-Partition in Linux gemountet und diese dann exportiert, damit ich dann vom anderen Rechner drauf zugreifen kann - also per NFS.
Bis 9.1 ging das gut, jetzt nicht mehr, aber ich weiss leider nicht warum. :cry:

Moment, ich sag dir die genaue Konstellation: meine Rechner heissen r1 und r5. Auf r1 habe ich windows gemountet als /windows und exportiert. Auf r5 habe ich dieses Verzeichnis gemountet in meinem home-Verzeichnis /home/roland/r1/windows.
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Moin,

ändere doch mal die Optitionen in der fstab in "noauto,user,exec".
Wobei das noauto nur, wenn es nicht automatisch gemountet werden soll.
Sonst "auto".
defaults ist da glaub nicht so angebracht.

Ein Link für weitere Optionen bei NFS:
http://www.linux-user.de/ausgabe/2002/0 ... ml?print=y
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
rbest
Hacker
Hacker
Beiträge: 560
Registriert: 10. Nov 2004, 14:28
Kontaktdaten:

Beitrag von rbest »

geht leider trotzdem nicht. Es wird gemountet: /home/roland/r1/windows und darin C,c,F und f, aber die jeweiligen Verzeichnisse sind leer (bzw. nicht sichtbar).
Hab schon gedacht, ich hätte was gefunden. Da gips nämlich noch eine export-Option nohide, aber die hat auch nix gebracht.
Antworten