Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

IP-Adresse mittels DHCP von WLAN-Router

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
dast
Newbie
Newbie
Beiträge: 2
Registriert: 7. Nov 2004, 13:51

IP-Adresse mittels DHCP von WLAN-Router

Beitrag von dast »

Hallo Leute,

also ich bin noch recht unerfahren unter Linux und hab folgendes Problem:

Habe auf meinem acer TravelMate 8003LMi Notebook SUSE 9.1 installiert und möchte gerne über meinen WLAN-Router ins Internet.

Ein Arbeits-Kollege hat mir den Treiber für meinen Intel PRO/Wireless 2200BG Chip installiert und es auch schon geschaft über unseren WLAN-Firmen-Router ins Internet zu gelangen.

Jetzt möchte ich allerdings auch zuhause über meinen WLAN-Router ins Internet, was allerdings noch nicht so recht funktioniert.

So, also nach dem Booten lade ich zuerst mal den Treiber für meinen WLAN-Chip von Intel indem ich in das Treiber-Verzeichnis wechsle und den Treiber mittels ./load lade.

Als nächstes setzte ich alle WLAN-Parameter, wie Verschlüsselung, Kanal, usw. mittels dem iwconfig Kommando. Das scheint auch zu funktionieren, d.h. er findet den Router.

Wenn ich als nächstes das WLAN-Netzwerk eth1 mittels ifconfig eth1 up hochfahren möchte scheint es so als ob ich keine IP-Adresse und keinen Standard-Gateway bekommen würde. Wenn ich dann ifconfig eingebe erhalte ich folgende Ausgabe:

Code: Alles auswählen

eth0      Link encap:Ethernet  HWaddr 00:C0:9F:43:AD:ED
          inet6 addr: fe80::2c0:9fff:fe43:aded/64 Scope:Link
          UP BROADCAST NOTRAILERS MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:6

eth1      Link encap:Ethernet  HWaddr 00:0E:35:3F:AE:10
          inet6 addr: fe80::20e:35ff:fe3f:ae10/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1404 (1.3 Kb)  TX bytes:790 (790.0 b)
          Interrupt:10 Base address:0x6000 Memory:d0214000-d0214fff

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 b)  TX bytes:100 (100.0 b)
Das WLAN-Netzwerk läuft unter eth1. Aber irgndwie fehlt mir die IP-Adresse und der Standard-Gateway. Ich möchte mir eine IP-Adresse mittels DHCP vom WLAN-Router zuweisen lassen. Ich hab dann mal mittels dem Befehl dhcpcd eth1 versucht mir eine IP-Adresse zuweisen zu lassen (weiss jedoch nicht ob das der richtige Befehl ist) und hab folgende Meldung erhalten:

Code: Alles auswählen

    eth1      device: Intel Corp.: Unknown device 4220 (rev 05)
ERROR: No configuration found for eth1
Wie bekomme ich nun mittls DHCP eine IP-Adresse und dann ins Internet?!

Im voraus schon mal DANKE!
Benutzeravatar
dast
Newbie
Newbie
Beiträge: 2
Registriert: 7. Nov 2004, 13:51

Beitrag von dast »

So, jetzt funktioniert es ... weiss zwar nicht warum es davor nicht geklappt hat, aber hab das ganze nochmal genau so wie beschrieben wiederholt und siehe da es hat geklappt.

Ich bekomme zwar noch immer die folgende Fehlermeldung wenn ich den Befehl dhcpcd eth1 ausführe:

Code: Alles auswählen

ERROR: No configuration found for eth1
Aber es geht! Kann mir vielleicht jemand erklären was die Meldung zu bedeuten hat und wie ich sie wegbekomme?!

Ach ja noch was... Wie mach ich es dass das WLAN beim Systemstart austomatisch startet (Treiber laden und iwconfig, ifconfig und dhcpcd ausführen)?
Antworten