Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SuSE Linux 9.0 WLan via Hotplug

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

SuSE Linux 9.0 WLan via Hotplug

Beitrag von oeli »

Hallo, hab ein kleines Prob.
Hab eine Toshiba Wireless Lan Karte an meinem Laptop. Sie ist Intern, aber ein und ausschaltbar. Yast erkennt sie ohne Probleme, und auch in hotplugctl wird sie gefunden. Hab alle einstellungen in Yast getätigt (IP, Gateway, DHCP...). Aber ich komme nicht ins Netz. Wenn ich Ping aufrufe gibt er zurück: Network not reachable.
Ich finde sie auch nicht mit dem kwifimanager.
Was kann ich tun? Kann ich die Karte auch ohne Hotplug ansteuern bzw. ihr einen festen Namen wie eth0 zuweisen?
DaBomb

Beitrag von DaBomb »

Dir fehlen die passenden Treiber zu Deiner Karte. Daher funktioniert es nicht und es wird auch nicht das benötigte wlan0-Interface aufgebaut.

Welchen Chipsatz hat Deine Karte?
Gast

Beitrag von Gast »

Intersil PRISM2
wird von cardinfo aber auch als solcher erkannt...
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

upps, war net eingeloggt :)
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

oh, hab gerade auf einer site gesehen, dass meine Karte den Hermes Chipsatz drauf hat und nicht den Prism2, wie von cardinfo angezeigt.
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

Unter Knoppix (aktuelle Version) läuft die Karte übrigens einwandfrei und ohne murren und knurren....falls das zur behebung meines Problems etwas zuträgt :)
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

noch ein kleiner Nachtrag :)
Ich hab jetzt die genauen Produkt Angaben von Toshiba. Die Karte ist eine CardBus TI 1410 / Lucent ORiNOCO.
Wird von YAST als Toshiba Wireless Lan Card erkannt, was auch richtig ist, aber im cardinfo steht sie als 11 Mbps Prism2 Wireless Lan Card.
In den Produktspezifikationen stand direkt darunter "Mini_PCI: Ja"
Ich weiß aber nicht, ob sich das auf die WLan Karte bezogen hat...
Was ist Mini PCI denn überhaupt? Ich kann mir denken, dass es etwas ähnliches wie PCI oder PCMCIA ist, aber wo liegt der Unterschied zwischen PCMCIA und Mini PCI?

MfG
oeli
DaBomb

Beitrag von DaBomb »

Das liegt daran, dass das neue Knoppix den 2.6er Kernel testhalber dabei hat.
Wer auf seinem System den 2.6.2 Kernel installiert, wird feststellen, dass es dann auch unter einer 8.2er SuSE funktioniert.
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

Wie kann ich den neuen Kernel denn installieren, oder ist das nicht mal eben so zu machen?

MfG
oeli
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

Hab jetzt den 2.6.3er kernel drauf. Meine WLan Karte (CardBus TI 1410 / Lucent ORiNOCO) funzt aber immer noch nicht...Hab's auch schon mit Linuxant probiert, der findet die Karte aber absolut nicht.

Hüüüüülffeeeeee! :)
oeli____________

AMD Athlon XP 2200+
512 MB RAM
ATI Radeon 9800 Pro
SuSE 9.1
Kernel: 2.6.5
DaBomb

Beitrag von DaBomb »

2.6.3 ???

Die empfohlene und stabile Verision der 2.6 - Generation, ist der 2.6.2 Kernel.

öffne mal eine Konsole und gib ein: uname -r

Poste mal die dann angegebene Kernelversion
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

uname -r gibt 2.6.3-0-default aus.
unter ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... i386/i586/ gibt es auch nur noch diese Version. Der 2.6.2 ist da gar net mehr vorhanden.
oeli____________

AMD Athlon XP 2200+
512 MB RAM
ATI Radeon 9800 Pro
SuSE 9.1
Kernel: 2.6.5
DaBomb

Beitrag von DaBomb »

Ok, Du hast recht. Bei www.kernel.org
wird der 2.6.3 als stable-version angegeben.

Wird Deine Karte erkannt im Plugger?
dirk viher
Hacker
Hacker
Beiträge: 568
Registriert: 19. Feb 2004, 18:08
Wohnort: Herzogenrath

kernel 2.6.3-0

Beitrag von dirk viher »

Habe gerade den kernel 2.6.3-0 installiert um ein netgear MA521 pcmcia mit rtl8180 chip zum laufen zu bringen.
Karte wird unter YAST-Hardware mit irq und io und bei Netzwerk als Netgear Eternet Controler erkannt.
cardctl ident gibt aber keine Karte an.
Beim kernel 2.4.21-144-default ging das noch.
Wird der Chip jetzt vom 2.6.3-0 unterstützt oder nicht.
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

Jap, im Plugger wird die Karte als "Toshiba Wireless LAN Card" erkannt (genau wie im YaST). Wenn ich auf Details klicke steht dann unter Allgemein, dass sie verfügbar und konfiguriert ist und unter Treiber steht:
Driver Info #0:
Driver Status: orinoco_cs is active
Driver Activation Cmd: "modprobe orinoco_cs"
oeli____________

AMD Athlon XP 2200+
512 MB RAM
ATI Radeon 9800 Pro
SuSE 9.1
Kernel: 2.6.5
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

Weiß keiner mehr weiter???
Hülfeee :)
oeli____________

AMD Athlon XP 2200+
512 MB RAM
ATI Radeon 9800 Pro
SuSE 9.1
Kernel: 2.6.5
Gast

Beitrag von Gast »

Kontrollier mal die Einstellungen in den Dateien
config, wireless.opts, *wlan-ng.conf unter /etc/pcmcia.
Es kann sein, dass du noch Änderungen vornehmen musst.
In der /etc/pcmcia/config stehen die Treiber, die für die jeweiligen Karten geladen werden sollen.
Treiber und manfid sollten mit deiner Karte übereinstimmen.
In wireless.opts kannst du die Einstellungen verfeinern. Ich musste hier den Channel ändern bevor es funktionierte.
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

Aaaalso,
ich hab weder in der config, noch in der wlan-ng.conf meine Karte, mit dem Namen, mit dem sie im Plugger gefunden wird, wiedergefunden.
Wie muss ich sie denn da eintragen? (also nicht wie sondern was :))
oeli____________

AMD Athlon XP 2200+
512 MB RAM
ATI Radeon 9800 Pro
SuSE 9.1
Kernel: 2.6.5
dirk viher
Hacker
Hacker
Beiträge: 568
Registriert: 19. Feb 2004, 18:08
Wohnort: Herzogenrath

Beitrag von dirk viher »

cardctll indent liefert manfid ?x????, ?x????
Du machst in den Datein, wo die Karten aufgeführt sind einen neuen Eintrag nach dem gleichen Schema.
Name der Karte (ist frei wählbar)
manfid ( was cardctl indent liefert)
bind "prism2_cs" ( wenn prism2-chip, bei USB schau bei anderen Karten nach, wie der Treiber heißt.
Benutzeravatar
oeli
Newbie
Newbie
Beiträge: 21
Registriert: 4. Feb 2004, 22:38

Beitrag von oeli »

Hab die Karte jetzt so in die config und wlan-ng.conf eingetragen:

card "TOSHIBA WIRELESS LAN CARD"
manfid 0x0156, 0x0002
bind "orinoco_cs"


sie tut allerdings immer noch nix :(
oeli____________

AMD Athlon XP 2200+
512 MB RAM
ATI Radeon 9800 Pro
SuSE 9.1
Kernel: 2.6.5
Antworten