Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Rechner mit Suse 9.1 +WINXP via Crossoverkabel verbunden?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Micar4
Newbie
Newbie
Beiträge: 25
Registriert: 9. Okt 2004, 00:15
Wohnort: Aichach

Rechner mit Suse 9.1 +WINXP via Crossoverkabel verbunden?

Beitrag von Micar4 »

Hallo Linuxer,

ich habe folgendes Problem ! Ich hab hier einen Rechner mit Suse 9.1 +WINXP und einen Rechner mit Suse 9.1. Beide sind mit Onboard LAN via Crossoverkabel verbunden.
LAN von Rechner 1 hat die feste IP 192.168.129.6, LAN von Rechner 2 hat IP 192.168.129.5
Ich kann von jedem Rechner aus den anderen anpingen aber keine ssh Verbindung aufbauen :-(.
Ein ifstatus eth0 auf Rechner 1 bringt folgende ausgabe :
ifstatus eth0
eth0 device: Linksys Network Everywhere Fast Ethernet 10/100 model NC100 (rev 11)
eth0 configuration: eth-id-00:30:05:35:94:db
eth0 is up
2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:30:05:35:94:db brd ff:ff:ff:ff:ff:ff
inet 192.168.129.6/24 brd 192.168.129.255 scope global eth0
inet6 fe80::230:5ff:fe35:94db/64 scope link
valid_lft forever preferred_lft forever
eth0 IP address: 192.168.129.6/24
Configured routes for interface eth0:
169.254.0.0 - 255.255.0.0 eth0
Active routes for interface eth0:
192.168.129.0/24 proto kernel scope link src 192.168.129.6
169.254.0.0/16 scope link
1 of 1 configured routes for interface eth0 up

Netstat -rn siehe unten:
netstat -rn
Kernel IP Routentabelle
Ziel Router Genmask Flags MSS Fenster irtt Iface
192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
192.168.129.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.178.1 0.0.0.0 UG 0 0 0 eth1

Ein ping 192.168.129.5 bringt folgende Ausgabe:
PING 192.168.129.5 (192.168.129.5) 56(84) bytes of data.
64 bytes from 192.168.129.5: icmp_seq=1 ttl=64 time=0.162 ms
64 bytes from 192.168.129.5: icmp_seq=2 ttl=64 time=0.131 ms
64 bytes from 192.168.129.5: icmp_seq=3 ttl=64 time=0.133 ms
64 bytes from 192.168.129.5: icmp_seq=4 ttl=64 time=0.132 ms
64 bytes from 192.168.129.5: icmp_seq=5 ttl=64 time=0.133 ms
64 bytes from 192.168.129.5: icmp_seq=6 ttl=64 time=0.130 ms
64 bytes from 192.168.129.5: icmp_seq=7 ttl=64 time=0.140 ms

--- 192.168.129.5 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 5998ms
rtt min/avg/max/mdev = 0.130/0.137/0.162/0.013 ms

Jedoch ein nmap -O 192.168.129.5 folgende Ausgabe
nmap -O 192.168.129.5

Starting nmap 3.50 ( http://www.insecure.org/nmap/ ) at 2004-10-31 13:58 CET
Warning: OS detection will be MUCH less reliable because we did not find at least 1 open and 1 closed TCP port
All 1659 scanned ports on 192.168.129.5 are: filtered
Too many fingerprints match this host to give specific OS details

Nmap run completed -- 1 IP address (1 host up) scanned in 87.490 seconds

Von Rechner 2 (192.168.129.5) auf Rechner 1 (192.168.129.6) zeigt nmap -O 192.168.129.6 folgendes:

Starting nmap 3.50 ( http://www.insecure.org/nmap/ ) at 2004-10-31 14:07 CET
Interesting ports on localhost (127.0.0.1):
(The 1655 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE
22/tcp open ssh
25/tcp open smtp
111/tcp open rpcbind
631/tcp open ipp
Device type: general purpose
Running: Linux 2.4.X|2.5.X
OS details: Linux 2.5.25 - 2.5.70 or Gentoo 1.2 Linux 2.4.19 rc1-rc7)
Uptime 0.009 days (since Sun Oct 31 13:54:20 2004)

Nmap run completed -- 1 IP address (1 host up) scanned in 5.520 seconds

Wenn ich jetzt ein ssh 192.168.129.5 mache kommt nach ewigen Zeiten:

ssh: connect to host 192.168.129.5 port 22: Connection timed out

Ein nmap -O localhost auf Rechner 2 bringt :

//www.insecure.org/nmap/ ) at 2004-10-27 01:20 CEST
Interesting ports on localhost (127.0.0.1):
(The 1649 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE
13/tcp open daytime
21/tcp open ftp
22/tcp open ssh
25/tcp open smtp
37/t
me
111/tcp open rpcbind
427/tcp open svrloc
631/tcp open ipp
5801/tcp open vnc-http-1
5901/tcp open vnc-1
Device type: general purpose
Running: Linux 2.4.X|2.5.X
OS details: Linux 2.5.25 - 2.5.70 or Gentoo 1.2 Linux 2.4.19 rc1-rc7)
Uptime 0.004 days (since Wed Oct 27 01:15:09 2004)

Nmap run completed -- 1 IP address (1 host up) scanned in 5.561 seconds

Ein ifstatus eth0 auf Rechner 2 :
ifstatus eth0
eth0 device: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 91)
eth0 configuration: eth-id-ff:ff:ff:ff:ff:ff
eth0 is up
2: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether ff:ff:ff:ff:ff:ff brd ff:ff:ff:ff:ff:ff
inet 192.168.129.5/24 brd 192.168.129.255 scope global eth0
inet6 fe80::fdff:ffff:feff:ffff/64 scope link
valid_lft forever preferred_lft forever
eth0 IP address: 192.168.129.5/24
Configured routes for interface eth0:
169.254.0.0 - 255.255.0.0 eth0
Active routes for interface eth0:
192.168.129.0/24 proto kernel scope link src 192.168.129.5
169.254.0.0/16 scope link
1 of 1 configured routes for interface eth0 up

Wäre Klasse wenn mir jemand einen Tip hat wo das Problem liegt !

Danke im vorraus,

Armin
Benutzeravatar
moses
Member
Member
Beiträge: 57
Registriert: 3. Aug 2004, 10:27
Wohnort: Neuwied
Kontaktdaten:

Beitrag von moses »

Welche SuSE Version hast du denn (Personal, Professional) und läuft der ssh daemon überhaupt?
Benutzeravatar
Micar4
Newbie
Newbie
Beiträge: 25
Registriert: 9. Okt 2004, 00:15
Wohnort: Aichach

Beitrag von Micar4 »

Hy Moses,

ich hab Suse 9.1 Proffessional und der sshd läuft ! Wenn ich jedoch in der sshd_config nachsehe dann ist alles auskommentiert !

$OpenBSD: sshd_config,v 1.68 2003/12/29 16:39:50 millert Exp $

# This is the sshd server system-wide configuration file. See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented. Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication no
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
# mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
# in this release. The use of 'gssapi' is deprecated due to the presence of
# potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
#GSSAPIEnableMITMAttack no

# Set this to 'yes' to enable PAM authentication (via challenge-response)
# and session processing. Depending on your PAM configuration, this may
# bypass the setting of 'PasswordAuthentication' and 'PermitEmptyPasswords'
UsePAM yes

#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem sftp /usr/lib/ssh/sftp-server

Mfg,

Armin
Benutzeravatar
moses
Member
Member
Beiträge: 57
Registriert: 3. Aug 2004, 10:27
Wohnort: Neuwied
Kontaktdaten:

Beitrag von moses »

Das ist normal, er benutzt dann einkompilierte Standardwerte. Aber hast du die Firewall aktiviert oder etwas ähnliches? Möchtest du mit XP auf SuSE zugreifen oder SuSE -> SuSE?
Benutzeravatar
Micar4
Newbie
Newbie
Beiträge: 25
Registriert: 9. Okt 2004, 00:15
Wohnort: Aichach

Beitrag von Micar4 »

Hy Moses,

Firewall ist komplett aus ! Möchte Mit suse auf suse verbinden .
Sollte ich vielleicht mal die ssh Pakete neu installieren ?
Das komische ist ja auch das ich mit nmap keinerlei offene Ports angezeigt bekomme :-(.

Danke,

Armin
Benutzeravatar
Micar4
Newbie
Newbie
Beiträge: 25
Registriert: 9. Okt 2004, 00:15
Wohnort: Aichach

Beitrag von Micar4 »

Hy Moses und alle die es Interressiert,

ich hab den Fehler gefunden ! Es war das Onboard LAN auf meinem Asus Board ! Eine Netwerkkarte für 9,95,- eingebaut IP vergeben und es funzt.

Armin
Antworten