Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Achtung! Probleme mit drucken und CUPS nach Update

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4001
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Achtung! Probleme mit drucken und CUPS nach Update

Beitrag von misiu »

Für SuSE 9.1 Nutzer!

Bei Problemen mit drucken nach Update mit YaST- YOU
sollte CUPS deinstalliert und im Anschluss neu
installiert werden. Vorgehensweise ist von SuSE
hier beschrieben:


http://portal.suse.com/sdb/de/2004/07/p ... stall.html

Es sind offensichtlich folgende Pakete, die die Probleme bereiten:

cups 1.1.20-108.13.i586
cups-client 1.1.20-108.13.i586
cups-devel 1.1.20-108.13.i586
cups-libs 1.1.20-108.13.i586
footmatic-filters 3.0.1-41.7.i586

Nachtrag:

CUPS-Programmabstürze (xpp,gtklp,xtpsetup,yast) :

(Dank an Christoph)
ich hatte nach einem Update von SuSE 9.0 auf 9.2 ein Problem mit allen cups Programmen, d.h. den clients.
Sowohl die yast Drucker Konfiguration als auch andere Programme wie gtklp stürzten einfach unverhofft mit Speicherzugriffsfehler ab.

Schuld ist die cups Version bis einschliesslich 1.1.21-5.6, die laut
bug tracking liste einen Fehler bei zu restriktiven Systemeinstellungen hat. Bei mir lag das Problem am tcpwrapper, der alle Zugriffe verbot:
/etc/hosts.allow /etc/hosts.deny

in letzterer stand ALL:ALL drin und in der ersten nichts.
Ich fügte ALL:LOCAL in /etc/hosts.allow ein und siehe da, alles ging wieder!

Ich hoffe anderen hilft der Bericht hier. Ich bin daran beinahe verzweifelt.

Schoenen Gruss,
Christoph
Zuletzt geändert von misiu am 27. Nov 2005, 13:59, insgesamt 2-mal geändert.
sybertronic
Newbie
Newbie
Beiträge: 7
Registriert: 14. Feb 2005, 16:27

Beitrag von sybertronic »

Ist das auch bei suse 9.2 das problem?
uhoso
Newbie
Newbie
Beiträge: 1
Registriert: 11. Mär 2005, 06:53
Wohnort: Soest

hplaserjet 5L unter Suse 9.2

Beitrag von uhoso »

Ich hatte das gleiche Problem.

Ändere doch mal in der yast2 Druckerkonfiguration die PPD-Einstellung auf
HP LaserJet 5L Foomatic /ljet4 ...
bei mir hats funktioniert.

uhoso
Antworten