Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Bootpd automatisch starten

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
ludwig

Bootpd automatisch starten

Beitrag von ludwig »

Hallo Linux Freaks!

Ich habe eine kleinen Problem. Ich möchte einen embedded Rechner über das Netzwerk booten. So weit funktionniert es aber ich muss immer zuerst bootpd und dann xinetd in der Konsole eingeben um den dienst zu starten. Meine Frage:

Wie mache ich, dass bootpd automatisch gestartet wird? In welche Datei muss ich was eintragen?

Ich habe die SuSE 8.2 Pro als Betriebsystem.

Vielen dank für die Hilfe

Ludwig
schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Bootpd automatisch starten

Beitrag von schweer »

ludwig hat geschrieben:Wie mache ich, dass bootpd automatisch gestartet wird? In welche Datei muss ich was eintragen?
Im Prinzip geht es so:
Für das runlevel einen Startlink setzen, Annahme runlevel 3

Code: Alles auswählen

cd /etc/init.d/rc3.d/
ln -s ../xinetd S99xinetd
und entsprechenden Killlink:

Code: Alles auswählen

cd /etc/init.d/rc3.d/
ln -s ../xinetd K01xinetd
(Das geht wahrscheinlich auch mit irgendwelchen GUIs.)
Dann noch im Verzeichnis /etc/xinetd.d eine Datei namens bootpd anlegen (abkupfern von einer anderen Datei in dem Verzeichnis und anpassen, setzen von disable = no nicht vergessen).
Es sollte dann beim Wechsel in das runlevel 3 der bootpd starten.
Ausprobieren z.B. mit "init 1; init 3".

wolfgang
Ludwig

lauft immer noch nicht

Beitrag von Ludwig »

Hallo

Vielen Dank für die erse Hilfe! Es lauft noch nicht, aber ich denke, dass es sicher gut kommt.

Also die Datei bootp-DD2 (die Name sollte keine Rolle spielen, oder?) in /etc/xinetd.d existiert bereit. Ich habe es angepasst und sieht so aus:

# blablalba...
service bootp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
group = root
server = /usr/sbin/bootpd
server_args = -c /tftpboot
disable = no
}

Die Datei bootpd im /usr/sbin is vorhanden.

Das Problem ist, dass ich immer zuerst bootpd in der Konsole eingeben muss. Ich habe mit ps x mal angeschaut und ich beim noramlem Start lauft der Prozesse bootpd nicht.

Soll es noch sonst irgendwo eingetragen werden (boot.local)?

Sorry, aber ich bin mit dem Bootvorgang von SuSE nicht so gut...

Danke im voraus

Ludwig
schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: lauft immer noch nicht

Beitrag von schweer »

Hast Du schon mal im syslog nachgesehen? Der bootpd startet auf diese Weise (über den xinetd) ja erst, wenn er kontaktiert wird (also der Dienst von einem client angefordert wird).

wolfgang
Antworten