Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Nicht mal der Ping

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
mampfi

Nicht mal der Ping

Beitrag von mampfi »

Rechner mit Windows XP: IP=192.168.0.2
SuSe Linux 7.2 (nicht Professional):

Ergebnis: Null Funktion, Nicht mal der Ping

Fehlermeldung ret=-1

oder Ausgabe "56 Bytes" und bleibt der Ping hängen
Benutzeravatar
nny
Member
Member
Beiträge: 226
Registriert: 4. Jan 2004, 17:06

Beitrag von nny »

hi,
das sind leider nur sehr ungenaue Angaben von Dir....
is XP und SuSE auf dem gleichen Rechner?
sprich tut die Karte unter XP? oder ganz andere Rechner, dann vielleicht Karte kaputt, Kabel kaputt???
tut ping localhost? oder bleibst da auch hängen???
was sagt den den ifconfig ?? Oder lspci ?? wird die Karte überhaupt erkannt???
it takes a nation of millions to hold us back
Chuck D / Public Enemy No1
/join #nny @ euIRC
poiin2000
Member
Member
Beiträge: 55
Registriert: 29. Jan 2004, 17:04
Wohnort: Pforzheim
Kontaktdaten:

Beitrag von poiin2000 »

Code: Alles auswählen

nmap -sP $ip
Eventuell 127.0.0.1 verwenden

iputils neu installieren?

ifconfig -a

route

mfg p2k
mampfi

Beitrag von mampfi »

Das XP ist auf einem anderen Athlon. Das Problem muss an dem Linux-Rechner (Duron) liegen, weil ich mit einem anderen Rechner die selben Probleme hatte.

Auf dem Duron ist noch ein Windows 98 installiert, wenn beide Windows gebootet sind, dann funktioniert das Netzwerk.
poiin2000
Member
Member
Beiträge: 55
Registriert: 29. Jan 2004, 17:04
Wohnort: Pforzheim
Kontaktdaten:

Beitrag von poiin2000 »

Gebe bitte auf der 'Konsole' deines Linux Systems (Unter KDE Terminal) folgendes als root ein.

Code: Alles auswählen

ifconfig -a

nmap -sP 127.0.0.1

ping 127.0.0.1

route
Die Ausgaben davon bitte hier in diesen Thread

p2k
Gast

Beitrag von Gast »

Ausgabe von ifconfig:
-----------------------


o Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:33 errors:0 dropped:0 overruns:0 frame:0
TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:2148 (2.0 Kb) TX bytes:2148 (2.0 Kb)

ppp0 Protokoll:Punkt-zu-Punkt Verbindung
inet Adresse:217.184.110.14 P-z-P:213.20.173.65 Maske:255.255.255.255
UP PUNKTZUPUNKT RUNNING NOARP MULTICAST MTU:1514 Metric:1
RX packets:274 errors:0 dropped:0 overruns:0 frame:0
TX packets:355 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:3
RX bytes:98363 (96.0 Kb) TX bytes:61267 (59.8 Kb)

sit0 Protokoll:IPv6-nach-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Ausgabe von ping:
---------------------

PING 127.0.0.1 (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=255 time=0.185 ms
64 bytes from 127.0.0.1: icmp_seq=1 ttl=255 time=0.151 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=255 time=0.152 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=255 time=0.158 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=255 time=0.155 ms
64 bytes from 127.0.0.1: icmp_seq=5 ttl=255 time=0.153 ms
64 bytes from 127.0.0.1: icmp_seq=6 ttl=255 time=0.146 ms
64 bytes from 127.0.0.1: icmp_seq=7 ttl=255 time=0.149 ms
64 bytes from 127.0.0.1: icmp_seq=8 ttl=255 time=0.170 ms
64 bytes from 127.0.0.1: icmp_seq=9 ttl=255 time=0.153 ms
64 bytes from 127.0.0.1: icmp_seq=10 ttl=255 time=0.158 ms
64 bytes from 127.0.0.1: icmp_seq=11 ttl=255 time=0.154 ms
64 bytes from 127.0.0.1: icmp_seq=12 ttl=255 time=0.150 ms
64 bytes from 127.0.0.1: icmp_seq=13 ttl=255 time=0.153 ms
--- 127.0.0.1 ping statistics ---
14 packets transmitted, 14 packets received, 0% packet loss
round-trip min/avg/max = 0.146/0.156/0.185 ms

Ausgabe von route:
----------------------

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
213.20.173.65 * 255.255.255.255 UH 0 0 0 ppp0
default 213.20.173.65 0.0.0.0 UG 0 0 0 ppp0

Der nmap ist bei mir offenbar nicht vorhanden.

Mit locate und find -name wird er nicht gefunden
mampfi

Beitrag von mampfi »

Sorry, Gast war ich
poiin2000
Member
Member
Beiträge: 55
Registriert: 29. Jan 2004, 17:04
Wohnort: Pforzheim
Kontaktdaten:

Beitrag von poiin2000 »

Soweit ok.

Du solltest deine Netzwerkkarte mit yast noch mit einer Privaten IP Adresse (z.B. 192.168.0.3) konfigurieren.

Besser wäre es wenn du eine 2 Netzwerkkarte einbauen kannst.

Code: Alles auswählen

ifconfig eth0 down
ifconfig eth0 192.168.0.3
ifconfig eth0 up
ping 192.168.0.2
ping 192.168.0.3
Ich vermute mal das dies nicht geht ... aber teste es mal;)

Gruss poiin2000
mampfi

Dank

Beitrag von mampfi »

Danke, werd ich mal probieren
Antworten