Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[erledigt] Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
Christina
Member
Member
Beiträge: 190
Registriert: 4. Mär 2019, 13:44

[erledigt] Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Christina »

Hi,
ich habe jetzt auf Leap 15.3 umgestellt und möchte die ältere Version Audacity 2.2.2 gegen 2.4.2 ersetzen.
"multimedia:apps"-Repository: http://download.opensuse.org/repositori ... Leap_15.3/
Yast bringt hier eine Fehlermeldung:

Code: Alles auswählen

#### YaST2 conflicts list - generated 2021-11-03 11:01:26 ####

nichts stellt 'libavcodec.so.58.91()(64bit)' bereit, das vom zu installierenden audacity-2.4.2-lp153.172.13.x86_64 benötigt wird

    [ ] audacity-2.4.2-lp153.172.13.x86_64 nicht installieren
    [ ] audacity-2.4.2-lp153.172.13.x86_64 durch Ignorieren einiger Abhängigkeiten brechen


nichts stellt 'libavcodec.so.58.91()(64bit)' bereit, das vom zu installierenden audacity-2.4.2-lp153.172.13.x86_64 benötigt wird

    [ ] audacity-2.4.2-lp153.172.13.x86_64 durch Ignorieren einiger Abhängigkeiten brechen
    [ ] audacity-lang-2.4.2-lp153.172.13.noarch nicht installieren


#### YaST2 conflicts list END ###
Das Build-Datum von audacity 2.4.2-lp153.172.13 ist Sa 06 Mär 2021 16:54:57 CET, also sehr alt. Hier vermute ich den Fehler.
In libavcodec58_134 - FFmpeg codec library ist eine neuere Datei vorhanden /usr/lib64/libavcodec.so.58.134.100

Gibt es irgendwo einen aktuelleren Build für Audacity 2.4.2 oder soll ich die (fälschliche) Abhängigkeit brechen?

lg Christina
Zuletzt geändert von Christina am 4. Nov 2021, 17:38, insgesamt 1-mal geändert.
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Sauerland »

Das Problem ist, das eigentlich in dem Repo schon audacity 3.0.5 gebaut wird, welches aber unter Leap wegen fehlender Abhängigkeiten nicht baut.......

Benutze einfach die Version aus dem OSS Repo.
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Christina
Member
Member
Beiträge: 190
Registriert: 4. Mär 2019, 13:44

Re: Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Christina »

OK, Danke dir.
Die Suche nach RPMs auf https://software.opensuse.org/search liefert bei Leap 15.3 zur Zeit irgendwie kaum oder unzureichende Ergebnisse. Da wird vermutlich gerade umgebaut.
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Sauerland »

Christina hat geschrieben: 4. Nov 2021, 10:14 OK, Danke dir.
Die Suche nach RPMs auf https://software.opensuse.org/search liefert bei Leap 15.3 zur Zeit irgendwie kaum oder unzureichende Ergebnisse. Da wird vermutlich gerade umgebaut.
Nö, alles da:
https://software.opensuse.org/package/audacity
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Christina
Member
Member
Beiträge: 190
Registriert: 4. Mär 2019, 13:44

Re: Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Christina »

Audacity 2.4.2 im multimedia:apps-Repo fehlt bei der Trefferausgabe für Leap 15.3.
Das ist mir auch schon bei einigen anderen Programmen aufgefallen.
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Sauerland »

Weiter runterscrollen-----nicht offizielle Pakete azeigen lassen-----SUSE:SLE-15:GA--------dort gibt es Pakete in multimedia:apps.......

Oder auch /home Repos mit audacity 3.0.5:
https://build.opensuse.org/package/show ... s/audacity
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Christina
Member
Member
Beiträge: 190
Registriert: 4. Mär 2019, 13:44

Re: Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Christina »

Sauerland hat geschrieben: 4. Nov 2021, 11:41 Weiter runterscrollen-----nicht offizielle Pakete azeigen lassen-----SUSE:SLE-15:GA--------
Danke, darauf wäre ich nicht gekommen.
Genau da finden sich auch die vermissten Programme, die in den Repositories tatsächlich aber in einem Unterverzeichnis "openSUSE_Leap_15.3" liegen.
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Audacity 2.4.2 - Konflikt: libavcodec.so.58 - Leap 15.3

Beitrag von Sauerland »

Es gibt auf software.opensuse.org Probleme mit Leap 15.3, da diese auf SLE beruht und somit werden nicht alle Pakete angezeigt.
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Antworten