Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst]Probleme mit der Zeitanzeige

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 748
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

[Gelöst]Probleme mit der Zeitanzeige

Beitrag von lewendi »

Wenn ich unter Kubuntu die Zeit in "Systemeinstellungen" einstelle und anschließend Windows starte ist die Zeit immer um 2 Stunden verstellt.
Eine Korrektur im Bios bringt auch nix.

Ich nehme mal an dass es mit einer der 2 Zeiten zu tun hat.
timedatectl
Local time: Mo 2021-10-18 16:16:15 CEST
Universal time: Mo 2021-10-18 14:16:15 UTC
RTC time: Mo 2021-10-18 14:16:15
Time zone: Europe/Berlin (CEST, +0200)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no
Wie kann ich das ändern?

Gruß
lewendi
Zuletzt geändert von lewendi am 19. Okt 2021, 11:28, insgesamt 1-mal geändert.
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 1040
Registriert: 19. Sep 2014, 18:22

Re: Probleme mit der Zeitanzeige

Beitrag von susejunky »

Hallo lewendi,
lewendi hat geschrieben: 18. Okt 2021, 16:39 Wenn ich unter Kubuntu die Zeit in "Systemeinstellungen" einstelle und anschließend Windows starte ist die Zeit immer um 2 Stunden verstellt.
Eine Korrektur im Bios bringt auch nix.

Ich nehme mal an dass es mit einer der 2 Zeiten zu tun hat.
timedatectl
Local time: Mo 2021-10-18 16:16:15 CEST
Universal time: Mo 2021-10-18 14:16:15 UTC
RTC time: Mo 2021-10-18 14:16:15
Time zone: Europe/Berlin (CEST, +0200)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no
Wie kann ich das ändern?

Gruß
lewendi
welchen Wert hat in Deinem MS Windows der Registry-Eintrag

Code: Alles auswählen

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
oder existiert dieser Eintrag bei Dir nicht?

Falls der Eintrag nicht existiert oder den Wert 0 hat, so bedeutet das, dass Dein MS Windows erwartet, dass Deine Rechner-Hardware-Uhr auf Lokalzeit (aktuell CEST) eingestellt ist. Kubuntu hat aber Deine Rechneruhr auf UTC (CEST-2) gesetzt.

Wenn Du in MS Windows den oben genannten Registry-Schlüssel anlegst (Typ: DWORD) und/oder auf 1 setzt, dann sollte MS Windows nach dem nächsten Neustart mit dem UTC Deiner Rechner-Hardware-Uhr arbeiten.

Viele Grüße

susejunky
Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 748
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

Re: Probleme mit der Zeitanzeige

Beitrag von lewendi »

@susejunky

Code: Alles auswählen

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
Den Eintrag gab es bei mir nicht, warum, keine Ahnung.
Erstellt -> funktioniert. ;)

Danke und Grüße

lewendi
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 1040
Registriert: 19. Sep 2014, 18:22

Re: Probleme mit der Zeitanzeige

Beitrag von susejunky »

Hallo lewendi,
lewendi hat geschrieben: 19. Okt 2021, 11:28...

Code: Alles auswählen

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
Den Eintrag gab es bei mir nicht, warum, keine Ahnung.
soweit mir bekannt, ist die "Standard-Erwartungshaltung" von MS Windows, dass die Rechner-Hardware-Uhr mit der lokalen Zeit (z.B. CEST/CET) betrieben wird.

Viele Linux-Distributionen (z.B. openSUSE) stellen die Rechner-Hardware-Uhr aber auf UTC ein (und halten diese Einstellung bei jedem Abgleich mit einem NTP-Server auch ein). Die Umrechnung von UTC auf die lokale Zeit erfolgt dann durch das Betriebssystem bzw. die Desktop-Umgebung.

Besagter Registry-Schlüssel wird in MS Windows erst dann benötigt, wenn die Rechner-Hardware-Uhr mit UTC betrieben wird (und MS Windows die Umrechnung von UTC auf lokale Zeit vornehmen muss).

Viele Grüße

susejunky
Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 748
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

Re: [Gelöst]Probleme mit der Zeitanzeige

Beitrag von lewendi »

Alles klar. Kapiert! ;) ;)
Antworten