Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Updateprobleme mit pipewire-lang

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
bayernherz
Hacker
Hacker
Beiträge: 506
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

[gelöst] Updateprobleme mit pipewire-lang

Beitrag von bayernherz »

hallo zusammen,

ich verwende:
Betriebssystem: openSUSE Tumbleweed 20210904
KDE-Plasma-Version: 5.22.5
KDE-Frameworks-Version: 5.85.0
Qt-Version: 5.15.2
Kernel-Version: 5.14.0-1-default (64-bit)
Grafik-Plattform: X11
Prozessoren: 4 × Intel® Core™ i5-6267U CPU @ 2.90GHz
Speicher: 15,5 GiB Arbeitsspeicher
Grafikprozessor: Mesa Intel® Iris® Graphics 550

und bekomme beim update mit

Code: Alles auswählen

zypper dup
folgend Fehlermeldung

Code: Alles auswählen

Problem: das zu installierende pipewire-lang-0.3.38-2.1.noarch erfordert 'pipewire = 0.3.38', aber diese Anforderung kann nicht bereitgestellt werden
  Nicht installierbare Anbieter: pipewire-0.3.38-2.1.i586[packman-rwth]
  pipewire-0.3.38-2.1.x86_64[packman-rwth]

Lösung 1: Folgende Aktionen werden ausgeführt:
  veraltetes pipewire-0.3.34-1.1.x86_64 beibehalten
  veraltetes libpipewire-0_3-0-0.3.34-1.1.x86_64 beibehalten
  veraltetes pipewire-tools-0.3.34-1.1.x86_64 beibehalten
  veraltetes pipewire-modules-0.3.34-1.1.x86_64 beibehalten
  veraltetes pipewire-spa-plugins-0_2-0.3.34-1.1.x86_64 beibehalten
  veraltetes pipewire-spa-tools-0.3.34-1.1.x86_64 beibehalten
 
 Lösung 2: install pipewire-0.3.38-2.1.x86_64 from vendor http://packman.links2linux.de
  replacing pipewire-0.3.34-1.1.x86_64 from vendor openSUSE
 
 Lösung 3: install pipewire-lang-0.3.37-1.1.noarch from vendor openSUSE
  replacing pipewire-lang-0.3.34-2.7.noarch from vendor http://packman.links2linux.de
 
 Lösung 4: pipewire-lang-0.3.38-2.1.noarch durch Ignorieren einiger Abhängigkeiten brechen

Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/3/4/a/d/?] (a): 

Code: Alles auswählen

zypper se -s pipewire
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name                                     | Type       | Version    | Arch   | Repository
--+------------------------------------------+------------+------------+--------+------------------------
  | gstreamer-plugin-pipewire                | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | gstreamer-plugin-pipewire                | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | gstreamer-plugin-pipewire                | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | gstreamer-plugin-pipewire                | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | gstreamer-plugin-pipewire-debuginfo      | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | gstreamer-plugin-pipewire-debuginfo      | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | libpipewire-0_2-1                        | Paket      | 0.2.7-1.9  | x86_64 | openSUSE-Tumbleweed-Oss
  | libpipewire-0_2-1                        | Paket      | 0.2.7-1.9  | i586   | openSUSE-Tumbleweed-Oss
i | libpipewire-0_3-0                        | Paket      | 0.3.34-1.1 | x86_64 | (Systempakete)
v | libpipewire-0_3-0                        | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
v | libpipewire-0_3-0                        | Paket      | 0.3.38-2.1 | i586   | packman-rwth
v | libpipewire-0_3-0                        | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
v | libpipewire-0_3-0                        | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | libpipewire-0_3-0-32bit                  | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | libpipewire-0_3-0-32bit                  | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | libpipewire-0_3-0-32bit-debuginfo        | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | libpipewire-0_3-0-debuginfo              | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | libpipewire-0_3-0-debuginfo              | Paket      | 0.3.38-2.1 | i586   | packman-rwth
i | pipewire                                 | Paket      | 0.3.34-1.1 | x86_64 | (Systempakete)
v | pipewire                                 | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
v | pipewire                                 | Paket      | 0.3.38-2.1 | i586   | packman-rwth
v | pipewire                                 | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
v | pipewire                                 | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire                                 | Quellpaket | 0.3.38-2.1 | noarch | packman-rwth
  | pipewire                                 | Quellpaket | 0.3.34-2.1 | noarch | packman-rwth
  | pipewire-alsa                            | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-alsa                            | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-alsa                            | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-alsa                            | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-alsa-32bit                      | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-alsa-32bit                      | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-alsa-32bit-debuginfo            | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-alsa-debuginfo                  | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-alsa-debuginfo                  | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-debuginfo                       | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-debuginfo                       | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-debugsource                     | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-debugsource                     | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-devel                           | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-devel                           | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-devel                           | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-devel                           | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-doc                             | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-doc                             | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-doc                             | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-doc                             | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
i | pipewire-lang                            | Paket      | 0.3.34-2.7 | noarch | (Systempakete)
v | pipewire-lang                            | Paket      | 0.3.38-2.1 | noarch | packman-rwth
v | pipewire-lang                            | Paket      | 0.3.34-2.1 | noarch | packman-rwth
v | pipewire-lang                            | Paket      | 0.3.37-1.1 | noarch | openSUSE-Tumbleweed-Oss
  | pipewire-libjack-0_3                     | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-libjack-0_3                     | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-libjack-0_3                     | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-libjack-0_3                     | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-libjack-0_3-32bit               | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-libjack-0_3-32bit               | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-libjack-0_3-32bit-debuginfo     | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-libjack-0_3-debuginfo           | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-libjack-0_3-debuginfo           | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-libjack-0_3-devel               | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-libjack-0_3-devel               | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-libjack-0_3-devel               | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-libjack-0_3-devel               | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
i | pipewire-media-session                   | Paket      | 0.3.34-2.7 | x86_64 | (Systempakete)
v | pipewire-media-session                   | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
v | pipewire-media-session                   | Paket      | 0.3.38-2.1 | i586   | packman-rwth
v | pipewire-media-session                   | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
v | pipewire-media-session                   | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-media-session-debuginfo         | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-media-session-debuginfo         | Paket      | 0.3.38-2.1 | i586   | packman-rwth
i | pipewire-modules                         | Paket      | 0.3.34-1.1 | x86_64 | (Systempakete)
v | pipewire-modules                         | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
v | pipewire-modules                         | Paket      | 0.3.38-2.1 | i586   | packman-rwth
v | pipewire-modules                         | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
v | pipewire-modules                         | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-modules-32bit                   | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-modules-32bit                   | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-modules-32bit-debuginfo         | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-modules-debuginfo               | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-modules-debuginfo               | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-pulseaudio                      | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-pulseaudio                      | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire-pulseaudio                      | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-pulseaudio                      | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-pulseaudio-debuginfo            | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-pulseaudio-debuginfo            | Paket      | 0.3.38-2.1 | i586   | packman-rwth
i | pipewire-spa-plugins-0_2                 | Paket      | 0.3.34-1.1 | x86_64 | (Systempakete)
v | pipewire-spa-plugins-0_2                 | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
v | pipewire-spa-plugins-0_2                 | Paket      | 0.3.38-2.1 | i586   | packman-rwth
v | pipewire-spa-plugins-0_2                 | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
v | pipewire-spa-plugins-0_2                 | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-spa-plugins-0_2-32bit           | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-spa-plugins-0_2-32bit           | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire-spa-plugins-0_2-32bit-debuginfo | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-spa-plugins-0_2-debuginfo       | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-spa-plugins-0_2-debuginfo       | Paket      | 0.3.38-2.1 | i586   | packman-rwth
i | pipewire-spa-tools                       | Paket      | 0.3.34-1.1 | x86_64 | (Systempakete)
v | pipewire-spa-tools                       | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
v | pipewire-spa-tools                       | Paket      | 0.3.38-2.1 | i586   | packman-rwth
v | pipewire-spa-tools                       | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
v | pipewire-spa-tools                       | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-spa-tools-debuginfo             | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-spa-tools-debuginfo             | Paket      | 0.3.38-2.1 | i586   | packman-rwth
i | pipewire-tools                           | Paket      | 0.3.34-1.1 | x86_64 | (Systempakete)
v | pipewire-tools                           | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
v | pipewire-tools                           | Paket      | 0.3.38-2.1 | i586   | packman-rwth
v | pipewire-tools                           | Paket      | 0.3.37-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
v | pipewire-tools                           | Paket      | 0.3.37-1.1 | i586   | openSUSE-Tumbleweed-Oss
  | pipewire-tools-debuginfo                 | Paket      | 0.3.38-2.1 | x86_64 | packman-rwth
  | pipewire-tools-debuginfo                 | Paket      | 0.3.38-2.1 | i586   | packman-rwth
  | pipewire0_2-compat                       | Paket      | 0.2.7-1.9  | x86_64 | openSUSE-Tumbleweed-Oss
  | pipewire0_2-compat                       | Paket      | 0.2.7-1.9  | i586   | openSUSE-Tumbleweed-Oss

Code: Alles auswählen

zypper se -s pipewire-lang
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name          | Type  | Version    | Arch   | Repository
--+---------------+-------+------------+--------+------------------------
i | pipewire-lang | Paket | 0.3.34-2.7 | noarch | (Systempakete)
v | pipewire-lang | Paket | 0.3.38-2.1 | noarch | packman-rwth
v | pipewire-lang | Paket | 0.3.34-2.1 | noarch | packman-rwth
v | pipewire-lang | Paket | 0.3.37-1.1 | noarch | openSUSE-Tumbleweed-Oss
 
Ich wäre für einen Tipp von Euch sehr dankbar. ;)

bayernherz :thumbs:
Zuletzt geändert von bayernherz am 7. Okt 2021, 13:20, insgesamt 1-mal geändert.
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5553
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Updateprobleme mit pipewire-lang

Beitrag von tomm.fa »

Lösung/Vorschlag Nummer 2?
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
bayernherz
Hacker
Hacker
Beiträge: 506
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Updateprobleme mit pipewire-lang

Beitrag von bayernherz »

hallo zusammen,
während des Updates
habe ich interaktiv noch nachfolgende Packete nach packman convertiert.

Code: Alles auswählen

zypper dup
....
Die folgenden 6 Pakete werden den Anbieter ändern:
  libpipewire-0_3-0         openSUSE -> http://packman.links2linux.de
  pipewire                  openSUSE -> http://packman.links2linux.de
  pipewire-modules          openSUSE -> http://packman.links2linux.de
  pipewire-spa-plugins-0_2  openSUSE -> http://packman.links2linux.de
  pipewire-spa-tools        openSUSE -> http://packman.links2linux.de
  pipewire-tools            openSUSE -> http://packman.links2linux.de
....
Damit ist das Problem erledigt. ;)
Ich bedanke mich für den Hinweis.

bayernherz :thumbs:
Antworten