Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] align_image-stack findet libhdf5 nicht

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Lance_Blastoff
Member
Member
Beiträge: 81
Registriert: 13. Jan 2008, 17:46

[Gelöst] align_image-stack findet libhdf5 nicht

Beitrag von Lance_Blastoff »

Ich poste dies mal in Multimedia wenn es nicht passt bitte verschieben.

Ich möchte mit align_image_stack ein paar Bilder ausrichten beim Aufruf auf der Kommandozeile bekomme ich diese Meldung

Code: Alles auswählen

align_image_stack: error while loading shared libraries: libhdf5_hl.so.100: cannot open shared object file: No such file or directory
ein

Code: Alles auswählen

locate libhdf5_hl.so.100 
           
gibt
                   

Code: Alles auswählen

/usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.100 
/usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.100.0.1
Ich habe dann noch die 32 bit Variante installiert und jetzt gibt

Code: Alles auswählen

locate libhdf5_hl.so.100 
/usr/lib/mpi/gcc/openmpi/lib/libhdf5_hl.so.100 
/usr/lib/mpi/gcc/openmpi/lib/libhdf5_hl.so.100.0.1 
/usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.100 
/usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.100.0.1
die Fehlermeldung bleibt die gleiche.

Im den weiten des Netzes kann ich nichts zur Kombination libhdf5 und align_image_stack finden.

BS ist OpenSuse 15.3 in 15.1 ging es noch ohne Probleme.

Wisst Ihr Rat?
Zuletzt geändert von Lance_Blastoff am 28. Sep 2021, 08:23, insgesamt 1-mal geändert.
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: align_image-stack findet libhdf5 nicht

Beitrag von Sauerland »

Ist im OSS Repo:

Code: Alles auswählen

zypper se -s libhdf5_hl100
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                         | Type  | Version           | Arch   | Repository
---+------------------------------+-------+-------------------+--------+-----------
i+ | libhdf5_hl100                | Paket | 1.10.7-bp153.3.43 | x86_64 | OSS
   | libhdf5_hl100-32bit          | Paket | 1.10.7-2.34       | x86_64 | OSS
   | libhdf5_hl100-mvapich2       | Paket | 1.10.7-bp153.3.44 | x86_64 | OSS
   | libhdf5_hl100-mvapich2-32bit | Paket | 1.10.7-2.29       | x86_64 | OSS
   | libhdf5_hl100-openmpi        | Paket | 1.10.1-6.8        | x86_64 | OSS
   | libhdf5_hl100-openmpi-32bit  | Paket | 1.10.1-6.8        | x86_64 | OSS
i  | libhdf5_hl100-openmpi2       | Paket | 1.10.7-bp153.3.62 | x86_64 | OSS
   | libhdf5_hl100-openmpi2-32bit | Paket | 1.10.7-2.36       | x86_64 | OSS
   | libhdf5_hl100-openmpi3       | Paket | 1.10.7-bp153.3.62 | x86_64 | OSS
   | libhdf5_hl100-openmpi3-32bit | Paket | 1.10.7-2.35       | x86_64 | OSS
   | libhdf5_hl100-openmpi4       | Paket | 1.10.7-bp153.3.61 | x86_64 | OSS
   | libhdf5_hl100-openmpi4-32bit | Paket | 1.10.7-2.35       | x86_64 | OSS

Code: Alles auswählen

rpm -ql libhdf5_hl100
/usr/lib64/libhdf5_hl.so.100
/usr/lib64/libhdf5_hl.so.100.1.4
/usr/share/licenses/libhdf5_hl100
/usr/share/licenses/libhdf5_hl100/COPYING
Also als root:

Code: Alles auswählen

zypper in -f libhdf5_hl100
Denn anscheinend wird nicht in dem von Dir geposteten Verzeichnis gesucht....
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Benutzeravatar
Lance_Blastoff
Member
Member
Beiträge: 81
Registriert: 13. Jan 2008, 17:46

Re: align_image-stack findet libhdf5 nicht

Beitrag von Lance_Blastoff »

Du hast meinen Tag gerettet!

Code: Alles auswählen

locate libhdf5_hl.so.100 
/usr/lib/mpi/gcc/openmpi/lib/libhdf5_hl.so.100 
/usr/lib/mpi/gcc/openmpi/lib/libhdf5_hl.so.100.0.1 
/usr/lib64/libhdf5_hl.so.100 
/usr/lib64/libhdf5_hl.so.100.1.4 
/usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.100 
/usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.100.0.1


Kurze Nachfrage sollte Hugin das nicht selbsttätig mit installieren? alig_image_stack ist ja Besatndteil von Hugin.
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5552
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: align_image-stack findet libhdf5 nicht

Beitrag von tomm.fa »

Lance_Blastoff hat geschrieben: 28. Sep 2021, 08:22Kurze Nachfrage sollte Hugin das nicht selbsttätig mit installieren? alig_image_stack ist ja Besatndteil von Hugin.
Macht es doch auch.
Musste es erst wieder zur Vorführung entfernen:

Code: Alles auswählen

zypper rm libhdf5_hl100
Reading installed packages...
Resolving package dependencies...

The following 10 packages are going to be REMOVED:
  enblend-enfuse gdal hugin libgdal29 libhdf5_hl100 libnetcdf18 libvigraimpex11 python3-GDAL qgis qmapshack

10 packages to remove.
After the operation, 399.3 MiB will be freed.
Continue? [y/n/v/...? shows all options] (y): 
( 1/10) Removing hugin-2019.2.0-bp153.1.21.x86_64 .....................................................................................................................................[done]
( 2/10) Removing qgis-3.18.3-lp153.63.11.x86_64 .......................................................................................................................................[done]
( 3/10) Removing qmapshack-1.15.2-lp153.3.4.x86_64 ....................................................................................................................................[done]
( 4/10) Removing enblend-enfuse-4.2-bp153.2.1.x86_64 ..................................................................................................................................[done]
( 5/10) Removing gdal-3.3.2-lp153.154.1.x86_64 ........................................................................................................................................[done]
( 6/10) Removing libvigraimpex11-1.11.1-bp153.1.21.x86_64 .............................................................................................................................[done]
( 7/10) Removing python3-GDAL-3.3.2-lp153.154.1.x86_64 ................................................................................................................................[done]
( 8/10) Removing libgdal29-3.3.2-lp153.154.1.x86_64 ...................................................................................................................................[done]
( 9/10) Removing libnetcdf18-4.7.4-bp153.3.11.x86_64 ..................................................................................................................................[done]
(10/10) Removing libhdf5_hl100-1.10.7-bp153.3.43.x86_64 ...............................................................................................................................[done]
Dann die Installation von hugin:

Code: Alles auswählen

zypper in hugin
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 4 NEW packages are going to be installed:
  enblend-enfuse hugin libhdf5_hl100 libvigraimpex11

4 new packages to install.
Overall download size: 13.2 MiB. Already cached: 0 B. After the operation, additional 44.9 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): 
Retrieving package libhdf5_hl100-1.10.7-bp153.3.43.x86_64                                                                                               (1/4),  82.0 KiB (154.3 KiB unpacked)
Retrieving: libhdf5_hl100-1.10.7-bp153.3.43.x86_64.rpm ................................................................................................................................[done]
Retrieving package libvigraimpex11-1.11.1-bp153.1.21.x86_64                                                                                             (2/4), 195.8 KiB (676.1 KiB unpacked)
Retrieving: libvigraimpex11-1.11.1-bp153.1.21.x86_64.rpm ..............................................................................................................................[done]
Retrieving package enblend-enfuse-4.2-bp153.2.1.x86_64                                                                                                  (3/4),   1.3 MiB (  7.0 MiB unpacked)
Retrieving: enblend-enfuse-4.2-bp153.2.1.x86_64.rpm ...................................................................................................................................[done]
Retrieving package hugin-2019.2.0-bp153.1.21.x86_64                                                                                                     (4/4),  11.6 MiB ( 37.1 MiB unpacked)
Retrieving: hugin-2019.2.0-bp153.1.21.x86_64.rpm ..........................................................................................................................[done (7.3 MiB/s)]

Checking for file conflicts: ..........................................................................................................................................................[done]
(1/4) Installing: libhdf5_hl100-1.10.7-bp153.3.43.x86_64 ..............................................................................................................................[done]
(2/4) Installing: libvigraimpex11-1.11.1-bp153.1.21.x86_64 ............................................................................................................................[done]
(3/4) Installing: enblend-enfuse-4.2-bp153.2.1.x86_64 .................................................................................................................................[done]
(4/4) Installing: hugin-2019.2.0-bp153.1.21.x86_64 ....................................................................................................................................[done]
und libhdf5_hl100 ist dabei.
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
Antworten