Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
diemoe
Newbie
Newbie
Beiträge: 28
Registriert: 20. Aug 2005, 12:34
Wohnort: Bamberg / Oberfranken
Kontaktdaten:

[Gelöst] openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von diemoe »

Guten Tag zusammen,

seit einigen Tagen lässt sich Jackd auf meinem Rechner nicht mehr starten. Zu dem Thema finden sich sehr viele Beiträge im Netz (zum Teil über 10 Jahre alt), aber diesmal komme ich nicht weiter. Beim Start mit QJackCtl erhalte ich jedesmal diese Ausgabe:

Code: Alles auswählen

11:39:23.545 Statistik zurückgesetzt.
11:39:23.547 ALSA-Verbindung geändert.
Cannot connect to server socket err = Datei oder Verzeichnis nicht gefunden
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
11:39:23.632 Schaubild der ALSA-Verbindungen geändert.
11:39:25.376 JACK startet...
11:39:25.377 /usr/bin/jackd -m -dalsa -r44100 -p1024 -n2 -D -Chw:DSP -Phw:DSP
Cannot connect to server socket err = Datei oder Verzeichnis nicht gefunden
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
no message buffer overruns
11:39:25.396 JACK wurde mit PID = 5175 gestartet.
no message buffer overruns
no message buffer overruns
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:DSP|hw:DSP|1024|2|44100|0|0|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: mmap-based access is not possible for the capture stream of this audio interface
ALSA: cannot configure capture channel
Released audio card Audio0
audio_reservation_finish
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
11:39:25.499 JACK wurde angehalten
11:39:30.598 Keine Verbindungsaufnahme als Client zum JACK-Server möglich. - Gesamtbetrieb schlug fehl. - Verbindungsaufnahme zum Server gescheitert. Bitte sehen Sie im Meldungsfenster nach weiteren Informationen.
Cannot connect to server socket err = Datei oder Verzeichnis nicht gefunden
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Ich habe auch schon versucht, Jackd mit 'Cadence' zu starten, aber ebenfalls ohne Erfolg. Eine Installation entspr. Pakete aus dem Multimedia-Repo haben ebenfalls keinen Erfolg gebracht. In meinem Acer VERITON stecken zwei Soundkarten, die RME Hammerfall HDSP 9632 und meine Grafikkarte, der dritte Eintrag stammt von meiner WebCam:

Code: Alles auswählen

dietmar@localhost:~> cat /proc/asound/cards
 0 [DSP            ]: H-DSP - Hammerfall DSP
                      RME Hammerfall HDSP 9632 at 0xfbef0000, irq 21
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfbd7c000 irq 17
 2 [U0x46d0x804    ]: USB-Audio - USB Device 0x46d:0x804
                      USB Device 0x46d:0x804 at usb-0000:00:1d.0-1.2, high speed
Als Benutzer befinde ich mich in der Gruppe 'Audio', auch meine limits.conf ist entsprechend angepasst.
Das weitere Setup für meine Maschine habe ich mit dem Perl-Skript 'realtimeconfigquickscan' optimiert:

Code: Alles auswählen

== GUI-enabled checks ==
Checking if you are root... no - good
Checking filesystem 'noatime' parameter... 5.3.18 kernel - good
(relatime is default since 2.6.30)
Checking CPU Governors... CPU 0: 'ondemand' CPU 1: 'ondemand' CPU 2: 'ondemand' CPU 3: 'ondemand'  - not good
Set CPU Governors to 'performance' with 'cpupower frequency-set -g performance' or 'cpufreq-set -c <cpunr> -g performance' (Debian/Ubuntu)
See also: http://linuxmusicians.com/viewtopic.php?f=27&t=844
Checking swappiness... System running without disk swap - good
** Your system is configured without swap. No swap => no problem between swap and realtime
Checking for resource-intensive background processes... none found - good
Checking checking sysctl inotify max_user_watches... >= 524288 - good
Checking whether you're in the 'audio' group... yes - good
Checking for multiple 'audio' groups... no - good
Checking the ability to prioritize processes with chrt... yes - good
Checking kernel support for high resolution timers... found - good
Kernel with Real-Time Preemption... not found - not good
Kernel without 'threadirqs' parameter or real-time capabilities found
For more information, see https://wiki.linuxaudio.org/wiki/system_configuration#do_i_really_need_a_real-time_kernel
Checking if kernel system timer is high-resolution... found - good
Checking kernel support for tickless timer... found - good
== Other checks ==
Checking filesystem types... ok.
** Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks.
   Find your sound card's IRQ by looking at '/proc/interrupts' and lspci.
Ich verwende Jack seit 15 Jahren und habe damit schon einiges erlebt - aber diesmal bin ich ziemlich ratlos, da meine Audio-Installation (mit Harrison Mixbus als DAW - und ohne Realtime-Kernel) vor wenigen Tagen noch tadellos funktionierte.

Was ist hier los? :???:

Ziemlich ratlos, mit freundlichen Grüßen und der Bitte um Hilfe

Dietmar
Zuletzt geändert von diemoe am 2. Sep 2021, 20:26, insgesamt 1-mal geändert.
Acer VERITON M680G
4x Intel Core i5 CPU 650 @ 3,2 GHz
NVIDIA GeForce GT 1030
RME Hammerfall 9632

Fotografie: https://www.flickr.com/photos/josefm/albums
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von Sauerland »

Ich weiss nicht, evtl spuckt da pipewire hinein.
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Benutzeravatar
Geier0815
Guru
Guru
Beiträge: 4464
Registriert: 14. Jun 2004, 09:12

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von Geier0815 »

Schon mal mit einem anderen/älteren Kernel versucht?
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
diemoe
Newbie
Newbie
Beiträge: 28
Registriert: 20. Aug 2005, 12:34
Wohnort: Bamberg / Oberfranken
Kontaktdaten:

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von diemoe »

Hallo zusammen,

ein Kernel-Update als Ursache scheidet aus, habe den vorigen Kernel ausprobiert. Die Spur führt wohl eher in Richtung PipeWire - bin gerade dabei, mich etwas einzulesen. Es einfach zu deinstallieren bringt nichts, dann verschwinden auch Firefox und Chromium vom Rechner (wenn man keine Abhängigkeiten brechen will).
Bei der Suche im Netz findet man übrigens viele aktuelle Beiträge zum Thema PipeWire: die Entwicklung scheint sehr erfolgversprechend zu sein und rasch zu verlaufen.
PipeWire soll einmal Pulseaudio ersetzen - liest man hier: https://www.reddit.com/r/openSUSE/comme ... _pipewire/ oder hier: https://www.reddit.com/r/openSUSE/comme ... umbleweed/

Was das Ganze jetzt für Pro-Audio-Anwender, die ihre DAW bisher unter Linux mit Jack laufen lassen, bedeutet, werde ich vermutlich jetzt herausfinden (müssen). :igitt:

Danke für die Tipps erstmal, bis dann

Dietmar
Acer VERITON M680G
4x Intel Core i5 CPU 650 @ 3,2 GHz
NVIDIA GeForce GT 1030
RME Hammerfall 9632

Fotografie: https://www.flickr.com/photos/josefm/albums
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von Sauerland »

Es einfach zu deinstallieren bringt nichts, dann verschwinden auch Firefox und Chromium vom Rechner (wenn man keine Abhängigkeiten brechen will).
Kann man alles löschen bis auf:

Code: Alles auswählen

zypper se -si pipewire
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name              | Type  | Version      | Arch   | Repository
---+-------------------+-------+--------------+--------+-------------------------------------------------------------
i+ | libpipewire-0_3-0 | Paket | 0.3.24-4.3.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
diemoe
Newbie
Newbie
Beiträge: 28
Registriert: 20. Aug 2005, 12:34
Wohnort: Bamberg / Oberfranken
Kontaktdaten:

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von diemoe »

Hallo Sauerland,

habe Pipewire installiert und die Pulseaudio-Pakete entfernt, die Konfiguration mit

Code: Alles auswählen

systemctl --user enable --now pipewire.{service,socket} systemctl --user enable --now pipewire-pulse.{service,socket}
und

Code: Alles auswählen

systemctl reboot
geladen.
Die beiden Karten werden erkannt, aber nur die Audio-Ausgabe über die Grafikkarte an die Mini-Lautsprecher am Monitor funktioniert, die Hammerfall-Karte bleibt stumm - bei Audacity bewegt sich nichtmal der Abspielkopf.

Jetzt habe ich PipeWire bis auf die von Dir erwähnte libpipewire-0_3-0 entfernt und die Konfiguration mit

Code: Alles auswählen

systemctl --user disable --now pipewire.{socket,service}
zurückgesetzt, aber ohne Erfolg: Jack startet nicht.

Bei SUSE findet sich noch eine extra-Seite zum Thema PipeWire: https://en.opensuse.org/openSUSE:Pipewire, das werde ich nochmal studieren. Ich fürchte jedoch, dass ich zu 15.2 zurück muss, wenn ich wieder eine funtionierende Audioinstallation haben möchte. :-?

Dietmar
Acer VERITON M680G
4x Intel Core i5 CPU 650 @ 3,2 GHz
NVIDIA GeForce GT 1030
RME Hammerfall 9632

Fotografie: https://www.flickr.com/photos/josefm/albums
Benutzeravatar
HPF-84E
Member
Member
Beiträge: 61
Registriert: 8. Dez 2018, 20:45

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von HPF-84E »

Hi,

nachdem ich diesen Thread gelesen hatte war ich auch interessiert an diesen Thema und habe im Internet hier und da ein paar Sachen durchgelesen.
Die Dokumentation von Pipewire hängt wohl noch ein bisschen nach. Bei der Einsicht von ’"man pipewire" muss man sich auch von mapage zu manpage hangeln.

Ein Interessanter Forenbeitrag war dieser: https://debianforum.de/forum/viewtopic.php?t=179375
Nun gut es war schon spät gestern aber ich glaube verstanden zu haben das für die einzelnen Soundanwendungen entsprechende Schnittstellen zur Verfügung gestellt werden müssen. In deinen Fall mit Jack wäre es also

Code: Alles auswählen

pipewire-libjack-0_3
.
Eine Überprüfung meinerseits hat gezeigt das ich wahrscheinlich wie jeder anndere auch nur die Standardinstallation besitze. ->

Code: Alles auswählen

jag@localhost:~/Schreibtisch> zypper se pipewire
Repository 'Main Update Repository' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.
Repository 'Update Repository (Non-Oss)' ist veraltet. Sie können 'zypper refresh' als root ausführen, um es zu aktualisieren.
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name                      | Summary                                                                  | Type
--+---------------------------+--------------------------------------------------------------------------+-----------
  | gstreamer-plugin-pipewire | Gstreamer Plugin for PipeWire                                            | Paket
i | libpipewire-0_3-0         | A Multimedia Framework designed to be an audio and video server and more | Paket
i | pipewire                  | A Multimedia Framework designed to be an audio and video server and more | Paket
  | pipewire                  | A Multimedia Framework designed to be an audio and video server and more | Quellpaket
  | pipewire-devel            | Development Files For PipeWire, A Multimedia Framework                   | Paket
  | pipewire-doc              | PipeWire media server documentation                                      | Paket
  | pipewire-libjack-0_3      | PipeWire libjack replacement libraries                                   | Paket
  | pipewire-libpulse-0_3     | A Multimedia Framework designed to be an audio and video server and more | Paket
i | pipewire-modules          | Modules For PipeWire, A Multimedia Framework                             | Paket
i | pipewire-spa-plugins-0_2  | Plugins For PipeWire SPA                                                 | Paket
i | pipewire-spa-tools        | The PipeWire SPA Tools                                                   | Paket
i | pipewire-tools            | The PipeWire Tools                                                       | Paket
Vielleicht bin ich auch auf dem Holzweg aber eine Überprüfung der Dinge wäre bestimmt nicht Fehl am Platz.
diemoe
Newbie
Newbie
Beiträge: 28
Registriert: 20. Aug 2005, 12:34
Wohnort: Bamberg / Oberfranken
Kontaktdaten:

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von diemoe »

Hallo HPF-84E,

habe den genannten Thread kurz überflogen, vielen Dank für den Tipp. Mein momentaner Weg zurück zu einer funktionierenden Audio-Installation (Harrison Mixbus an JACK) sieht so aus (dem verregneten WE sei Dank): Neuinstallation von openSUSE 15.2 und Rückaktualisierung von Firefox auf 68.9.0esr (die letzte FF-Version, die ohne libpipewire-0_3-0 auskommt.

Jetzt ist das System 'pipewire-frei'. Morgen abend gehts dann vorauss. weiter mit Installation von Jack usf.; dann bin ich hoffentlich schlauer oder zumindest nicht dümmer als jetzt.


Freundliche Grüße,

Dietmar
Acer VERITON M680G
4x Intel Core i5 CPU 650 @ 3,2 GHz
NVIDIA GeForce GT 1030
RME Hammerfall 9632

Fotografie: https://www.flickr.com/photos/josefm/albums
diemoe
Newbie
Newbie
Beiträge: 28
Registriert: 20. Aug 2005, 12:34
Wohnort: Bamberg / Oberfranken
Kontaktdaten:

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von diemoe »

JACK startet wieder:

Bild

Jetzt muss ich erstmal mit einem veralteten Firefox leben, da die neueren FFs nicht mehr ohne libpipewire funktionieren (hab ich ausprobiert). Aber es erscheint hiermit erwiesen, dass Pipewire Jack killt. Und jetzt müssen alle, denen es wie mir geht, warten, bis alles auch mit Pipewire geht.

Bild

Grüße, Dietmar
Acer VERITON M680G
4x Intel Core i5 CPU 650 @ 3,2 GHz
NVIDIA GeForce GT 1030
RME Hammerfall 9632

Fotografie: https://www.flickr.com/photos/josefm/albums
Benutzeravatar
Geier0815
Guru
Guru
Beiträge: 4464
Registriert: 14. Jun 2004, 09:12

Re: openSUSE 15.3 - Jackd lässt sich nicht mehr starten [gelöst]

Beitrag von Geier0815 »

Wenn Du experimentieren möchtest, kannst Du mal versuchen neben pipewire auch pipewire-libjack zu verwenden. Dafür läßt Du jack und libjack weg. Damit sollten Anwendungen, die jack nutzen wollen, pipewire nutzen. Guck mal hier und dann auch hier.
Da ich debian verwende, keine externe Soundkarte habe und jack nur sehr selten verwende, kann ich allerdings keine Erfahrungswerte beitragen.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
diemoe
Newbie
Newbie
Beiträge: 28
Registriert: 20. Aug 2005, 12:34
Wohnort: Bamberg / Oberfranken
Kontaktdaten:

Re: [Gelöst] openSUSE 15.3 - Jackd lässt sich nicht mehr starten

Beitrag von diemoe »

Hallo geier0815,

danke für die Tipps. Werde ich bei Gelegenheit mal ausprobieren, aber jetzt bin ich erstmal froh, überhaupt weiter an meinem aktuellen Musikprojekt arbeiten zu können.


Grüße, Dietmar
Acer VERITON M680G
4x Intel Core i5 CPU 650 @ 3,2 GHz
NVIDIA GeForce GT 1030
RME Hammerfall 9632

Fotografie: https://www.flickr.com/photos/josefm/albums
Antworten