Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Fehler beim Aktualisieren [gelöst]

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
marbas13
Hacker
Hacker
Beiträge: 271
Registriert: 2. Nov 2007, 16:44

Fehler beim Aktualisieren [gelöst]

Beitrag von marbas13 »

Hallo,

ich bekomme vom Software-Update -Control den Fehler

Code: Alles auswählen

Signature verification for Repository https-download.opensuse.org-f3ed359d failed 
Ein

Code: Alles auswählen

zypper refresh
bringt keinen Fehler.

Hat jemand eine Idee was die Ursache sein könnte und wie ich es beheben kann?

Vielen Dank schon mal!
Zuletzt geändert von marbas13 am 25. Aug 2021, 21:35, insgesamt 1-mal geändert.
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5552
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Fehler beom Aktualisieren

Beitrag von tomm.fa »

Und wenn du noch die Ausgaben von

Code: Alles auswählen

cat /etc/*release
sowie

Code: Alles auswählen

zypper lr -d
angegeben hättest und wo oder wie das Update genau ausgeführt wurde…
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
marbas13
Hacker
Hacker
Beiträge: 271
Registriert: 2. Nov 2007, 16:44

Re: Fehler beom Aktualisieren

Beitrag von marbas13 »

Gerne, auch wenn ich nicht weiß, was ich da tue :ops:

Code: Alles auswählen

cat /etc/*release
NAME="openSUSE Tumbleweed"
# VERSION="20210807"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20210807"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20210807"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
DOCUMENTATION_URL="https://en.opensuse.org/Portal:Tumbleweed"
LOGO="distributor-logo"

Code: Alles auswählen

zypper lr -d
#  | Alias                                  | Name                            | Enabled   | GPG Check       | Refresh        | Priority  | Type   | URI                                                                                 | Serv->
---+----------------------------------------+---------------------------------+-----------+-----------------+----------------+-----------+--------+-------------------------------------------------------------------------------------+-------
 1 | download.opensuse.org-non-oss          | Haupt-Repository (NON-OSS)      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                               | 
 2 | download.opensuse.org-oss              | Haupt-Repository (OSS)          | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                   | 
 3 | download.opensuse.org-tumbleweed       | Hauptaktualisierungs-Repository | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/                                     | 
 4 | ftp.gwdg.de-Essentials                 | Packman Essentials Repository   | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/Essentials       | 
 5 | ftp.gwdg.de-openSUSE_Tumbleweed        | Packman Repository              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                 | 
 6 | https-download.opensuse.org-2661f83e   | openSUSE:Tumbleweed             | Nein      | ----            | ----           |   99      | NONE   | https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/dod/                | 
 7 | https-download.opensuse.org-287cc7db   | home:Herbster0815               | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://download.opensuse.org/repositories/home:/Herbster0815/openSUSE_Tumbleweed/  | 
 8 | https-download.opensuse.org-2db9bee1   | openSUSE:Tumbleweed             | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/           | 
 9 | https-download.opensuse.org-4109a726   | Emulators                       | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://download.opensuse.org/repositories/Emulators/openSUSE_Tumbleweed/           | 
10 | https-download.opensuse.org-9e3a1cba   | openSUSE:Factory                | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Factory/snapshot/              | 
11 | https-download.opensuse.org-f3ed359d   | home:laxity                     | Ja        | (r ) Ja         | Nein           |   99      | rpm-md | https://download.opensuse.org/repositories/home:/laxity/openSUSE_Tumbleweed/        | 
12 | openSUSE-20200428-0                    | openSUSE-20200428-0             | Nein      | ----            | ----           |   99      | rpm-md | hd:/?device=/dev/disk/by-id/usb-SanDisk_Cruzer_Blade_20044526000514B207B0-0:0-part2 | 
13 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository            | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                 | 
14 | packman.inode.at-openSUSE_Tumbleweed   | Packman Repository              | Nein      | ----            | ----           |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                   | 
15 | repo-debug                             | openSUSE-Tumbleweed-Debug       | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                             | 
16 | repo-source                            | openSUSE-Tumbleweed-Source      | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/ 
Ah prima, da findet sich die "Nummer" f3ed359d, die hab ich in YAST noch nie gesehen.
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Fehler beim Aktualisieren

Beitrag von Sauerland »

Wenn du schon Repos einbindest und aktivierst, solltest du auch den refresh einschalten.

Und zu der ganzen Repoliste halte ich diesmal meine Klappe.....
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 1040
Registriert: 19. Sep 2014, 18:22

Re: Fehler beom Aktualisieren

Beitrag von susejunky »

Hallo marbas13,
marbas13 hat geschrieben: 23. Aug 2021, 21:45Gerne, auch wenn ich nicht weiß, was ich da tue
wenn dem tatsächlich so ist, dann wäre es besser, wenn Du ausschließlich die Repositories 1,2,3 und 5 (ggf. noch 13) verwenden würdest (d.h. alle anderen Repositories in YaST deaktivieren oder - noch besser - löschen).

Viele Grüße

susejunky
marbas13
Hacker
Hacker
Beiträge: 271
Registriert: 2. Nov 2007, 16:44

Re: Fehler beim Aktualisieren

Beitrag von marbas13 »

Vielen Dank für die Hilfe.
1. Es ist nur ein Repo aktiv, das nicht refresht wird. Und das weil es eben die Probleme gemacht hat.
2. Die Aussage bezog sich auf die Hoffnung, dass mir jemand erklärt, was

Code: Alles auswählen

cat /etc/*release
macht.

Ich finde es toll, wenn man nicht man nur gesagt bekommt, tippe das ein und poste den Output sondern auch kurz erklärt wird, was man da tut.
Bei Befehlen schau ich mir die manpages an, ich weiß was cat macht, aber cat /etc/*release war mir neu. Hab ich aber jetzt nachgelesen.

Kann man wirklich ohne Packman Repo auskommen? :???:
Und laxity brachte ein cooler Retro-Emulator (VC-20, C64, ....) ins Spiel. :irre:
Sauerland
Guru
Guru
Beiträge: 4247
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Fehler beim Aktualisieren [gelöst]

Beitrag von Sauerland »

Code: Alles auswählen

cat /etc/*release
Ausgabe eines Dateiinhaltes der Datei: irgendwasrelease die sich im Verzeichnis /etc befindet.

Ist meist:

Code: Alles auswählen

ls -al /etc/ | grep -i release
lrwxrwxrwx 1 root  root       21  4. Jun 10:43 os-release -> ../usr/lib/os-release
In diesem Fall heisst die Datei os-release und das ist ein Link auf die Datei /usr/lib/os-release.

Code: Alles auswählen

../usr/lib/os-release
Lese: .. ein Verzeichnis höher gehen als das gerade angezeigte (/etc) und von dort nach /usr/lib/ wechseln und die Datei os-release benutzen. (relativer Pfad)
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5552
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Fehler beim Aktualisieren [gelöst]

Beitrag von tomm.fa »

Code: Alles auswählen

cat /etc/*release
zeigt dir den Inhalt der Datei os-release. Diese Datei beinhaltet unter anderem die Angaben welche Linux-Distribution verwendet wirdDa diese Datei aber auch je nach verwendeter Distribution anders benannt sein kann, z.B. debian-release, suse-release usw., ersetzt man den ersten Teil mit einem „Platzhalter“ (Wildcard), eine Datei release ist meist vorhanden.
Bei den meisten Distributionen ist es mittlerweile nur noch os-release.
Alternativ kann auch der Befehl

Code: Alles auswählen

lsb-release
mit der entsprechenden Option, zum Beispiel

Code: Alles auswählen

lsb-release -a
,
verwendet werden um zu erfahren welche Linux-Distribution verwendet wird.

(Ich habe schon wieder zu lange für den Beitrag gebraucht, da wahr jemand schneller und das mit /etc hat sich halt bei mir mit der Zeit eingebrannt.) :/
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
Benutzeravatar
susejunky
Moderator
Moderator
Beiträge: 1040
Registriert: 19. Sep 2014, 18:22

Re: Fehler beim Aktualisieren

Beitrag von susejunky »

Hallo marbas13,
marbas13 hat geschrieben: 25. Aug 2021, 21:35...Kann man wirklich ohne Packman Repo auskommen? :???:
nun, ich hatte empfohlen die Repositories 1,2,3 und 5 (ggf. noch 13) zu behalten:
marbas13 hat geschrieben: 23. Aug 2021, 21:45...

Code: Alles auswählen

zypper lr -d
#  | Alias                                  | Name                            | Enabled   | GPG Check       | Refresh        | Priority  | Type   | URI                                                                                 | Serv->
---+----------------------------------------+---------------------------------+-----------+-----------------+----------------+-----------+--------+-------------------------------------------------------------------------------------+-------
 1 | download.opensuse.org-non-oss          | Haupt-Repository (NON-OSS)      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                               | 
 2 | download.opensuse.org-oss              | Haupt-Repository (OSS)          | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                   | 
 3 | download.opensuse.org-tumbleweed       | Hauptaktualisierungs-Repository | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/                                     | 
...
 5 | ftp.gwdg.de-openSUSE_Tumbleweed        | Packman Repository              | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                 | 
...
13 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository            | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                 | 
...
und nur den Rest zu deaktivieren/löschen.
marbas13 hat geschrieben: 25. Aug 2021, 21:35... Und laxity brachte ein cooler Retro-Emulator (VC-20, C64, ....) ins Spiel. :irre:
Das dauerhafte Aktivieren von Factory und/oder HOME Repositories ist mit Risiken verbunden.

Wenn man sich sicher ist, dass man diese Risiken beherrscht (und/oder dem Besitzer eines HOME Repositories vollständig vertraut), dann kann man diese Respositories benutzen ...

Viele Grüße

susejunky
marbas13
Hacker
Hacker
Beiträge: 271
Registriert: 2. Nov 2007, 16:44

Re: Fehler beim Aktualisieren [gelöst]

Beitrag von marbas13 »

Vielen Dank für die Erklärungen, so habe ich wieder was gelernt!
Und ich habe dabei auch entdeckt, dass es ein Emulator Repo gibt:
https://download.opensuse.org/repositor ... umbleweed/
Antworten