Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Suse 15.3 erkennt zweiten Monitor nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 536
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

[gelöst] Suse 15.3 erkennt zweiten Monitor nicht

Beitrag von f.gruber »

Hallo,
nach dem Upgrade von openSuse Leap 15.2 auf 15.3 wird mein zweiter Monitor nicht mehr erkannt.

Auf der gleichen Maschine läuft auch Ubuntu 20.4 und es werden beide Monitore erkannt.

Ich hatte das Problem auch mit Suse 15.2 - da war der von Virtualbox installierte preemt-Kernel die Ursache. Siehe folgenden Thread: https://linux-club.de/forum/viewtopic.p ... 86#p793786

Nun bei Suse 15.3 sehe ich, dass allerlei verschiedene Kernel installiert worden sind ...

Ich verwende die proprietären nvidia Treiber. Mit dem nouveau Treiber hatte ich bei diesem Computer schon schlechte Erfahrungen.

Code: Alles auswählen

hwinfo --gfx
20: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.386]
  Unique ID: VCu0.s4mibcVaiLE
  Parent ID: 3hqH.dmRx1m7CVE5
  SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GK104 [GeForce GTX 770]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x1184 "GK104 [GeForce GTX 770]"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
  SubDevice: pci 0x2825 
  Revision: 0xa1
  Memory Range: 0xee000000-0xeeffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xe7ffffff (ro,non-prefetchable)
  Memory Range: 0xea000000-0xebffffff (ro,non-prefetchable)
  I/O Ports: 0xcc00-0xcc7f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 10 (no events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00001184sv00001462sd00002825bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #31 (PCI bridge)
Was kann ich bzw. soll ich nun machen?
Zuletzt geändert von f.gruber am 6. Aug 2021, 22:25, insgesamt 1-mal geändert.
Gruß
Ferdinand
Sauerland
Guru
Guru
Beiträge: 4252
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Suse 15.3 erkennt zweiten Monitor nicht

Beitrag von Sauerland »

Driver Info #0:
Driver Status: nouveau is not active
Driver Activation Cmd: "modprobe nouveau"
Kein Nvidia Treiber, kein nouveau Treiber.......
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 536
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Suse 15.3 erkennt zweiten Monitor nicht

Beitrag von f.gruber »

Hätte gedacht, dass mit der Installation des Nvidia Treibers dieser auch aktiviert wird.

Verstehe das anscheinend nicht richtig.
Gruß
Ferdinand
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 536
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Suse 15.3 erkennt zweiten Monitor nicht

Beitrag von f.gruber »

Ich habe auf der Konsole folgenden Befehl eingegeben

Code: Alles auswählen

modprobe nouveau
Plasma wird augenblicklich beendet und der Anmeldebilschirm erscheint auf beiden Monitoren. Jedoch kann ich mich dann nicht anmelden am Plasma Desktop, weil die Tastatur nicht reagiert ...
Zuletzt geändert von f.gruber am 6. Aug 2021, 22:25, insgesamt 1-mal geändert.
Gruß
Ferdinand
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 536
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

Re: Suse 15.3 erkennt zweiten Monitor nicht

Beitrag von f.gruber »

Nun habe ich mit YAST die NVIDIA Treiber neu installiert (Update). Beim nächsten Bootvorgang wurde daraufhin der zweite Monitor erkannt und aktiviert.

Damit ist das Problem gelöst, wie man auch in der Ausgabe von hwinfo --gfx sieht:

Code: Alles auswählen

  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia_drm is active
    Driver Activation Cmd: "modprobe nvidia_drm"
  Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
Gruß
Ferdinand
Antworten