Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kein Netzwerk nach dem Boot!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

Hallo, seit ein paar Tagen hab idh folgendes Problem! Nachdem ich in 15.3 gebootet habe, komme ich nichts ins Internet. Nach ein paar Minuten funktioniert es dann wieder. Ich kann auch per Ping den Router nicht erreichen. Kann das sein, das es mit einem Kernelupdate vor ein paar Tagen zusammenhängt?
Sauerland
Guru
Guru
Beiträge: 4242
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kein Netzwerk nach dem Boot!

Beitrag von Sauerland »

Poste mal:

Code: Alles auswählen

/sbin/lspci -nnk | grep -iA3 net
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5552
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Kein Netzwerk nach dem Boot!

Beitrag von tomm.fa »

Ebenso könnten die Ausgaben von

Code: Alles auswählen

uname -r

Code: Alles auswählen

systemctl show -p Id network.service
und als Root/su ausgeführt,

Code: Alles auswählen

cat /etc/sysconfig/network/ifcfg-[earw]*
hilfreich sein um dir zu helfen können.
Sensible Daten, wie Spaßwörter (Passwörter), sollten bei letzterer Ausgabe vor der Veröffentlichung hier unkenntlich gemacht werden.
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Re: Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

Kernel:

Code: Alles auswählen

Linux localhost 5.3.18-59.16-default #1 SMP Thu Jul 15 11:28:57 UTC 2021 (0b62bdb) x86_64 x86_64 x86_64 GNU/Linux
/sbin/lspci -nnk | grep -iA3 net

Code: Alles auswählen

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-V [8086:15b8]
        Subsystem: ASRock Incorporation Device [1849:15b8]
        Kernel driver in use: e1000e
        Kernel modules: e1000e
systemctl show -p Id network.service

Code: Alles auswählen

Id=wicked.service
cat /etc/sysconfig/network/ifcfg-[earw]*

Code: Alles auswählen

BOOTPROTO='dhcp'
STARTMODE='auto'
ZONE='public'
IPADDR=''
NETMASK=''
PREFIXLEN=''
BROADCAST=''
MTU='0'
NETWORK=''
REMOTE_IPADDR=''
BOOTPROTO='dhcp'
STARTMODE='auto'
ZONE='public'
IPADDR=''
NETMASK=''
PREFIXLEN=''
BROADCAST=''
ETHTOOL_OPTIONS=''
MTU=''
NAME=''
NETWORK=''
REMOTE_IPADDR=''
Sonst funktioniert alles, keine Probleme ist nur nach dem Booten, das sich das Netzwerk erst nach ein paar Minuten aktiviert.
Sauerland
Guru
Guru
Beiträge: 4242
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kein Netzwerk nach dem Boot!

Beitrag von Sauerland »

1. Hast du mal den Router neu gestartet?
2. Hast du es mal mit einer festen IP versucht?

Du könntest auch mal das Netzwerk beim booten mitstarten lassen, ist ein Punkt in der Konfiguration.
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Re: Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

!. ich hab den router mal neugestartet, werde ich beim nächsten boot sehen.
2. das ist aktiviert, netzwerk startet immer beim booten, wie gesagt ist seit 2 bis 3 tagen, ich weiß nicht, ob es mit dem letzten kernelupdtat zusammenhängt, das war auch zu der zeit.
spoensche
Moderator
Moderator
Beiträge: 7587
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Kein Netzwerk nach dem Boot!

Beitrag von spoensche »

Poste mal bitte die Ausgabe von

Code: Alles auswählen

ip a s
ip r s
cat /etc/resolv.conf
Verwendest du den Networkmanager?
Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5552
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Kein Netzwerk nach dem Boot!

Beitrag von tomm.fa »

spoensche hat geschrieben: 24. Jul 2021, 12:57Verwendest du den Networkmanager?
tomm.fa hat geschrieben: 24. Jul 2021, 10:05 Ebenso könnten die Ausgaben von
[…]

Code: Alles auswählen

systemctl show -p Id network.service
[…]
hilfreich sein um dir zu helfen können.
[…]
HarryMalaria hat geschrieben: 24. Jul 2021, 11:44 systemctl show -p Id network.service

Code: Alles auswählen

Id=wicked.service
sollte deine Frage beantworten. ;)
Linupedia - Wiki des Linux-Club.
Rechner 1: openSUSE Leap 15.3 mit KDE/Plasma, Kernel 5.14.*
Rechner 2: openSUSE Leap 15.3 mit Fluxbox 1.3.7 und Kernel 5.13.*
Rechner 3: openSUSE Leap 15.3, GNOME 3.34 mit Wayland
Rechner 4: PineTab mit Arch Linux
HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Re: Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

spoensche hat geschrieben: 24. Jul 2021, 12:57 Poste mal bitte die Ausgabe von

Code: Alles auswählen


ip r s
cat /etc/resolv.conf
Verwendest du den Networkmanager?
Nein, ich verwende keinen networkmanager!

ip a s

Code: Alles auswählen

: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 70:85:c2:30:9b:13 brd ff:ff:ff:ff:ff:ff
    altname enp0s31f6
    inet 192.168.2.101/24 brd 192.168.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 2003:dc:3724:41f1:b807:1637:a24f:bdff/64 scope global temporary dynamic 
       valid_lft 14397sec preferred_lft 1797sec
    inet6 2003:dc:3724:41f1:7285:c2ff:fe30:9b13/64 scope global dynamic mngtmpaddr 
       valid_lft 14397sec preferred_lft 1797sec
    inet6 fe80::7285:c2ff:fe30:9b13/64 scope link 
       valid_lft forever preferred_lft forever
3: virbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 52:54:00:22:f7:43 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe22:f743/64 scope link 
       valid_lft forever preferred_lft forever
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 02:42:58:be:e3:79 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever
6: vnet1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master virbr0 state UNKNOWN group default qlen 1000
    link/ether fe:54:00:f0:d1:cb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc54:ff:fef0:d1cb/64 scope link 
       valid_lft forever preferred_lft forever
ip r s

Code: Alles auswählen

efault via 192.168.2.1 dev eth0 proto dhcp 
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown 
192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.101 
192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1 

Code: Alles auswählen

cat /etc/resolv.conf
### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
### autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
abgdf
Guru
Guru
Beiträge: 3411
Registriert: 13. Apr 2004, 21:15

Re: Kein Netzwerk nach dem Boot!

Beitrag von abgdf »

Kein Netzwerk nach dem Boot!
Die letzten Worte des Fischers. ;)
Sauerland
Guru
Guru
Beiträge: 4242
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kein Netzwerk nach dem Boot!

Beitrag von Sauerland »

Also wenn ich dich recht verstehe, funktioniert ein:

Code: Alles auswählen

ping -c2 8.8.8.8
direkt nach dem booten nicht?

Oder funktioniert nur ein

Code: Alles auswählen

ping -c2 google.com
nicht?
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
spoensche
Moderator
Moderator
Beiträge: 7587
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Kein Netzwerk nach dem Boot!

Beitrag von spoensche »

In der /etc/resolv.conf ist kein DNS-Server eingetragen und daher funktioniert DNS nicht. Prüfe mal deine Konfiguration im Wick.
HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Re: Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

so, ich war einige zeit im urlaub, das problem ist immer noch vorhanden. hab mir auch eine fritzbox ausgeliehen mit aktueller firmware, das selbe problem.
systemctl network status zeigt mir immer an:

Active: active (exited) since

Ich hab das Netzwerk in yast konfiguriert: hier ist wicked dienst aktiviert und und dynamische adresse dhcp. dhcp 4 und 6. und bei hostname/dns: ist: ja, irgendwelche aktiviert. es gibt noch eth0 und br0 (virt-manager) zur auswahl. aber das war immer so. in der /etc/resolv.conf ist als nameserver die router ip eingetragen:

Code: Alles auswählen

### /etc/resolv.conf is a symlink to /var/run/netconfig/resolv.conf
### autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
### Call "netconfig update -f" to force adjusting of /etc/resolv.conf.
nameserver fe80::1%eth0
nameserver 192.168.2.1
Sauerland
Guru
Guru
Beiträge: 4242
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kein Netzwerk nach dem Boot!

Beitrag von Sauerland »

Und was sagen die beiden pings?

Sowie:

Code: Alles auswählen

cat /etc/sysconfig/network/ifcfg-eth0

Code: Alles auswählen

cat /etc/sysconfig/network/ifroute-eth0
Hast du es mal mit deaktiviertem IPV6 versucht?
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Re: Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

Ich hab das mal aktiviert:
systemctl enable systemd-resolved und dann
systemctl start systemd-resolved,
und dann den pc ganz heruntergefahren, nach dem neustart ging das netzwerk sofort, ich werde das mal beobachten. woran das gelegen hat, keine ahnung, es lief ja mit der konfiguration seit einigen jahren, hatte früher mit dem networkmanager probleme, drum hab ich die andere konfiguration mit wicked gewählt, hatte auch nie probleme, auch nicht mit den virtuellen maschinen, lief alles prima, bis neulich. mit dem systemctl hab ich irgendwo gelesen, dass die resolv.conf darüber laufen soll.
spoensche
Moderator
Moderator
Beiträge: 7587
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Kein Netzwerk nach dem Boot!

Beitrag von spoensche »

Das Netzwerk funktionierte auch vorher schon. Nur DNS nicht.
HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Re: Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

Und das funktioniert immer noch nicht richtig, mal gehts mal nicht. Hängt das mit der datei: resolv.config zusammen? Wenn ja, was kann die Ursache sein? Ich hab gelesen, man soll den networkmanager nehmen, da ist aber das Problem, dass ich noch ein virtuelles netzwerk habe: eth0 und br0. in yast werden beide aufgelistet. br0 wird im netzwerkmanager nicht aufgelistet und ich kann es auch nicht hinzufügen. Was ist die Lösung soll man die dns server in yast manuelle eintragen und wenn ja welche? Seit ich mit den neztwerkeinstellungen experimentiert habe erscheint in der konsole plötzlich folgendes format: name@32stellige zahl, kann man das wieder rückgängig machen?
spoensche
Moderator
Moderator
Beiträge: 7587
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Kein Netzwerk nach dem Boot!

Beitrag von spoensche »

Poste mal die Ausgabe von

Code: Alles auswählen

ip a s
ip r s
Was hattest du den mit der Bridge vor?

Die 32 stellige Zahl ist der Hostname des Systems.

Du musst dich entscheiden, ob du den NetworkManager oder Yast für die Netzwerkkonfiguration verwenden willst.
HarryMalaria
Hacker
Hacker
Beiträge: 274
Registriert: 17. Nov 2005, 18:24

Re: Kein Netzwerk nach dem Boot!

Beitrag von HarryMalaria »

Das hab ich! Ich nutze jetzt den Netzwerkmanager, das Problem gelegentlich immer noch auf, immer nach dem "aufwachen" aus dem standby, nachdem boot eigentlich nicht mehr. Es muß an den DNS liegen, denn das Netzwerk ist aktiv.

Code: Alles auswählen

● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor pr>
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Wed 2021-09-15 07:44:25 CEST; 11h ago
       Docs: man:NetworkManager(8)
   Main PID: 1231 (NetworkManager)
      Tasks: 4 (limit: 4915)
     CGroup: /system.slice/NetworkManager.service
             ├─ 1231 /usr/sbin/NetworkManager --no-daemon
             └─21743 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /run/NetworkM
Also die Probleme treten sowohl mit den wicked-dienst als auch mit den networkmanager auf. nach eingabe des befhels: netconfig update -f
läuft es wieder. eingestllt ist dhcp das seit jahren, könnte es auch sein, dass die probleme von der telekom stammen und mit meinem system gar nix zu tun haben? oder könnte es was bringen, feste dns server einzutragen? welche soll man dann nehmen, von der telekom finde ich keine, viele meinen man sollte die von google nehmen (ist das sinnvoll)?
Sauerland
Guru
Guru
Beiträge: 4242
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Kein Netzwerk nach dem Boot!

Beitrag von Sauerland »

So sieht meine /etc/resolv.conf aus:

Code: Alles auswählen

cat /etc/resolv.conf 
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
#search linux

# Cloudflare and APNIC
nameserver 1.1.1.1
# quad9
nameserver 9.9.9.9
# Router
nameserver 192.168.0.254
Desktop: OpenSUSE Leap 15.3, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.3, Intel-Skylake, Kernel 5.3
Antworten